• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

08/Mar - Superboot ERD79 -> GRI40 - rooting the Nexus One

301 posts in this topic

Posted

Thanks so much for this!

0

Share this post


Link to post
Share on other sites

Posted (edited)

thank's good job

Edited by vorach
0

Share this post


Link to post
Share on other sites

Posted

But this superboot work on Nexus ONE Vodafone with the recent build FRF91?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi Paul! Thanks for your good job, well done!

I successfully rooted for my Google Nexus One (Froyo 2.2 FRF91) by using your Superboot for FRF91.

Yes, it is required to unlock the bootloader first before I install superboot my Nexus.

This is what I did:

1. Download the superboot, because the files from mediafire link is corrupted everytime I download.

2. Extract all files in the superboot zip file to C:\1.1-FRF91-nexusone-superboot

3. Open the windows command prompt so I can see any messages shown when superbooting

4. Point the directory to C:\1.1-FRF91-nexusone-superboot

5. Connect the phone to USB and boot the Nexus One to bootloader mode (hold down the trackball and power button)

In this step, I do a simple check that the phone is detected by the fastboot by starting another command prompt like the following:

C:\>cd android-sdk-windows

C:\android-sdk-windows>cd tools

C:\android-sdk-windows\tools>fastboot devices

HT017******* fastboot

C:\android-sdk-windows\tools>

6. Back to the command prompt, type: install-superboot-windows.bat like below:

C:\1.1-FRF91-nexusone-superboot>install-superboot-windows.bat

and then the following messages shown:

C:\1.1-FRF91-nexusone-superboot>fastboot-windows.exe boot boot.FRF91.superboot.img

downloading 'boot.img'... OKAY

booting... OKAY

C:\1.1-FRF91-nexusone-superboot>

7. My phone reboot automatically, and I noticed that it's installs Superuser Permissions application.

8. Done.

Edited by Paul
0

Share this post


Link to post
Share on other sites

Posted

Before you install any ROM, you should always check the md5sum to make sure the file was not corrupted. You can download an application for windows to check it here. http://www.pc-tools.net/win32/md5sums/

Mac here. http://llmd5sum.software.informer.com/ (I'm a pc so I haven't tried this one. Shop around if you need to.)

Make sure you have the correct radio for Froyo based ROMs.

You can get the correct radio and a vanilla FRF91 and root.zip here (all of these have to be flashed in a specific order without rebooting so read the steps carefully) http://tinyurl.com/2bdl58w.

Fastboot may be available soon, but I don't think that has anything to do with what is going on with your phone. It sounds like a bad .zip.

If you lose your recovery after you reboot, you will have to repeat the steps to to flash it in fastboot.

Keep trying, reading, and learning! Post your experiences (success or failures) for all to read and learn from. Good luck and have fun with it. :(

Just wanted to update everyone . . . . THIS WORKED PERFECTLY!!! THANK YOU! Now that the image installed correctly, my audio issue is also resolved. So now I have a rooted Nexus One with Froyo. Now that just rocks!!! Thank you!!!

Here is what I did:

1.) I downloaded three files as mentioned above:

- signed-passion-FRF91-from-FRF85B.db99fdf1.zip

- update-nexusone-FRF91-stock-noradio-signed.zip

- update-nexusone-FRF91-cm-addons-signed.zip

2.) I booted my phone to recovery mode, and went to the [uSB-MS toggle] menu

3.) I copied the first file to the root of the SD Card, and renamed it to: update.zip

4.) I then went to the [Flash zip from sdcard] menu . . . and let it complete the install (this first file produced some errors which I ignored)

5.) I then went to the [uSB-MS toggle] menu

6.) I copied the second file to the root of the SD Card, and renamed it to: update.zip

7.) Repeat step 4 (no errors)

8.) I then went to the [uSB-MS toggle] menu

9.) I copied the third file (add-ons) to the SD Card, and renamed it to update.zip

10.) Repeat step 4 (no errors)

11.) I rebooted my phone, and all is well, on the right version.

Thanks again!!!

0

Share this post


Link to post
Share on other sites

Posted (edited)

-DELETED-

Edited by McHale
0

Share this post


Link to post
Share on other sites

Posted

I'm having the same problem as a few of you had with the file being 600 bytes. When i try and unzip it i get an error. How do you get around or fix this? I'm on frf91 and have completed unlocking the bootloader. Thanks for the help in advance.

0

Share this post


Link to post
Share on other sites

Posted

I downloaded the mirror link for FRF91 (the first one appears to be broken) but I got a different MD5.. I got:

6dc34c3e94f52fdea73683d7f6d557eb instead of

de97d4f6c3b724d8cde015a986f99b95

Anyone know what's going on? Is something wrong with the FRF91 version?

0

Share this post


Link to post
Share on other sites

Posted

Hi, I'm not sure if this questions belongs here or somewhere else on the forum - so feel free to move it (I'm new here).

I have N1 FRF50 ... A while back when Froyo 2.2 came out I looked into rooting, did it using superboot I believe, and then uploaded a custom ROM for 2.2. Everything has worked great.

Now since mid-July I've been being harassed by my N1 to install an OTA update. I tell it to restart and install, and it only restarts to the superboot screen (Black with green text). So I tell it to reboot and then I'm usually good for a few days until the update pops up again. I'd like to install this official update, is there anyway to do this? I don't really have a need to have the phone rooted (I don't think). I do not run any special apps, at one point I needed to use an AT&T sim in it, so I unlocked.

Any help would be appreciated. If I try to install any "official" updates from online using superboot I get an error saying the signature is incorrect or failed.

Thanks.

0

Share this post


Link to post
Share on other sites

Posted

I have N1 FR91, I tried to root with superboot but I am stuck at

Downloading 'boot.img'...

Any idea how to fix it?

0

Share this post


Link to post
Share on other sites

Posted (edited)

EDIT:

Superboot for FRF91 (MediaFire Pro) ---> File corrupted... I can't extract..

(ROMraid / CoBlitz) Not load the page... (I just downloaded on this link, but just take me about 5 minutes to load the page)

Thanks a lotttttttt :) in installing all right now...

Edited by Minsu
0

Share this post


Link to post
Share on other sites

Posted

Hello!

I'm in desperate need of FRF91's Superboot, but the mediafire link is corrupted (shows only 692 B as it was mentioned) and the other one just redirects to modaco.com. Could anyone upload FRF91's superboot or post a working download link?

Thanks in advance. :huh:

0

Share this post


Link to post
Share on other sites

Posted

Any plans for a FRG33 superboot?

0

Share this post


Link to post
Share on other sites

Posted

Any plans for a FRG33 superboot?

yes please make superboot for FRG33

thx

0

Share this post


Link to post
Share on other sites

Posted

Hello

the Superboot for FRF91 dont work with sLCD Nexus > Black screen :lol:

0

Share this post


Link to post
Share on other sites

Posted

+1 for Suberboot FRG33

0

Share this post


Link to post
Share on other sites

Posted

The question is :

"Is Superboot technically possible on Android 2.2.1 releases ?"

I'd love it for FRG83 !

0

Share this post


Link to post
Share on other sites

Posted (edited)

+1 for Suberboot FRG83

Edited by changwufei
0

Share this post


Link to post
Share on other sites

Posted

+1 for Suberboot FRG83

0

Share this post


Link to post
Share on other sites

Posted

Updated with FRG83 Superboot / Insecure boots. :P

P

0

Share this post


Link to post
Share on other sites

Posted

Updated with FRG83 Superboot / Insecure boots. :P

P

Works like a charm. Thank you.

0

Share this post


Link to post
Share on other sites

Posted

just hanging on waiting for device, any help

0

Share this post


Link to post
Share on other sites

Posted

Hello

the Superboot for FRF91 dont work with sLCD Nexus > Black screen :P

I just rooted two phones, and got also black screen after the phone booted. Then, I

just physically removed battery and restarted, and it all worked smoothly and the

phones are now rooted. So, do not panic if you see a black screen.

0

Share this post


Link to post
Share on other sites

Posted

just hanging on waiting for device, any help

Try unlocking the bootlader following the instructions in the other pinned topic,

this helps to ger rid of these "ERROR: could not clear input pipe; result -536870163< waiting for device >"

messages.

0

Share this post


Link to post
Share on other sites

Posted

I can't download the file FRF91,it only has 692b.is any

hthing wrong?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.