• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

How to get into Recovery Mode?

24 posts in this topic

Posted

I have tried everything I could after using the Lickonn recovery image, and I still cannot get into Recovery Mode. Quickboot just cycles through as well, without going into it.

If I hold the hardware keys down, I get 2 or 3 quick vibrations, and an icon ( I think it's a speaker phone or message one) flashing on the top of the unit, but nothing on the screen. I have searched the threads, and found nothing I can use to assist.

Can someone help?

0

Share this post


Link to post
Share on other sites

Posted (edited)

search first, go to adb with your phone normally on:

adb reboot recovery

but try flash recovery again

to enter fastboot:

adb reboot bootloader

Edited by chunga
0

Share this post


Link to post
Share on other sites

Posted

The first command causes the unit to display "Acer" then the green androids. Then it shuts down, and does this again. Ending in the home screen.

The second one enters fastboot. I am trying to flash Lick's custom ROM. I have root access.

0

Share this post


Link to post
Share on other sites

Posted

The first command causes the unit to display "Acer" then the green androids. Then it shuts down, and does this again. Ending in the home screen.

The second one enters fastboot. I am trying to flash Lick's custom ROM. I have root access.

try to flash recovery again

fastboot -i 0x0502 flash recovery recovery.img

0

Share this post


Link to post
Share on other sites

Posted

Ok, flashed and verified. I don't have the recovery image on the Liquid, it's on my PC.

Still nothing. It repeats the steps I outlined above.

Aren't rookies fun? :)

0

Share this post


Link to post
Share on other sites

Posted (edited)

Ok, flashed and verified. I don't have the recovery image on the Liquid, it's on my PC.

Still nothing. It repeats the steps I outlined above.

Aren't rookies fun? :)

the image stays on your computer

you need fastboot for your Operating system to write the recovery.img

place the recovery.img on the folder of Paul's superboot that you use to root the device

enter that folder and with your phone normally ON type

adb-windows.exe reboot bootloader

it will reboot fastboot , then type:

fastboot-windows.exe -i 0x0502 flash recovery recovery.img

fastboot-windows.exe -i 0x0502 reboot

it will reboot normally, to enter recovery:

adb-windows.exe reboot recovery

it will reboot in recovery mode

Edited by chunga
0

Share this post


Link to post
Share on other sites

Posted

Followed step by step. Exactly as you've written it.

The unit repeats the same thing. Acer, then Android. Black. Acer, then Android...then home screen.

I'm stumped. Completely.

0

Share this post


Link to post
Share on other sites

Posted

do you have the right recovery? try redownload

0

Share this post


Link to post
Share on other sites

Posted

Followed step by step. Exactly as you've written it.

The unit repeats the same thing. Acer, then Android. Black. Acer, then Android...then home screen.

I'm stumped. Completely.

you must flash a rom with the acer downloader... then you may try, if not it wont work

0

Share this post


Link to post
Share on other sites

Posted

Also QuickBoot App allows you to go to recovery

0

Share this post


Link to post
Share on other sites

Posted

Same problem here.

Tried the exact steps to Re-flash recovery and enter recovery mode. No luck.

Also tried to Flash using Acer Download Tool - Just gives me "Not in OS mode error"...

Piter1225, Could you please let us know how to boot into recovery using QuickBoot?

0

Share this post


Link to post
Share on other sites

Posted

Same problem here.

Tried the exact steps to Re-flash recovery and enter recovery mode. No luck.

Also tried to Flash using Acer Download Tool - Just gives me "Not in OS mode error"...

Piter1225, Could you please let us know how to boot into recovery using QuickBoot?

if you would actually USE the app first then you wouldnt need to ask.

0

Share this post


Link to post
Share on other sites

Posted

if you would actually USE the app first then you wouldnt need to ask.

Thanks very much you were very helpful.

I just did not know this is an Application you download from AndroidMarket. I assumed it should be part of SDK as adb.

Well that did not work either. Boot Acer > Android then reboots again Acer > Android > Home Screen.

0

Share this post


Link to post
Share on other sites

Posted

Thanks very much you were very helpful.

I just did not know this is an Application you download from AndroidMarket. I assumed it should be part of SDK as adb.

Well that did not work either. Boot Acer > Android then reboots again Acer > Android > Home Screen.

then you might not even have a recovery flashed.

Can you get into bootloader mode? if you can try and reflash the recovery

0

Share this post


Link to post
Share on other sites

Posted

If you rooted your Liquid with the anternate "root" V1.1, it could happen like that. Since that's exactly what I go through.

I fixed it by update to 2.005 ROM, then update again the second time, but have task manager kill acer downloader as soon as fastboot screen comes up. Then I rooted the phone with the normal "root" v1.4 and loaded the lickonn recovery image. And it worked perfectly from there.

0

Share this post


Link to post
Share on other sites

Posted

then you might not even have a recovery flashed.

Can you get into bootloader mode? if you can try and reflash the recovery

Hi Goa200,

1. Yes I can get into bootloader.

2. I have tried to re-flash recovery several times. The bootloader returns this.

D:\android\tools>fastboot -i 0x0502 flash recovery recovery.img

< waiting for device >

sending 'recovery' (4876 KB)... OKAY

writing 'recovery'... OKAY

on the handset it even says Verified... OKAY

I suppose that means that recovery is flashed? I have tried Lickonn recovery. Maybe I should try something else?

I fixed it by update to 2.005 ROM, then update again the second time, but have task manager kill acer downloader as soon as fastboot screen comes up. Then I rooted the phone with the normal "root" v1.4 and loaded the lickonn recovery image. And it worked perfectly from there.

How do I update to 2.005 ROM ? I cannot get to recovery mode and the Acer Download Tool gives me "The phone is not in OS mode error". ?

BTW - i have rooted it using SuperBoot from Paul http://android.modaco.com/content/acer-liq...ing-the-liquid/

Thanks for help.

0

Share this post


Link to post
Share on other sites

Posted

I suppose that means that recovery is flashed? I have tried Lickonn recovery. Maybe I should try something else?

How do I update to 2.005 ROM ? I cannot get to recovery mode and the Acer Download Tool gives me "The phone is not in OS mode error". ?

BTW - i have rooted it using SuperBoot from Paul http://android.modaco.com/content/acer-liq...ing-the-liquid/

Thanks for help.

boot your phone normally, when it is in the launcher the Acer Download tool you recognize the phone and allow you to download the ROM onto the phone.

0

Share this post


Link to post
Share on other sites

Posted

boot your phone normally, when it is in the launcher the Acer Download tool you recognize the phone and allow you to download the ROM onto the phone.

I turn off the phone, connect USB, Start Acer Download tool, Start Up the phone, click on Start in the Download Tool. And it loads into home screen. The Downloader jsut gives me this error:

[Lock] Security... has exception : System.InvaliOperationException: The port is closed at System.IO/Ports/Write

Still trying to figure it out.

0

Share this post


Link to post
Share on other sites

Posted

Same issue with Umka.

If I cannot get into the Recovery mode, how can I use Nandroid to backup my original data inside phone before upgrading firmware?

My firmware is Acer_Liquid_1.001.04_AAP_FET.

Thanks.

0

Share this post


Link to post
Share on other sites

Posted

If I cannot get into the Recovery mode, how can I use Nandroid to backup my original data inside phone before upgrading firmware?

I would even upgrade without doing backup and reinstall/resetup everything from scratch. just cannot upgrade without getting into recovery mode. :) B)

0

Share this post


Link to post
Share on other sites

Posted

For details on flashing, please refer to the post on using Acer Download Tool, but one thing you must know is that you will have to install Acer's driver from their support site, it comes in 32 and 64 bit version to suit whichever OS that you are currently using now.

0

Share this post


Link to post
Share on other sites

Posted

Hello Zycamaniac,

Could you please post a link to the post on using Acer Download Tool ?

I have tried everything I could think of, but as I told before, Acer Download Tool gives errors either "Phone not in OS mode" or "Server Connection failed". Of course I am using USB driver from Acer;s support website.

thank you

0

Share this post


Link to post
Share on other sites

Posted

No idea why but today Acer Download Tool finally worked and I was able to flash the ROM and Recovery image. Now looking for a nice new ROM to flash. B) :D

However, no idea how this was solved. Probably problem with drivers not setup by windows properly. The only thing I can think of to suggest to other having similar problems - is to reinstall ACER drivers from their support website several times until it works :)

Thanks everyone for advise.

0

Share this post


Link to post
Share on other sites

Posted (edited)

....Simple answer

Lincoins recovery image only works with factory EMEA devices.. OR after you use Acer tools to completely flash your system to an EMEA rom..

something to do with the Acer tool actually flashing an restricted/unpatitioned part of the rom that contains the config for booting and hardware key combinations

(i dont actually belive that, seeing as i havent seen any proof.. we would have modded it already..)

the recovery images will not work on factory AAP, CSL or FET devices untill you do a full flash or similar process

this was the case with both of my liquids ( a CSL and a FET )

Its not documented anywhere, but its been said a couple of places, Google it..

And Acer's tool is a bit sketchy with the googles dev drivers its only picks up the device 2/10 trys

Using acers drivers will increase your chances alot.

Edited by Nova2.1
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.