• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Huawei U8100

12 posts in this topic

Posted (edited)

Hi guys.

Wind released the U8100 last week.

Even though they're close cousins, I'm not certain the Pulse Mini ROMs will work for it, since it may be opperating at a different band frequency (full AWS) to run on Wind's network. I was able to root the device using Paul's SuperBoot though, and install a launcher to replace Huawei's Canvas.

I am, however, getting problems removing stock apps. Though I have root, I can't seem to get permissions to ADB anything as a superuser. I get errors like "permission denied" and "adb root cannot run as root in production builds". So I'm pretty much lost, since the most tampering I've ever done with any computer stuff is trying making a texture pack for Morrowind.

Any ideas what could be going wrong on my end? I'm looking to do just a few simple (well not for me, heh) things, like removing:

Browser.apk .odex

EmotionClockWidget.apk .odex

FrenchPack.apk .odex

Launcher.apk .odex

HWTheme_Entertainment.apk .odex

HWTheme_Social.apk .odex

HWTheme_Work.apk .odex

MyBookmarks.apk .odex

MyCalendar.apk .odex

MyEvents.apk .odex

MyMemo.apk .odex

MyVideo.apk .odex

servosearch.apk .odex

PhotoAblumWidget.apk .odex (Note the spelling error)

TouchPal.apk .odex

WeatherClock.apk .odex

StaticPhotoFrame.apk.odex

And replacing the stock Music application with Eliot Stocker's Music Mod 1.6.

Any idea why I can't run ADB commands like mount, in order to remove these apps? Any help could be appreciated. I've also extracted what was in the phone and uploaded Huawei's updata file to a faster host, if anyone wants to take a look.

I'm going to try to find out why I can't use adb to its fullest, despite having installed the full SDK, installed drivers, and rooted my phone.

Edit: Haha, I must have been doing something wrong in the early hours of the morning, because adb works. I guess a decent sleep helps! Removed Huawei's locked apps, and the phone seems to perform better. I'm just glad ServoSearch is gone.

Edited by Lyphen
0

Share this post


Link to post
Share on other sites

Posted

try use titanium beckup, it's work with my huawei u8100. amonra rec 1.6 pulsemini work on this model, but move app to sd didn't work.

0

Share this post


Link to post
Share on other sites

Posted

Lyphen,

Being a new Android user, can you provide the "Complete Idiot's Guide" on how you rooted the Wind Mobile Canada U8100 please ?

I read that I need it rooted to run the wifi tether, so down the rabbit hole I go...

Thanks in advance !!

0

Share this post


Link to post
Share on other sites

Posted

I'm pretty sure that Wi-Fi tether comes standard through a Huawei program with the U8100. When you plug it in through your USB port, it should mount itself as a CD drive and offer the installation of a "Android Wireless Internet". You can use that application to tether.

As for rooting, I used the Superboot for the Pulse Mini, which worked for me.

0

Share this post


Link to post
Share on other sites

Posted

I'm pretty sure that Wi-Fi tether comes standard through a Huawei program with the U8100. When you plug it in through your USB port, it should mount itself as a CD drive and offer the installation of a "Android Wireless Internet". You can use that application to tether.

As for rooting, I used the Superboot for the Pulse Mini, which worked for me.

Thanks for the info Lyphen. I think the "Android Wireless Internet" allows your PC to use the U8100 as a wireless modem, Wi-Fi tether turns the U8100 into a local Wi Fi access point (aka MyFi, etc) so that other devices can use it's internet via Wi Fi, devices such as the iPad

0

Share this post


Link to post
Share on other sites

Posted

I also understood the U8100 could be configured as a Wireless Access Point. I've got USB tethering working fine (using it right now), but I'd like to get the WAP feature working. I am also with Wind Canada. Any ideas? Can anyone confirm this feature exists? I am just going on press releases I've seen on the web.

Thanks for the info Lyphen. I think the "Android Wireless Internet" allows your PC to use the U8100 as a wireless modem, Wi-Fi tether turns the U8100 into a local Wi Fi access point (aka MyFi, etc) so that other devices can use it's internet via Wi Fi, devices such as the iPad
0

Share this post


Link to post
Share on other sites

Posted (edited)

Hello Lyphen,

Can you explain how you did it in more detail? I could activate the bootloader and run the script, but it would hang on <waiting for device>. As I understand it from the other thread, it seems I am missing drivers (and indeed, Windows is complaining about missing drivers). What driver did you use? I could not find a driver on Huawei's website. What operating system are you using (I have access to Vista and XP)?

Thanks in advance

Update: I found the drivers. For those interested, you get the driver by plugging the phone in the computer normally. Navigate to the phone in My Computer, and right click and open. Superboot worked fine, thanks.

Edited by hpp3
0

Share this post


Link to post
Share on other sites

Posted

I'm pretty sure that Wi-Fi tether comes standard through a Huawei program with the U8100. When you plug it in through your USB port, it should mount itself as a CD drive and offer the installation of a "Android Wireless Internet". You can use that application to tether.

As for rooting, I used the Superboot for the Pulse Mini, which worked for me.

!!!!!!!! H E L P !!!!!!!!!!!! I have the u8100 and tried the "superboot for the pulse". Plugged in the phone, ran superboot-windows.exe. Everything looked good, turned off phone, turned it on, now it is hung on the Wind home screen. If I take the battery out and attempt the bootloader mode, I get an "Unpacking: message at the top and a !update failed. HELP :S

0

Share this post


Link to post
Share on other sites

Posted

Yeah, I'm not sure what to do at that point. The lock in Wind screen is intentional - probably took 5 minutes for the phone to boot after superbooting for the first time. I'd try downloding the updata.app file and force updating the phone to stock again (volume up) - it'll take whatever is in the dload folder of the SDcard cand apply it.

0

Share this post


Link to post
Share on other sites

Posted

@Lyphen - Are you sure you have root access? I did the same thing to my Wind U8100. I have the Superuser Icon but when I double click, nothing happens.

Also, someone mentioned there is an App on CD that will turn it into a WiFi hotspot. I cannot find it. Any help appreciated.

There is a bug in Android where the OS does not respect the WiFi sleep policy if your MAC does not start with 00. My u8100 MAC is one that starts with 4C; so it does not obey my commands of not sleeping. I need this because @ my home, I am Wind Away and I want to receive emails, etc. I'm hoping with root access, I will be able to fix it somehow.

0

Share this post


Link to post
Share on other sites

Posted

I just got this phone and I'd like to speed up the touch responce as well. I'm trying to get it into boot mode, but I'm not having any luck. What buttons did you use to do that, and how long did it take you.

Thanks in advance..

0

Share this post


Link to post
Share on other sites

Posted (edited)

For anyone looking for a safe way to temporarily root your U8100, here is what I did:

1) Install Terminal Emulator from market, and VISIONary via this site:

http://android.modac...one-click-root/

2) Run VISIONary and do temporary root. Be careful not to do permanent root function. The remount /system read-write option also works.

3) Open Terminal Emulator and type 'su'. Now do what you like as root!

Root access doesn't work in adb yet for some reason. However using terminal on the phone is good enough for me. I specifically disabled unwanted bloatware:

pm disable com.servo.search

pm disable com.facebook.katana

etc.

I have *not* tried VISIONary's permanent root option, so you are on your own. Always have a copy of your current kernel software available to reload in case of problems.

Edited by georgie3
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.