liquid_it

SMSC Strangeness..

2 posts in this topic

DICLAIMER: I'M NOT RESPONSIBLE IF YOU SCREW SOMETHING ON YOUR PHONE, THIS IS JUST HOW I SOLVED MY PROBLEM!

Today, playing around with Info menu ( *#*#4636#*#* ), somehow I reset my SMSC number. For those who don't know what it is, this is the number used by your phone to forward sms, and is specific for every carrier.

My carrier, which is Vodafone Italy, has +393492000200, as you can find out on any "normal" phone with a Vodafone IT sim in :) .

Btw, in "phone info" submenu you can set ("update") or show up ("refresh") current smsc configuration. Oddly enough, this 2 buttons have the same label in italian translation ("aggiorna"), so if you have the same problem with other translations, please remember that left button will update your smsc number, while right button just show it up.

When I deleted the working config, I was not able to send any text, as expected, but I couldn't even set the right number back, God knows why! All I got in the number field was an "update error" message. I tried several number, wrote them with and without international prefix, but nothing worked.

Finally I got a friend's sim, who is on Vodafone too, and rebooted my phone with the sim this in. First of all I inspected which was the configured smsc number, wrote it down, rebooted with my sim in, updated my sim configuration without getting any error, and got back a sms-capable phone! :P

If you are asking which the strangeness was, well, the right number for the Vodafone Italy smsc is:

0791934329002000

which is definitely NOT a Vodafone phone number, it is not a phone number at all!!!

Can you please report your configured smsc number and your carrier, just to check if there's something wrong with my Galaxy???

Thanks in advance!

Edited by liquid_it
0

Share this post


Link to post
Share on other sites
DICLAIMER: I'M NOT RESPONSIBLE IF YOU SCREW SOMETHING ON YOUR PHONE, THIS IS JUST HOW I SOLVED MY PROBLEM!

Today, playing around with Info menu ( *#*#4636#*#* ), somehow I reset my SMSC number. For those who don't know what it is, this is the number used by your phone to forward sms, and is specific for every carrier.

My carrier, which is Vodafone Italy, has +393492000200, as you can find out on any "normal" phone with a Vodafone IT sim in :) .

Btw, in "phone info" submenu you can set ("update") or show up ("refresh") current smsc configuration. Oddly enough, this 2 buttons have the same label in italian translation ("aggiorna"), so if you have the same problem with other translations, please remember that left button will update your smsc number, while right button just show it up.

When I deleted the working config, I was not able to send any text, as expected, but I couldn't even set the right number back, God knows why! All I got in the number field was an "update error" message. I tried several number, wrote them with and without international prefix, but nothing worked.

Finally I got a friend's sim, who is on Vodafone too, and rebooted my phone with the sim this in. First of all I inspected which was the configured smsc number, wrote it down, rebooted with my sim in, updated my sim configuration without getting any error, and got back a sms-capable phone! :lol:

If you are asking which the strangeness was, well, the right number for the Vodafone Italy smsc is:

0791934329002000

which is definitely NOT a Vodafone phone number, it is not a phone number at all!!!

Can you please report your configured smsc number and your carrier, just to check if there's something wrong with my Galaxy???

Thanks in advance!

Hi.. When you say you had to "REBOOT" your phone, you mean just turn it off and on again or do a hard reset to factory settings with the SIM in it? I can't send SMS with my new Motorola DEFY, and with that info menu code you provided, I discovered SMSC field is empty. I guess all I have to do is input the correct number for my carrier, however it doesn't matter what number I enter there, it won't stay, I do not know how to save it.

I would really appreciate some advise.

Thank you!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.