• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

How to tune a FM radio station

208 posts in this topic

Posted

Sorry, I hate writing posts like this but could someone please upload the fm_hcitool file? I have stock 2.2 and I have searched this thread (promise!) and can't find it. I can see a "speaker" file, but not the normal one.

Thanks!

I need also.

0

Share this post


Link to post
Share on other sites

Posted

Is thers a way to change the volume?

0

Share this post


Link to post
Share on other sites

Posted

I need also.

Hi,

You just need to change the file in this thread 'fm_hcitool_speaker' to 'fm_hcitool' and put it in /system/bin/ and this worked for me.

Will it ever work to output to headphones? And change the volume?

Really nice job with this app! Appreciate a lot!

0

Share this post


Link to post
Share on other sites

Posted

OK, got this from Steve's ROM update zip files.

Use this in your bin folder for radio with headphones etc as it should be!

fm_hcitool.rar

0

Share this post


Link to post
Share on other sites

Posted

OK, got this from Steve's ROM update zip files.

Use this in your bin folder for radio with headphones etc as it should be!

Thanks, that worked like a charm. Now we just need to change the volume and this app would be perfect!

0

Share this post


Link to post
Share on other sites

Posted

Thanks, that worked like a charm. Now we just need to change the volume and this app would be perfect!

Well, there is also an additional small wish list:

  • Turn the radio off when a phone call connects
  • RDS (especially for mrmrmr!)
  • volume working
  • etc

0

Share this post


Link to post
Share on other sites

Posted (edited)

I'm trying to use Astro to copy the fm_hcitool file from my SDcard to \system\bin problem is when i click edit > copy in Astro it says "Copying fm_hcitool" but when i go to \system\bin and hit Edit, Paste is grayed out... can't seem to copy files there. What am i doing wrong?

I'm on DJ_steve's StreakDroid 1.6 and i'm rooted... i can copy the file within the SD card so i know Astro works...

Edit:

Also... downloaded the .rar and put it on the SD card. When i tried using StreakDroid Recovery to apply a .zip it never showed up in the list, so i changed the name on my PC to .zip and moved it over to the SD card again... When i tried to install, it was there this time but came back

"Can't open /sdcard/_android2.2/Streak_Radio.zip

(bad)

"install Aborted"

Downloaded and tried to install again, same thing...

Edit 2:

Ok apparently it installed anyway... I used Astro to browse my SD card and try to install the apk... got there and used the app manager to launch it and it said it was already installed... went to Apps and there it was...

*****Also i didn't need the fm_hcitool in /system/bin for the Radio to work, not sure but as stated i'm on StreakDroid 1.6*****

Its great to have the Radio working and all, but the volume is so LOUD... I can't even use it. LOL.

Be waiting for an update to this great app if XsCode gets the time... volume control would be GREAT!

Edited by dzuest
0

Share this post


Link to post
Share on other sites

Posted

I'm trying to use Astro to copy the fm_hcitool file from my SDcard to \system\bin problem is when i click edit > copy in Astro it says "Copying fm_hcitool" but when i go to \system\bin and hit Edit, Paste is grayed out... can't seem to copy files there. What am i doing wrong?

I'm on DJ_steve's StreakDroid 1.6 and i'm rooted... i can copy the file within the SD card so i know Astro works...

Edit:

Also... downloaded the .rar and put it on the SD card. When i tried using StreakDroid Recovery to apply a .zip it never showed up in the list, so i changed the name on my PC to .zip and moved it over to the SD card again... When i tried to install, it was there this time but came back

"Can't open /sdcard/_android2.2/Streak_Radio.zip

(bad)

"install Aborted"

Downloaded and tried to install again, same thing...

Edit 2:

Ok apparently it installed anyway... I used Astro to browse my SD card and try to install the apk... got there and used the app manager to launch it and it said it was already installed... went to Apps and there it was...

*****Also i didn't need the fm_hcitool in /system/bin for the Radio to work, not sure but as stated i'm on StreakDroid 1.6*****

Its great to have the Radio working and all, but the volume is so LOUD... I can't even use it. LOL.

Be waiting for an update to this great app if XsCode gets the time... volume control would be GREAT!

I find the radio comes in loud, but as soon as I hit the volume buttons a bit it goes down to an acceptable level..

0

Share this post


Link to post
Share on other sites

Posted

I find the radio comes in loud, but as soon as I hit the volume buttons a bit it goes down to an acceptable level..

I get the exact same behavior. Unfortunately something would cause it to pop back up to being super loud after a while (made me jump in my seat!).

However, leaving the volume up (and using a headphone that has volume control on it) seems to help, but then if a phone call comes, or I try to open another player (power amp), the volume comes out the loud speakers. Its really inconvenient... (same behavior for phone calls, it seems to cause my volume on my head set to get shot as well.)

Workarounds I got right now would be to switch from silent to normal mode and back with the headphones unplugged. It seems to resort the volume issues.

Using streakdroid 1.6.

0

Share this post


Link to post
Share on other sites

Posted

@paullong

thank's for the fm hcitool ;) :)

now it work's on my streak, stock rom 2.2/318 with root

0

Share this post


Link to post
Share on other sites

Posted

There are no guys, just me....

I have a full time job, writing little apps is just a hobby....I have made some strides in controlling the radio via HCI rather than fm_hcitool but I have no idea of when this will be releasable..

Care to share? I've got the source you posted on here and am having a play

0

Share this post


Link to post
Share on other sites

Posted

I didn't pan out as it still needs root... also i've been very busy recently so no work has been done on it.. but if you run hcidump with adb shell and mess with the radio app you will see patterns.... ;)

Care to share? I've got the source you posted on here and am having a play
0

Share this post


Link to post
Share on other sites

Posted

I didn't pan out as it still needs root... also i've been very busy recently so no work has been done on it.. but if you run hcidump with adb shell and mess with the radio app you will see patterns.... :)

Cheers!

Have you put the latest source anywhere (with the preset buttons)? The one in this thread doesn't have 'em.

Will give the hcidump a go though :lol:

0

Share this post


Link to post
Share on other sites

Posted

Post 82 has the source with the presets I think

Cheers!

Have you put the latest source anywhere (with the preset buttons)? The one in this thread doesn't have 'em.

Will give the hcidump a go though :lol:

0

Share this post


Link to post
Share on other sites

Posted

But... How can i root my streak first?

I have the 2.2 1921 EU version.

Thanks,

Albert.

0

Share this post


Link to post
Share on other sites

Posted

Search for "Super One Click"

But... How can i root my streak first?

I have the 2.2 1921 EU version.

Thanks,

Albert.

0

Share this post


Link to post
Share on other sites

Posted (edited)

But... How can i root my streak first?

I have the 2.2 1921 EU version.

Thanks,

Albert.

there are a few threads regarding rooting the streak. and there is a search function on these forums. Not to be rude, but if you are starting from scratch, its best you read the correct threads, that already have many of the answers to the questions you may ask. Just as a hint though, 'superoneclick'.

and http://forum.xda-developers.com/showthread.php?t=805112

Edited by stoney1973
0

Share this post


Link to post
Share on other sites

Posted

there are a few threads regarding rooting the streak. and there is a search function on these forums. Not to be rude, but if you are starting from scratch, its best you read the correct threads, that already have many of the answers to the questions you may ask. Just as a hint though, 'superoneclick'.

and http://forum.xda-developers.com/showthread.php?t=805112

Sorry,

few weeks before I ty to use it and it couldn´t work. Now I try agian and... I cannont again.

Thaks for all,

Albert.

0

Share this post


Link to post
Share on other sites

Posted

Then you are doing something incorrectly.

Sorry,

few weeks before I ty to use it and it couldn´t work. Now I try agian and... I cannont again.

Thaks for all,

Albert.

0

Share this post


Link to post
Share on other sites

Posted

@paullong

thank's for the fm hcitool ;) ;)

now it work's on my streak, stock rom 2.2/318 with root

Dirtytiger

Maybe I'm brave but dum...

I've rooted my stock 2.2, also 318, put the fm_hcitool in /system/bin, and installed the .apk....

I'm using headphones (as supplied), have the volume full up, the gui is working (it changes frequency), re-booted...

BUT no radio. :D

Help please

0

Share this post


Link to post
Share on other sites

Posted

Dirtytiger

Maybe I'm brave but dum...

I've rooted my stock 2.2, also 318, put the fm_hcitool in /system/bin, and installed the .apk....

I'm using headphones (as supplied), have the volume full up, the gui is working (it changes frequency), re-booted...

BUT no radio. ;)

Help please

Download the Android terminal emulator and try running the commands in there - you'll get verbose feedback as to whether it's working or not.

0

Share this post


Link to post
Share on other sites

Posted

Download the Android terminal emulator and try running the commands in there - you'll get verbose feedback as to whether it's working or not.

Braver, but still dumb - what do I do with the TE?

0

Share this post


Link to post
Share on other sites

Posted

Braver, but still dumb - what do I do with the TE?

Type

su
and hit enter, then say yes to allowing root access Then type
fm_hcitool 1
to turn it on. If it errors, you know something is wrong.
fm_hcitool 0

will turn it off

0

Share this post


Link to post
Share on other sites

Posted

Type

su
and hit enter, then say yes to allowing root access Then type
fm_hcitool 1
to turn it on. If it errors, you know something is wrong.
fm_hcitool 0

will turn it off

Ah-Ha

'fm_hcitool not found'

Further searching shows no sign of bcom_fm either.

Have repeatedly tried copying using various file managers: some won't ("read only"), some will ("copied") but not one actual copy made in the bin.

What am I missing ?

And many thanks for your prompt responses - now I MUST get it to work!!!

0

Share this post


Link to post
Share on other sites

Posted

Ah-Ha

'fm_hcitool not found'

Further searching shows no sign of bcom_fm either.

Have repeatedly tried copying using various file managers: some won't ("read only"), some will ("copied") but not one actual copy made in the bin.

What am I missing ?

And many thanks for your prompt responses - now I MUST get it to work!!!

I'm on DJ Steve's 1.5.1 at the moment and fm_hcitool is in /system/xbin rather than /system/bin - may be worth giving that a go.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.