• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Access Point Name (APN) settings for UK mobile network providers.

66 posts in this topic

Posted (edited)

Seeing as a few people seem to be having problems with APN settings :-

To input a new APN click "MENU" on front of phone, click "settings" on the bottom right of the screen

click "Wireless and Networks" at the top of the screen, Click "Mobile Networks" at the bottom of the screen,

Click "Access Point Names" at the bottom of the screen. Click "MENU" on the front of the phone and select "New APN" on the screen,

Enter details of network settings below and then click "MENU" on the front of phone and "Save"

Hope this helps some people

Regards to all Billyhl.

Settings taken from unlocked-dongle website to help people out.

Whichever mobile network you use, try setting the APN to 'Dynamic' initially and use the appropriate username \ password below. If it doesn't work change to 'Static' and manually enter the APN setting.

All settings are case sensitive!

Vodafone

APN (contract): internet

APN (PAYG): pp.vodafone.co.uk

Username: web

Password: web

Orange

APN: orangeinternet

Username: leave blank

Password: leave blank

O2

APN (contract): mobile.o2.co.uk

APN (PAYG): m-bb.o2.co.uk

Username: web

Password: web

T-Mobile

APN: general.t-mobile.uk

Username: leave blank

Password: leave blank

Three

APN: 3internet

Username: leave blank

Password: leave blank

Tesco Mobile (uses the O2 network)

APN: prepay.tesco-mobile.com

Username: tescowap

Password: password

Virgin Mobile (uses the T-Mobile network)

APN: goto.virginmobile.uk

Username: user

Password: leave blank

BT Mobile (uses the Vodafone network)

APN: btmobile2.bt.com

Username: bt

Password: bt

ASDA Mobile (uses the Vodafone network)

APN: asdamobiles.co.uk

Username: web

Password: web

Edited by billyhl
1

Share this post


Link to post
Share on other sites

Posted

O2 incorrect as MMS not sending.

0

Share this post


Link to post
Share on other sites

Posted (edited)

These are the Access Point Name settings not the Multimedia Message Settings.

Cant you get the O2 mms settings by sending a text to 2020 i believe?? could be wrong so someone please confirm

Regards to all Billyhl.

Edited by billyhl
0

Share this post


Link to post
Share on other sites

Posted

This is what I've been using on my san francisco with my iphone pay monthly contract sim (not tested mms settings)

O2 UK

Cellular Data

APN: idata.o2.co.uk

Username: vertigo

Password: password

MMS

APN: idata.o2.co.uk

Username: vertigo

Password: password

MMSC: http://mmsc.mms.o2.co.uk:8002

MMS Proxy: 193.113.200.195:8080

MMS Max Message Size: 307200

MMS UA Prof URL: (blank)

source: my iphone's settings & link

0

Share this post


Link to post
Share on other sites

Posted

These are the Access Point Name settings not the Multimedia Message Settings.

Cant you get the O2 mms settings by sending a text to 2020 i believe?? could be wrong so someone please confirm

Regards to all Billyhl.

Ah!!! ok m8, no can't get settings that way, o2 can't send them to android phones.

0

Share this post


Link to post
Share on other sites

Posted

I'm going to Hong Kong tomorrow, and thought I'd look on appbrain for a tube map or anything HK related, and came across HK APN. Apparently it's an app to configure APNs for all the HK networks. I don't suppose there a similar app for the UK. I did have a look, but couldn't see anything, although there's one for Italy too.

0

Share this post


Link to post
Share on other sites

Posted

I'm going to Hong Kong tomorrow, and thought I'd look on appbrain for a tube map or anything HK related, and came across HK APN. Apparently it's an app to configure APNs for all the HK networks. I don't suppose there a similar app for the UK. I did have a look, but couldn't see anything, although there's one for Italy too.

I guess what you could do is install "APN Backup & Restore" from the market then download this zip and extract it to your SD card.ApnBackupRestore.zip

It's a copy of the custom APN config I'm using on my phone and should have APN information for most networks. If not it can be edited quite simply.

Once extracted open the app and click restore.

1

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks fibble, have just done that. 400+ APN's!! Last time I swapped my Virgin sim back to the Orange sim, and back to Virgin again, the phone seem to have lost the APN settings for Virgin. I had copied the Virgin settings to a notepad file on my SD card, so that I could enter them on my return to the UK. Your way seems to be a lot easier!! It did seem to remember the settings for Orange though. From my limited knowledge, this is something to do with the apf.conf?

Edited by synet
0

Share this post


Link to post
Share on other sites

Posted

heres a good site i came across:

http://www.filesaveas.com/gprs.html

0

Share this post


Link to post
Share on other sites

Posted

I guess what you could do is install "APN Backup & Restore" from the market then download this zip and extract it to your SD card.ApnBackupRestore.zip

It's a copy of the custom APN config I'm using on my phone and should have APN information for most networks. If not it can be edited quite simply.

Once extracted open the app and click restore.

Been trying to get my mms working for the past few days now with no luck. Just done exactly what you said and selected vodafone uk in my APN settings and voila...now working.

I cant thank you enough! :)

0

Share this post


Link to post
Share on other sites

Posted

Seeing as a few people seem to be having problems with APN settings :-

To input a new APN click "MENU" on front of phone, click "settings" on the bottom right of the screen

click "Wireless and Networks" at the top of the screen, Click "Mobile Networks" at the bottom of the screen,

Click "Access Point Names" at the bottom of the screen. Click "MENU" on the front of the phone and select "New APN" on the screen,

Enter details of network settings below and then click "MENU" on the front of phone and "Save"

Hope this helps some people

Regards to all Billyhl.

Settings taken from unlocked-dongle website to help people out.

Whichever mobile network you use, try setting the APN to 'Dynamic' initially and use the appropriate username \ password below. If it doesn't work change to 'Static' and manually enter the APN setting.

All settings are case sensitive!

Vodafone

APN (contract): internet

APN (PAYG): pp.vodafone.co.uk

Username: web

Password: web

Orange

APN: orangeinternet

Username: leave blank

Password: leave blank

O2

APN (contract): mobile.o2.co.uk

APN (PAYG): m-bb.o2.co.uk

Username: web

Password: web

T-Mobile

APN: general.t-mobile.uk

Username: leave blank

Password: leave blank

Three

APN: 3internet

Username: leave blank

Password: leave blank

Tesco Mobile (uses the O2 network)

APN: prepay.tesco-mobile.com

Username: tescowap

Password: password

Virgin Mobile (uses the T-Mobile network)

APN: goto.virginmobile.uk

Username: user

Password: leave blank

BT Mobile (uses the Vodafone network)

APN: btmobile2.bt.com

Username: bt

Password: bt

ASDA Mobile (uses the Vodafone network)

APN: asdamobiles.co.uk

Username: web

Password: web

Hi,

Newbee here..love the phone but..

Currently running r2 which is fine ..apart from Problem is…Cant get any internet via my Vodafone monthly account.

- was previously using iPhone 2g with this card Ok. I have only changed settings as above

Vodafone

APN (contract): internet

APN (PAYG): pp.vodafone.co.uk

Username: web

Password: web

But can only get the triangle in top left no connection available. Do i need to ask Vodafone to allow this APN?

Vodafone tec are non too helpful and passed me around not even knowing what I meant when I asked them to confirm what APN settings were required as obviously ZTE is not one of their handset types so therefore no need to know!

So, in order to get settings, am I correct in thinking that Paul’s r3 will put the correct settings in for me if I flash to that? Or am I just illustrating my “newbee-ness” ?

all replies welcome, perhaps an idiots guide?.

thanks

0

Share this post


Link to post
Share on other sites

Posted

I've just ordered a couple of the £10 a month rolling Tesco SIM's. So will the APN be of the pre-pay or contract kind.

Cheers, Will.

0

Share this post


Link to post
Share on other sites

Posted

Hi there. My Internet connection is fine over wifi. As I'm on voda contract, I have created the apn as per above. When I'm out and about to pick up a voda 3G do I just need to ensure my "data connection" is activated? Do I also need to activate "data roaming" as well please? Cheers!

0

Share this post


Link to post
Share on other sites

Posted

The APN setting for Vodafone UK can be found here: http://forum.vodafone.co.uk/topic/56720-ht...-vodafone-live/ it covers mobile internet and MMS.

Name: Vodafone UK

APN: wap.vodafone.co.uk

Username: wap

Password: wap

MMSC: http://mms.vodafone.co.uk/servlets/mms

MMS Proxy: 212.183.137.12

MMS Port: 8799

MCC: 234

MNC: 15

APN Type: *

You'll need to turn your phone off then on again for MMS to kick in.

0

Share this post


Link to post
Share on other sites

Posted

All i do is drag this into what ever rom i'm usings etc folder.

apns-conf.xml

0

Share this post


Link to post
Share on other sites

Posted

All i do is drag this into what ever rom i'm usings etc folder.

apns-conf.xml

I'm running R3 and it doesn't list any APNs. I've sold my san fran and I want to add O2 APN settings but it's not letting me save any settings. Anyone come across this?

0

Share this post


Link to post
Share on other sites

Posted (edited)

These are the Tesco PAYG setting as given to me and tested working from TescoMobile as laid out on the phone, Tesco use the O2 network

Name: Tesco WAP

APN: prepay.tesco-mobile.com

Proxy: 193.113.200.195

Port: 8080

Username: tescowap

Password: password

Server: - not set

MMSC: http://mmsc.mms.o2.co.uk:8080

MMS Proxy: 193.113.200.195

MMS Port: 8080

MCC: 234

MNC: 10

Authentication type: PAP

APN Type: default (you type default)

Edited by merlin617
0

Share this post


Link to post
Share on other sites

Posted

any advice on the full and proper settings for ASDA PAYG?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi guys

I'm bit confused by these APN settings and was wondering if anyone can help. I'm on o2 (pay monthly)

I've got the data settings working fine - but when people send me business cards - its saying that it can't download the data (as it's coming in as an mms).

going into APN - it seems that you cna only have one selected at a time - is that right - so do i need to switch apn every time i get an mms (no biggie as doesnt happen that often)

also - anyone know the correct settings for mms - as it doesnt seem to be working for me still

any help much appreciated

Edited by vik1
0

Share this post


Link to post
Share on other sites

Posted

Hi guys

I'm bit confused by these APN settings and was wondering if anyone can help. I'm on o2 (pay monthly)

I've got the data settings working fine - but when people send me business cards - its saying that it can't download the data (as it's coming in as an mms).

going into APN - it seems that you cna only have one selected at a time - is that right - so do i need to switch apn every time i get an mms (no biggie as doesnt happen that often)

also - anyone know the correct settings for mms - as it doesnt seem to be working for me still

any help much appreciated

Vic1 have you tried my MMS settings above they look as though they are straight from O2

0

Share this post


Link to post
Share on other sites

Posted (edited)

Asda web and mms apn's. (This was a problem post but is now updated to correct details for future users)

for the web

apn: asdamobiles.co.uk

proxy:

port:

username: web

password: web

server:

mmsc:

mms proxy:

mms port:

mcc: 234

mnc: 15

authentication type:

apn type: default

for mms

apn: asdamobiles.co.uk

proxy:

port:

username: wap

password: wap

server:

mmsc: http://mms.asdamobiles.co.uk/servlets/mms

mms proxy: 212.183.137.012

mms port: 8799

mcc: 234

mnc: 15

authentication type:

apn type: mms

Edited by targetbsp
0

Share this post


Link to post
Share on other sites

Posted

Aside from the fact my mms doesn't work... and considering you can only select one apn... am I meant to just be using the wap/mms one? My first thoughts upon getting the phone is 'i want to play with the internet. ah! web. that sounds right'. Should I just be using the wap username rather than web? I'm not sure what the difference is.

0

Share this post


Link to post
Share on other sites

Posted (edited)

The ones on the T-Mobile site are shown as:

1. Press the Menu key

2. Tap on Settings

3. Tap on Wireless & Networks to select.

4. Scroll down and tap on Mobile networks

5. Tap on Access Point Names to select.

6. Press the Menu key

7. Tap on New APN

8. Tap Name then enter T-Mobile MMS select OK

9. Tap APN then enter general.t-mobile.uk select OK

10. Tap Username then enter t-mobile select OK

11. Tap Password then enter tm select OK

12. Tap MMSC then enter http://mmsc.t-mobile.co.uk:8002 select OK

13. Tap MMS proxy then enter 149.254.201.135 select OK

14. Tap MMS port then enter 8080 select OK

15. Tap APN type then enter mms select OK

16. Press the Menu key

17. Tap Save

18. Press the Home key

1. Press the Menu key

2. Tap on Settings

3. Tap on Wireless & Networks to select.

4. Scroll down and tap on Mobile networks

5. Tap on Access Point Names to select.

6. Press the Menu key

7. Tap on New APN

8. Tap Name then enter T-Mobile Internet select OK

9. Tap APN then enter general.t-mobile.uk select OK

10. Tap Username then enter t-mobile select OK

11. Tap Password then enter tm select OK

12. Tap APN type then enter default select OK

13. Press the Menu key

14. Tap Save

15. Press the Home Key

But the MMS doesnt seem to work :rolleyes:

EDIT:

MMS seems to work 100% fine now so it must have just been having a bad day when i tried it first time around.

Edited by MrBelter
0

Share this post


Link to post
Share on other sites

Posted

Fixed my mms! I made 2 changes (based on some vodafone settings) Not sure which fixed it but one did. I changed the apn type from default to mms and I put a leading zero before the 12 in 212.183.137.12. Asdas setup page doesn't have that but the vodafone forum post suggested it was required.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.