• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

ZTE Blade/San Francisco Unofficial Froyo Build

539 posts in this topic

Posted

im concentrating more on bugs for the moment trying to iron out as much as possible and pass anything i find to the main developer (ie the chmod 04755 /system/bin/su thing). Prettiness can come later. What i would love is a kernel :D :P

0

Share this post


Link to post
Share on other sites

Posted

Sure, no pb... I am using the Alpha in the meantime (mostly fo the automatic SIM unlock, btw isn't this great ?!?)

0

Share this post


Link to post
Share on other sites

Posted

Just trying this out. Looking great from my first tests. Not got any problems with the calendar that I've noticed... Apart from now it manages to sync with exchange, I get duplicates because I sync'd my exchange calendar with my google calendar. So, I'm getting both versions of an event... lol. Fortunately, also, I haven't had any probs with the calendar force closing. Does this only happen when trying to do certain things?!

0

Share this post


Link to post
Share on other sites

Posted

I haven't seen any mention of voice dialing. Is it present in this build? If so has anyone tried it?

0

Share this post


Link to post
Share on other sites

Posted

I had a bit of an discovery on the 'Dialer' bug today (shown using most of the battery). So, I decided to try to freeze all three 'Dialer' entries with Titanium Backup and then to use a third-party dialer (Dialer One) to see if I could get the battery usage (reporting) to drop. The interesting thing I learned was when 'Dialer Storage 2.2' was frozen, I completely lost the phone/radio function. I also got frequent FC messages on com.android.phone. So, this all leads me to believe the native 'Dialer' is, in fact, integrated with the phone/radio and perhaps it is frequently (too frequently?) polling the mobile towers which is taking a hit on our batteries and causing the reporting of such high numbers under battery usage. Not a fix/workaround, but maybe that will help someone develop a fix/around? Perhaps there is a way to hack the /system/app/Phone.apk and change some setting where it's not so active?

I still have not figured out why some mp3s I have play (music I've ripped) and other don't (low-fi lectures with no DRM or anything - they play fine in 2.1).

0

Share this post


Link to post
Share on other sites

Posted

I had a bit of an discovery on the 'Dialer' bug today (shown using most of the battery). So, I decided to try to freeze all three 'Dialer' entries with Titanium Backup and then to use a third-party dialer (Dialer One) to see if I could get the battery usage (reporting) to drop. The interesting thing I learned was when 'Dialer Storage 2.2' was frozen, I completely lost the phone/radio function. I also got frequent FC messages on com.android.phone. So, this all leads me to believe the native 'Dialer' is, in fact, integrated with the phone/radio and perhaps it is frequently (too frequently?) polling the mobile towers which is taking a hit on our batteries and causing the reporting of such high numbers under battery usage. Not a fix/workaround, but maybe that will help someone develop a fix/around? Perhaps there is a way to hack the /system/app/Phone.apk and change some setting where it's not so active?

I still have not figured out why some mp3s I have play (music I've ripped) and other don't (low-fi lectures with no DRM or anything - they play fine in 2.1).

re mp3's

I found it was just the wma's that didnt work........codec?

0

Share this post


Link to post
Share on other sites

Posted

I had a bit of an discovery on the 'Dialer' bug today (shown using most of the battery). So, I decided to try to freeze all three 'Dialer' entries with Titanium Backup and then to use a third-party dialer (Dialer One) to see if I could get the battery usage (reporting) to drop. The interesting thing I learned was when 'Dialer Storage 2.2' was frozen, I completely lost the phone/radio function. I also got frequent FC messages on com.android.phone. So, this all leads me to believe the native 'Dialer' is, in fact, integrated with the phone/radio and perhaps it is frequently (too frequently?) polling the mobile towers which is taking a hit on our batteries and causing the reporting of such high numbers under battery usage. Not a fix/workaround, but maybe that will help someone develop a fix/around? Perhaps there is a way to hack the /system/app/Phone.apk and change some setting where it's not so active?

I still have not figured out why some mp3s I have play (music I've ripped) and other don't (low-fi lectures with no DRM or anything - they play fine in 2.1).

there's a bunch of xml files in the apk for configuration but I can't work out how to decompile/recompile them

0

Share this post


Link to post
Share on other sites

Posted

ive got my froyo build to work fine, im having no problems AT ALL with the marketplace?, the only isssues I have are that the music player won't play some songs for whatever reason?, and the GPS won't find my location.. but apart from that the phone is loads faster than what it was on 2.1. Thanks for the release looking forward to future builds. Keep up the good work! :P

0

Share this post


Link to post
Share on other sites

Posted

The interesting thing I learned was when 'Dialer Storage 2.2' was frozen, I completely lost the phone/radio function. I also got frequent FC messages on com.android.phone.

If I understand correctly the dialler storage 2.2 process makes copies of (or possibly archives?), SMS/MMS data and possibly other phone related info to one or more sqlite databases under /data/data/com.android.providers.telephony/databases

If that process is busy can you see an increase in the size of the mmssms.db file in that location?

(I don't have this ROM loaded so can't check myself).

0

Share this post


Link to post
Share on other sites

Posted (edited)

Right I have done both a full clockwork backup and a full titanium backup before installing 2.2

Obviously by following the installation instructions I am going to be wiping all data etc from the phone before applying the 2.2 update

So I was wondering if getting the phone back to how I have it now with all the data apps etc as it is will just be as simple as running a clockwork restore/titanium backup restore, if not can someone give me an idiots guide

Failing that if I want to go back to 2.1 (how i have it now, Pauls r4) will i just need to run that update.zip through clockwork and then perform clockwork restore to return phone to the current state

Edited by johntrfc
0

Share this post


Link to post
Share on other sites

Posted

big thanks to everyone working on this and all the helpfull comments im a noob and for some reason i cant get anything google to sync wont let me in market but the thing is ive flashed my psp ive had my phone on every rom going lol all worked compliments to everyone ive been reading every thread and everyone seems to be running market flawlessly now and ive tried it all clearing cache partition and privacy even formatted sd card setting tried to sign on 3g 1st i hope this is in the right thread could anyone else comment if having this problem please p.s sorry about the english :P

0

Share this post


Link to post
Share on other sites

Posted

Does anyone know why bluetooth HID doesn't work in this 2.2 rom? It works in pretty much every other Froyo rom out there...

0

Share this post


Link to post
Share on other sites

Posted

If I understand correctly the dialler storage 2.2 process makes copies of (or possibly archives?), SMS/MMS data and possibly other phone related info to one or more sqlite databases under /data/data/com.android.providers.telephony/databases

If that process is busy can you see an increase in the size of the mmssms.db file in that location?

(I don't have this ROM loaded so can't check myself).

I also belive this to be true, with my hero the biggest issue with battery was google backup. When you add your accounts and s*** it asks you if you want google to back stuff up. Say no otherwise your battery will be googles personal hooker every 20 seconds (xD).

Battery life issues? Turn off google backup sync!

0

Share this post


Link to post
Share on other sites

Posted

Open Issues:

MP3 - notifications.

I looked at the MP3 playing problems and it seems to be that the complete integration of MP3 decoding is not finished in the Chinese ROM, on which the alpha is based on.

I checked, with various MP3`s and some play some not. This depends on the structure of the MP§ ( if lenght is correctly displayed and so on). If you have badly encoded MP3, with wrong metadata, usally they do not play.

So i can´t imagine there will be a fix until the source comes up

a-GPS:

As written also in the other thread, in my gps.conf intermediate mode was activated, which sends "intermediate" GPS coordinates to GPS enabled apps before it gets the final fix.

You can just turn this off if you change the INTERMEDIATE = 1 switch to INTERMEDIATE = 0 ..

FM-Radio:

Seems to be a bug somewhere in the audio-hardware driver (looks to me like a typo in a function call) and without source it is the same situation as the MP3-problem. (BTW: Switching the FM-app from stock does not work :P)

Bluetooth:

There is a problem in the setup of the Bluetooth profiles on startup, but you can fix it very easy

type following commands

adb shell

cd /system/etc/bluetooth

chmod 644 *

reboot

Audio Routing:

On Boot there are some parameters set. The require the files AudioFilter.csv /system/etc

You can extract this file from the stock rom and place it into /system/etc

I don`t have a clue what it does, but at least the error message is gone.

That`s all folks.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Bluetooth:

There is a problem in the setup of the Bluetooth profiles on startup, but you can fix it very easy

type following commands

adb shell

cd /system/etc/bluetooth

chmod 644 *

reboot

Will this enable bluetooth HID mode?

EDIT: It didn't :P

Edited by nilezon
0

Share this post


Link to post
Share on other sites

Posted

noticed how intallation of this allowed more icons and exceptional web browsing.. was wondering is there something like this avail for the HTC Wildfire as this would be ideal....

0

Share this post


Link to post
Share on other sites

Posted

hi dnt no y but i keep getting "google talk authentication failed" error message and there for i think it is stopping me from downloading from the app store anyway of fixing this? thnx

0

Share this post


Link to post
Share on other sites

Posted

hi dnt no y but i keep getting "google talk authentication failed" error message and there for i think it is stopping me from downloading from the app store anyway of fixing this? thnx

see 4th post in

http://android.modaco.com/content/zte-blad...te-blade-alpha/

0

Share this post


Link to post
Share on other sites

Posted

hi i looked on that however i dont see a solution just people saying they got it to work and not stating how they did...

it is there in my long post (the fourth post in thread)

basically boot inot clockwork mod and delete caches and data, reboot into phone wipe (in privacy) and connect using 3g and not wifi to setup talk then start a download in market before turning on wifi

0

Share this post


Link to post
Share on other sites

Posted

is this the alpha version...i.e the same as the other topic? Just wondering as i've had issues with the alpha and decided to keep 2.1 until either beta or a proper version is released on here.

Sorry if this has already been answered.

ReV0h

0

Share this post


Link to post
Share on other sites

Posted

is this the alpha version...i.e the same as the other topic? Just wondering as i've had issues with the alpha and decided to keep 2.1 until either beta or a proper version is released on here.

Sorry if this has already been answered.

ReV0h

This is the original Alpha

The other is the original Alpha with some of the fixes listed in this thread pre-applied

0

Share this post


Link to post
Share on other sites

Posted (edited)

I still can't get adb to work... :)

My device only appears as a single device in Win7 device manager: hw id = USB\VID_19D2&PID_1350&REV_0226

I've tried installing both the Single and composite drivers for that hardware id - both cause the phone to report 'usb + USB debugging connected' but alas adb devices yields nothing (turning on usb storage doesn't cause the sd card to be visible either!)!

Edited by 2of1
0

Share this post


Link to post
Share on other sites

Posted

I still can't get adb to work... :)

My device only appears as a single device in Win7 device manager: hw id = USB\VID_19D2&PID_1350&REV_0226

I've tried installing both the Single and composite drivers for that hardware id - both cause the phone to report 'usb + USB debugging connected' but alas adb devices yields nothing (turning on usb storage doesn't cause the sd card to be visible either!)!

Is your phone rooted and on a home network

If yes, install ADBWIRELESS

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.