MoDaCo is undergoing planned maintenance. Site functionality may be reduced - follow @modaco or @paulobrien on Twitter for updates.

  • Announcements

    • Reminder - MoDaCo position on illegal content

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software
      Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)


      CUSTOM ROMS

      You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not be hosted directly in topic via the MoDaCo attachment system
      ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)
      ROMs must give full credit to the original author
      This decision has been taken in light of the huge amount of interest in this area of device customisation within the community, and member feedback! Please note that custom ROM discussion should be kept in specific device sub-areas, (e.g. Kaiser.MoDaCo.com for Kaiser based devices). ISSUES If you have any issues with this policy, please contact me directly via PM. P
    • Support MoDaCo by signing up to a MoDaCo Silver or Gold membership

      To sign up to an annual MoDaCo Silver subscription which will eliminate all ads from the site (as well as giving you access to the MoDaCo Online Kitchens for Android) for only £9.99 using PayPal, Credit or Debit Card, ensure you are logged in to the site, and then click the link below, which will take you directly to the subscription store! You can also sign up to an annual MoDaCo Gold subscription for £29.99, which adds the benefits listed below! PURCHASE A MODACO SUBSCRIPTION - FREE Titanium Backup Mobile for Android worth $5.99! - FREE 1 year PrivateInternetAccess.com worth $39.95! - FREE 1 year LastPass Premium worth $12! - FREE CalcConvert for Pocket PC from Binaryfish worth $17.95! - FREE Calendar Bar for Pocket PC from OmegaOne worth $9.99! - FREE CamerAware for Pocket PC and Smartphone from MoDaCo worth £19.99 / $30! - FREE Chronos for Pocket PC from ActiveKitten worth $14.95! - FREE CodeWallet Pro for Smartphone and Pocket PC from DeveloperOne worth up to $24.95! - FREE Concentrix for Pocket PC from eSoft Interactive worth $9.95! - FREE FlexMail for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE FTouchSL for Pocket PC from Vekoff s.r.o. worth 10 euro / $12.50! - FREE Jewel Challenge for Pocket PC from eSoft Interactive worth $9.95! - FREE John Cody's Alerts Pro for Smartphone from Omnisoft worth $14.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Dutch for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> French for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> German for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Italian for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Spanish for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Dutch for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> French for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> German for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Russian for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Turkish for Smartphone from Lingvosoft worth $49.95! - FREE Note2Self for Pocket PC and Smartphone from WebIS worth up to $19.90! - FREE Opera 8.60 for Pocket PC and Smartphone from Opera Software worth up to $48! - FREE Pocket Informant for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE Pocket Launcher for Pocket PC and Smartphone from Conduits worth $9.95! - FREE PTab for Pocket PC and Smartphone from z4soft worth up to $60! - FREE Resco Explorer for Pocket PC and Smartphone from Resco worth up to $49.90! - FREE Safemode for Pocket PC from monocube worth $12.95 - FREE SplashPhoto for Pocket PC and Smartphone from SplashData worth up to $59.90! - FREE Sprite Backup for Pocket PC and Smartphone from Sprite Software worth $29.95! - FREE Teksoft Glyphs UI for Pocket PC and Smartphone from Teksoft €9.95! - FREE Teksoft HeadsetRemote for Pocket PC and Smartphone from Teksoft €4.95! - FREE Traffic Jam for Pocket PC from eSoft Interactive worth $9.95! - FREE unlock (1 per year) from imei-check.co.uk - DISCOUNT of 10% at MoDaCo FairDeal - DISCOUNT of 10% at Semsons.com - FORUM - AD FREE SITE - FORUM - custom rank / title - FORUM - double competition entries - FORUM - double post attachment space - FORUM - no search flood control - FORUM - priority event registration - FORUM - triple PM space
    • Reminder: Selling items on the forum directly is not allowed

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspensions / ban.

ZTE V9 Tablet

491 posts in this topic

Posted (edited) · Report post

So Sebastian, let's say you got the cryanogen froyo stable branch to compile into an update zip and convinced the recovery to load it. You reboot and get the ANDROiD text for 60 seconds, then the device just reloads into recovery. USB never comes up.

Where would you start ? :-)

P.S. we néed to add ro.product.name to the props file of the recovery so it accepts an update zip.

P.P.S. Backup/recovery definitely works :-D

Edited by serialmonkey
0

Share this post


Link to post
Share on other sites

Posted · Report post

@Sebastian404 & @serialmonkey:

It would be really nice if you guys succeed in what you're trying to do; ZTE support doesn't seem much enthusiastic in the 2.2 upgrade. I'll be following this thread :unsure:

0

Share this post


Link to post
Share on other sites

Posted · Report post

P.P.S. Backup/recovery definitely works :-D

I will second that... recovery definatly working...

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

So Sebastian, let's say you got the cryanogen froyo stable branch to compile into an update zip and convinced the recovery to load it. You reboot and get the ANDROiD text for 60 seconds, then the device just reloads into recovery. USB never comes up.

Where would you start ? :-)

harsh language mostly... have you tried swearing at it?

First thing I'd do is try the image you made in the emulator... see if that gives you any better results..

Next thing I'd try using the 'standard' boot.img with your built system.img see if its something to do with your kernel/boot build...

P.S. we néed to add ro.product.name to the props file of the recovery so it accepts an update zip.

it is in usb.conf.. it should get picked up/set by the usbconfig process....

I've been using clockworkmod on the blade for a while without having it set... sorry still not got around to building some update zips for the V9 yet... been hella busy this week..

Edited by Sebastian404
0

Share this post


Link to post
Share on other sites

Posted · Report post

Not alot of success today.

Tried to build a base android froyo (not cyranmod). Good news is that it kinda booted - hung at the green screen but adb was alive. At that point I decided to restore back to my backup and everything went downhill.

Getting into 'adb shell' is a real hit-and-miss. 90% of the time I get the '#' prompt, but then it just hangs (like we saw in the past). Recovery is also having troubles seeing all my partitions. I get errors like 'Can't mount /dev/block/mtdblock4 (File exists)'. My backups won't restore and nothing boots.

So at 3am, it's time to sleep and hopefully I'll work out how to revive it in the morning.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I still can't adb shell into recovery and I'm pretty sure my partition table is screwed as I can't mount/flash/restore into system.

Pretty much dead in the water here for the moment. Someone else might want to have a stab at Froyo until I can't get myself sorted

Well, I now know how to use fastboot and the bootloader to restore images manually when you can adb working but not a full shell.

Now, to sort out my adb shell issues BEFORE I try that again :-)

Edited by serialmonkey
0

Share this post


Link to post
Share on other sites

Posted · Report post

and with that, still no joy. I've tried using my original boot.img with the new system.img but it just gets to the green android screen, waits for awhile, and reboots into recovery. It's the lack of feedback which is frusterating at the moment.

This is using stock Froyo source. I might go back and work out why I can't get the cryanogen froyo-stable branch to compile fully. Which GIT branch are you using for your Blade images ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

are you using ADB via windows or linux ??

Just have an issue here, as i am sick of rebooting from windows to ubuntu and back again just to make some changes...

I use Ubuntu 10.04 for everything i do, so rebooting into windows is painful.

I am just curious, if you use or if anyone uses Ubuntu, as how you get the V9 to connect to ADB... I have read every forum and posting i can think of for adding XX.android.rules to the udev/rules.d profile. I even downloaded and updated to the latest Android SDK... here is my issue though...

I can connect my HTC Desire HD to ADB via Ubuntu, no issue... I can get my wifes HTC Desire to connect... I cant get my Huawei S7, ZTE V9 nor my LG Optimus to connect. I have all the codes added to the rules file for every device. I have tried every version of the rules files and both the 10.04 and the 10.10 versions of the files. i have rebooted my computer, restarted udev and even did the adb kill-server, start-server mentions... still, Ubuntu will only see some of these devices.

Please save me from my windows rebooting nightmare!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Works fine in Ubuntu for me (after updating the udev config).

So, does it appear in lsusb ? Does it appear in 'abd devices' ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Dear,

please write how to install a ZTE V9 "b8_recovery-clockwork-2.5.1.8-light.img"

Sorry for my bad English

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

serialmonkey,

I've just been looking at the kernel source, they use the same source for the light as the blade... have you tried building the 2.1 kernel?

EDIT: I managed to build a new Kernel.. I rebuilt it with EXT3 & EXT4 support.... anyone care to try this version of clockworkmod recovery?

Edited by Sebastian404
0

Share this post


Link to post
Share on other sites

Posted · Report post

please write how to install a ZTE V9 "b8_recovery-clockwork-2.5.1.8-light.img"

1. Root your device

2. Get adb working

3. Copy the IMG to your sdcard using 'adb push'

4. Get a 'adb shell'

5. Run 'flash_image recovery b8_recovery-clockwork-2.5.1.8-light.img'

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I've just been looking at the kernel source, they use the same source for the light as the blade... have you tried building the 2.1 kernel?

Yes

EDIT: I managed to build a new Kernel.. I rebuilt it with EXT3 & EXT4 support.... anyone care to try this version of clockworkmod recovery?

Same result as with the kernel I built - just hangs at the android logo. No usb.

When building your blade Cryanogen images Sebastian, do you use the 'froyo' or 'froyo-stable' GIT branch ?

Edited by serialmonkey
0

Share this post


Link to post
Share on other sites

Posted · Report post

Works fine in Ubuntu for me (after updating the udev config).

So, does it appear in lsusb ? Does it appear in 'abd devices' ?

appears in lsusb, no issues there... i can even mount and unmount the sdcard and read/write to it in nautilus...

Just for some reason, it just wont ADB anything for me... and its really irritating me to swap back to windows just to use fastboot and adb. Most of the stuff i have been doing from terminal, but just sometimes there are some things i cant/dont want to do in terminal...

I even went to your page of goodies about this device and used your udev settings... still no dice.

Anyway... back to Windows i guess...

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I ppl!

I manage to get app2sd to work, as seen bellow on.

I used the device the hole day and reboted several times, but was missging the resixed screen so

After that I wanted to set te sreen with LCD Resizer, and make the changes permanent.

So i made 140, and rebooted

Same error than before appeared, but this time only with SDW.Launcher, and it gets stuck in that loop, since i does't load. everything seems ok in some way since de lock sreen seems ok, ans it unlocks, the top bar show the info and some apps loading in the background, just the launcher does load.

Since i had startup manage installed i managed to add launcher, settings, lcd resizer and others to load on boot

then with some patience i managed to get the resolution in 240

now it just boots gives vofadone logo... and reboots in a loop...

managed to get to settings menu and reset to factory settings

Still de sreen doesnt' accpets the normal size...

managed to get to settings menu and reset to factory settings

Still de sreen doesn't accpets the normal size... (i've been using 240) isn't that the default en zte v9?

and i can use the same sdcard or it loop to reboot... so i will have to format it again.

Would a backup from other device work?

or for this case anyone can post the system\"build.prop" file here pls!? (i belive thar woul solve the sreen issue.)

****************************************************

App2SD for "Dummies"

This procedure was used with ZTE V9, but should work with any other equipment, if needed.(i published it first in portugues this is a google auto tranlation.. since i'm short on time rigth now)

Uses but is aware of the risks!

By using these to accept that you will be solely responsible!

Tutorial by alpahxs using App2SD of joe.stone

Risk:

* Loss of data or card

* Advise if you have a minimum of apps installed

* Back up everything that exists especially in SD

Follow the instructions below to achieve the App2SD in your equipment

Requirements:

* Root

* Superuser

* Android 2.1 Eclair

HowTo:

1. Before installing app2sd. Do not forget to partition the sd card.

Method A:

Uses portable paragon partition manager (Google).

A-1-Open the program and care to choose the right drive! That is not formtates your pc!

A-2-Deletes all partitions on the card and partitions as you prefer.

A-3-In my case I created an ext2 (2GB), 256 MB swap, and the rest were in fat32 (8GB).

Method B:

If you have another terminal, which has the recovery, put there the SD card from your terminal, go into recovery and use options to partition the card.

B-1-Again creates 3 particções the way you like.

Created the partitions is normal card not being read by windows (if you use Linux do), but do not worry and insert the card into V9 ZTE.

Then follows the steps to stay with app2sd:

2.Faz app2sd_new downloads.

istech.co.id/ronie/app2sd_new.zip

3.Extrair to a folder and you'll stay with three directories inside it.

2.Copia all to the root of your SD card already in the ZTE.

5.Abre the Market, and installs the app GScript (can be lite).

6.Abre the GScript

7.No GScript, click on Menu in ZTE, and do "Add Script"

8.Clica the button "Load File" and select the script that you should appear at the top "app2sd.sh"

9.The script should then appear in the application, is "Save."

10.Deves now have the name of the script added to the list of GScript.

11. Repeat step 7 until you have all the additions to the list of scripts GScript.

12. Do adicioaste you all, if yes then go to app2sd.

13.A statement is that I had just run the "a2sd_data" return to the list and reboot, however I ended up using the first "app2sd.sh," so I think formatting the card again and then "a2sd_data" .

14. Reboot

15. The phone will reset the settings and see the size of internal memory ... if you managed to increase!

NOTES:

* In my case, I ran the two scripts and two times before reboot.

* When restarting is possible to restart the machine normally, or that it is giving error after error, if it is to make mistakes, simply do nothing!!

In my case, I began to think what might have brick, but as I had read several other reports of attempted app2sd, which sometimes happens, I was trying to give ok's to see if it stopped giving error (in my case had the ADW Launcher was installed and with that having done the whole list of startup, and never get there). Factured from micro seriously thought he had failed to normal GUI.

However I removed the battery three times, and always the same thing until I removed the sim card to try, and I ended up starting and allow to stand without stirring, (probably not necessary to remove the card) was there to give errors until + / - 3 minutes alone there was rebooted and when it did (it had gone the rest of the script, I suppose) already had the normal appearance.

In momemt'm using ZTE already has 2GB internal memory with almost the barnacle to share net to the pc, if not yet had time to experience more, but I have done a reboot since app2Sd (to put the sim card again) and everything seems to be the LCD ok.Só Resizer open, but seems not to apply the new settings, is now seeing how to solve this problem ...

Now see if it works with you.

Edited by alpha xs
0

Share this post


Link to post
Share on other sites

Posted · Report post

When building your blade Cryanogen images Sebastian, do you use the 'froyo' or 'froyo-stable' GIT branch ?

I grabbed the froyo branch.... but was only interested in the recovery really...

0

Share this post


Link to post
Share on other sites

Posted · Report post

any news about porting 2.2 to this device?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Can someone help me?!!!!!!!

I have rooted my ZTE V9. To free some internal memory I transferd all files from data\app to system\app and it was working fine. Then I found that I cann't uninstall any application which has been transfered to system\app . Then wanted to move all files back to data\app but due to space issue it was not complete.

Now I cannot use GPS, original browser, camera, calender, alarm and some other application because they are missing. I am not finding the related .apk anywhere.

Is there any way to revert it back to original state? I tried factory reset already but it did not helped me.

I would apprecitate if some help me to recover the issue.

Thank you in advance

0

Share this post


Link to post
Share on other sites

Posted · Report post

you will need a system.img backup and possibly a boot.img backup. You asked me on XDA about how to install the recovery.img

What you should have done is, installed clockwork recovery, backed up your system first and then made changes. This way, if anything goes wrong, like it has here, you can flash it back to its default setting.

If you like, i can send you my recovery files over, but they may be different to yours and may or may not work. They can just be loaded from recovery or you can use fastboot to flash them back. Make sure you have working recovery before you flash anything...

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I'm unable to test these on the real device, I managed to flash them to my blade so I know the script is ok... but here are the Two STOCK recovery updates I promised...

Life_V9V1.0.0B01-update_signed.zip - MD5: 77d52bbb524a975f1df4085d7d5483cb

OPTUS_V9V1.0.0B10-update_signed.zip - MD5 : 25bbba35307b1c4ced16d074bd620704

They should work with Clockworkmod Recovery.

Anyone care to test them out and post back?

Edited by Sebastian404
0

Share this post


Link to post
Share on other sites

Posted · Report post

1)backed up

2)installed OPTUS_V9V1.0.0B10-update_signed.zip

3)tested - everything works fine

4)rooted again

5)installed clockwork again

6)restored

everything is ok

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi there BlcakFox & Sebastian404,

Are the two builds above working 2.2/Froyo builds, as in, with APP2SD support etc.?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello, jimmyjack72

Those builds are just 2.1 stock builds with no APP2SD

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have been following this thread since beginning. I'd like help to get Froyo to run on the device, but unfortunately I had to send the device for repair, twice already.

My problem is that using GPS disconnects all the 3g/cellular modem connections. For example after opening navigation or google maps it cannot load new map data after GPS fix is acquired. You also cannot answer voice calls or make new calls after using GPS. Only way to fix the problem, I have noticed, is to reboot the device. Wifi connection is not affected and works OK.

Since for some reason they are unable to fix the problem I'd like to hear if other ZTE V9/Light users have experienced the problem or is it just my broken device?

Br, V

0

Share this post


Link to post
Share on other sites

Posted · Report post

My problem is that using GPS disconnects all the 3g/cellular modem connections. For example after opening navigation or google maps it cannot load new map data after GPS fix is acquired. You also cannot answer voice calls or make new calls after using GPS. Only way to fix the problem, I have noticed, is to reboot the device. Wifi connection is not affected and works OK.

quite a few people have had that problem with the ZTE Blade, but only with some firmwares...

have you tried installing the firmware we have ? once you get your device back of course...

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.