• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Skype speaker fix

47 posts in this topic

Posted (edited)

A lot of people were complaining about the Skype app sending sound to the loudspeaker. The Skype programmers were having the same problem that is described here. Basically they called AudioManager::setSpeakerphoneOn(false), but this fails (silently, and only on some devices) if you don't first set AudioManager::setMode(MODE_IN_CALL). Another example of random Android API horseshit.

Anyway, I did a quick baksmali/smali patch that seems to solve the problem, but I'm not sure if it breaks other functionality. Anyone care to test if it works for them?

http://www.multiupload.com/G2GU9CVUFJ

ps: this is completely untested, so if it breaks, destroys your phone, breaks into your house and steals your food, I'm not responsible

pps: this routes all audio to the internal speaker, including the ringing sound when someone is calling you!

ppps: I've submitted a bug report to Skype including information on how to fix it, so I'll just wait for them to sort it out the correct way.

Edited by Inopia
0

Share this post


Link to post
Share on other sites

Posted

Success! :P

(JJ9 on Swiss Blade)

Great work!! Let's hope Skype cares and adds this to the official release...

0

Share this post


Link to post
Share on other sites

Posted

So far so good! Excellent work! :P

Would love to see this fix implemented officially by Skype in future releases.

0

Share this post


Link to post
Share on other sites

Posted

Thank you! :P

Now, if you are still looking for challenges ... there's another popular question here - why can't ZTE's FMRadio play through anything other than the headset? (sure it needs the wire for its antenna, but it's sometimes nice to be able to play out through the speaker...)

0

Share this post


Link to post
Share on other sites

Posted

Hmm, it seems a bit flaky for me. Also, I think I've routed the ringer sound to the internal speaker as well :P

0

Share this post


Link to post
Share on other sites

Posted (edited)

... I think I've routed the ringer sound to the internal speaker as well :P

Or rather, Skype have routed the ringtone to the same place as the call audio ... which doesn't seem terribly clever.

Surely there ought to be a "ring the phone" API call, which would do what a normal incoming call would do ... but likely Skype is doing everything as though it were playing 'Media' ...

Edited by oh!dougal
0

Share this post


Link to post
Share on other sites

Posted

A lot of people were complaining about the Skype app sending sound to the loudspeaker. The Skype programmers were having the same problem that is described here. Basically they called AudioManager::setSpeakerphoneOn(false), but this fails (silently, and only on some devices) if you don't first set AudioManager::setMode(MODE_IN_CALL). Another example of random Android API horseshit.

Anyway, I did a quick baksmali/smali patch that seems to solve the problem, but I'm not sure if it breaks other functionality. Anyone care to test if it works for them?

http://www.multiupload.com/G2GU9CVUFJ

ps: this is completely untested, so if it breaks, destroys your phone, breaks into your house and steals your food, I'm not responsible

pps: this routes all audio to the internal speaker, including the ringing sound when someone is calling you!

ppps: I've submitted a bug report to Skype including information on how to fix it, so I'll just wait for them to sort it out the correct way.

Thank you so much for posting! Will try it for mom :P

0

Share this post


Link to post
Share on other sites

Posted

Sounds good, but just so that I'm sure I understand the routing to the internal speaker you've done affects only the Skype app? Guess I need to delete the Marketplace-installed app, and manually install this.

Much appreciated.

0

Share this post


Link to post
Share on other sites

Posted

OMG a lot of thanx 2 U! I wrote 2 Skype but they don't care about.

0

Share this post


Link to post
Share on other sites

Posted (edited)

A lot of people were complaining about the Skype app sending sound to the loudspeaker. The Skype programmers were having the same problem that is described here. Basically they called AudioManager::setSpeakerphoneOn(false), but this fails (silently, and only on some devices) if you don't first set AudioManager::setMode(MODE_IN_CALL). Another example of random Android API horseshit.

Anyway, I did a quick baksmali/smali patch that seems to solve the problem, but I'm not sure if it breaks other functionality. Anyone care to test if it works for them?

http://www.multiupload.com/G2GU9CVUFJ

ps: this is completely untested, so if it breaks, destroys your phone, breaks into your house and steals your food, I'm not responsible

pps: this routes all audio to the internal speaker, including the ringing sound when someone is calling you!

ppps: I've submitted a bug report to Skype including information on how to fix it, so I'll just wait for them to sort it out the correct way.

Hi,

Is this routes ringing sound to the internal speaker, only if skype is running, and as I exit from skype, everything goes back to normal, OR is this overwrites the main settings too?

Thnx

Jim

Edited by jim35
0

Share this post


Link to post
Share on other sites

Posted

thank you very much, it works well.

0

Share this post


Link to post
Share on other sites

Posted

Ok i have tested this fix and this is what happens

If i make a call on skype all the sounds will be routed to the earpiece even after the call

but everything will be rerouted to normal if you recieve a regular call after the skype call or

making a normal call to someone.

An easy solution to this would be a shortcut on the launcher that resets the soundsettings somehow (The same as if you start a regular call)

and you have to press that button everytime you have been in a skype call. Everything will then be routed

to the right speaker (You will even get the skype incoming call signal from the loudspeaker)

Any bright solutions of this? Right now i make a random call and disconnect directly when started calling and this

seem to reset the soundsettings.

Or maybe its possible to decompile again and put a line for this too in the skypecode?

0

Share this post


Link to post
Share on other sites

Posted

Thank you for a great fix.

It does use the ear speaker and it finally works like a phone. (screen doesnt turn off? arr just lower it before I make a call)

I can live with this until Skype releases a fix. (But I dont think they will)

The problem with every sound routed to the ear speaker is an easy fix as saxen08 mentioned that I can just make a fake test call to any random number

and hang up. (and its back to normal)

I dont know if this force sound routing thing is safe, but I guess there isnt a reason why it shoudnt be safe.

Great work

0

Share this post


Link to post
Share on other sites

Posted

Skype released a new update today but it still does not solve the exterior speaker issue.

I suggest you stick with this modified skype and wait until it can actually change.

This Skype is great. You can ACTUALLY use ear / exterior speaker button to function

and the screen can turn off.

Just remember to make a fake call to any number and hangup when you dont need skype :)

0

Share this post


Link to post
Share on other sites

Posted

"Security update"

That'll be for the db permissions exploit

http://www.androidpolice.com/2011/04/14/ex...and-a-lot-more/

btw, what's with all these "skimlinks"? every time anyone says Sykpe it auto places a link, I hope modaco isn't implementing those annoying keyword link parsers.

0

Share this post


Link to post
Share on other sites

Posted (edited)

"Security update"

That'll be for the db permissions exploit

http://www.androidpolice.com/2011/04/14/ex...and-a-lot-more/

btw, what's with all these "skimlinks"? every time anyone says Sykpe it auto places a link, I hope modaco isn't implementing those annoying keyword link parsers.

I think they are - any chance to monetise those punters' geekery eh?

Let's try a few...

Skype

Google

Ebay

Microsoft

Samsung

Apple

Comet

B&Q

MFI

Boots

Poundland

Ryanair

edit - of those, only skyp* and eb*y signed up from the looks of it

Edited by The Soup Thief
0

Share this post


Link to post
Share on other sites

Posted

It seems that this problem is actually an Android/Blade issue and has nothing to do with Skype as such. It also affects nearly all SIP type programmes.

Cyanogen have incorporated a fix that works, it seems, in the N41 build.

0

Share this post


Link to post
Share on other sites

Posted

Maybe the best way is to write an application which can switch between the internal and external speaker.

I saw similar applications in some non-android samsung phones before. Iphone can also do this freely.

0

Share this post


Link to post
Share on other sites

Posted

Uploaded a new patched skype here - https://jira.skype.com/browse/JSA-81 - this routes only the in-call audio to the earpiece, so the ringtone etc. should continue to work. Speakerphone works too. Same disclaimer applies - works for me on my ZTE Blade (Orange San Francisco) but use at your own risk.

0

Share this post


Link to post
Share on other sites

Posted

Hats off to you sir!

0

Share this post


Link to post
Share on other sites

Posted

thank you npgall!

Niall Gallagher also made an undate with the newer skype. There are many talented people in this forum..

0

Share this post


Link to post
Share on other sites

Posted (edited)

Uploaded a new patched skype here - https://jira.skype.com/browse/JSA-81 - this routes only the in-call audio to the earpiece, so the ringtone etc. should continue to work. Speakerphone works too. Same disclaimer applies - works for me on my ZTE Blade (Orange San Francisco) but use at your own risk.

Thanks, works fine for me ! :)

Edited by ponzer
0

Share this post


Link to post
Share on other sites

Posted

Working great for me too, That speakerphone thing was damn annoying.

0

Share this post


Link to post
Share on other sites

Posted

FYI this issue seems to be fixed in two new roms for ZTE Blade that I've now tried, so I probably won't be using my patched skype anymore. (others can continue using patched skype if you prefer of course, but personally I prefer to have this patched at OS-level instead of app-level).

I was using the FLB-Froyo rom, which suffers from this issue and requires skype to be patched, but Cyanogenmod 7.0.2 and (apparently also) Swedish Spring now include a patch at OS-level instead of app-level.

Definitely patched in Cyanogenmod 7.0.2 for ZTE Blade: http://code.google.com/p/cyanogenmod/issues/detail?id=2858

And from my own testing today the issue also /seems/ to be patched in Swedish Spring RLS5 (although I can't find any documentation to this effect).

0

Share this post


Link to post
Share on other sites

Posted

Thank you so much for this fix. Working well on my San Fran and also my son's T-Mobile Mini Pulse...you're a star!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.