• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

GPS crashes with CM7 Gen2

92 posts in this topic

Posted (edited)

Hi,

This is to collect more information on the (new) GPS reboot problem on Gen2 phones. Not the old temperature related one (that has been fixed), but the one that makes Google Maps, GPS Status and many other GPS applications reboot the phone after a few seconds. CoPilot and Navigon also have been reported to crash.

The only GSP application I have found working so far was SportsTracker. This works fine and only reboots the phone after the recording has been finished. Somebody else mentioned Sygic Maps working, I can't verify that.

Update: GPS Problems (might) have been fixed with the 7.0.2 Update, or check post #67 for clockwork flashable alternate gps libraries.

Edited by JobSup
0

Share this post


Link to post
Share on other sites

Posted

One thing that seems to work on my Gen2 Blade:

- flash CM7 Nightly39 (Gen1)

- flash cm7_gen2_converter_ver3.zip right after

Google Maps and other GPS Apps are working fine. The only thing I need to replace (or better include in the gen2_converter) is the current lobaudio.so for the SIP routing fix.

If that works out, I'll be a happy bunny for the upcoming easter holidays :-)

0

Share this post


Link to post
Share on other sites

Posted (edited)

I have the same issue tested with Navitel and Yandex maps

Ther're some of my logs http://slivabox.org.ua/android/log.zip

Edited by slivabox
0

Share this post


Link to post
Share on other sites

Posted

Even though I do not have Google maps installed, and my map routing application works fine, have you thought of placing a bug report for this as now we have a n41 it might be worth considering...?

It has not happened to me but, as noted, my mobile maps works fine.

0

Share this post


Link to post
Share on other sites

Posted

Hi,

This is to collect more information on the (new) GPS reboot problem on Gen2 phones. Not the old temperature related one (that has been fixed), but the one that makes Google Maps, GPS Status and many other GPS applications reboot the phone after a few seconds. CoPilot and Navigon also have been reported to crash.

The only GSP application I have found working so far was SportsTracker. This works fine and only reboots the phone after the recording has been finished. Somebody else mentioned Sygic Maps working, I can't verify that.

My blade is from Base/Germany and is a TFT with 5MP camera. Converted to Gen2 a few days ago. GPS is not really usable with CM7 at the moment.

Somebody suggested to disable GPS and enable it again, that did not help on my phone. Maybe we can collect more information to help finding the cause.

What Nightly are you running?

0

Share this post


Link to post
Share on other sites

Posted

What Nightly are you running?

Any Gen2 build so far had the same problem, Jacobs first build, N40 and N41.

Only flashing N39 with the Gen2 conversion files flashed afterwards is working better. GPS Status still seems to crash but after a few minutes compared to a few seconds.

I will post a bug report if more people are affected. That's what I am trying to find out with that topic.

So long

0

Share this post


Link to post
Share on other sites

Posted (edited)

Any Gen2 build so far had the same problem, Jacobs first build, N40 and N41.

Only flashing N39 with the Gen2 conversion files flashed afterwards is working better. GPS Status still seems to crash but after a few minutes compared to a few seconds.

I will post a bug report if more people are affected. That's what I am trying to find out with that topic.

So long

Have the same symptoms on all listed firmwares

Phone is English Orange SF

Edited by slivabox
0

Share this post


Link to post
Share on other sites

Posted

Mine were gone for a long while on N41. Originally on Jacob's Gen2 build he posted here, I had reboots every time Fancy Widget refreshed, but now only Google Maps causes it. Strange.

0

Share this post


Link to post
Share on other sites

Posted

Mine were gone for a long while on N41. Originally on Jacob's Gen2 build he posted here, I had reboots every time Fancy Widget refreshed, but now only Google Maps causes it. Strange.

Use the wifi to get the location and disable the gps when getting the location in Fancy Widget (I use it the pro version)

For settings > Location & Security Settings > Use Wireless networks for 'My Location'.

In Fancy Widget, manually set the location and forget about GPS - odd bug alright - saw someone mention on IRC that the qcom libs replacements solved the gps bug.... :S who knows...

0

Share this post


Link to post
Share on other sites

Posted (edited)

In Fancy Widget, manually set the location and forget about GPS - odd bug alright - saw someone mention on IRC that the qcom libs replacements solved the gps bug.... :S who knows...

Just found this post from xda.

http://forum.xda-developers.com/showpost.p...postcount=17883

edit: Note that the post is in EVO 4G section of the forum, I don't know if it affects blade?

Edited by sm4tik
0

Share this post


Link to post
Share on other sites

Posted

Just found this post from xda.

http://forum.xda-developers.com/showpost.p...postcount=17883

edit: Note that the post is in EVO 4G section of the forum, I don't know if it affects blade?

I think this GPS driver mentioned there won't work, different hw. But the problem might very well be in one of the two diver files in /system/lib/hw gps.blade.so or gps.goldfish.so.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi,

just found this thread and originally reported it to the "General CM7 thread".

I have the same problem here with literally all GPS programs.

It pretty much co-incidence with the GPS lock. All programm work fine with GPS DISabled.

I can confirm crashes a few seconds after teh GPS symbol appeared with these programs:

Navigon

Maps

Layar

Wikitude

Google goggles

It also crashes with SportsTracker. It takes much longer to crash the phone, probably until it really gets a fix. Does it use A-GPS?

Disabling and enabling +/- reboot doesn't solve anything for me. My phone is "no-gps" in the moment.

Jan

PS: It's a BASE Lutea.

EDIT: "Crash" means "Reboots"

Edited by OckoTomBrok
0

Share this post


Link to post
Share on other sites

Posted

Hi,

just found this thread and originally reported it to the "General CM7 thread".

I have the same problem here with literally all GPS programs.

It pretty much co-incidence with the GPS lock. All programm work fine with GPS DISabled.

I can confirm crashes a few seconds after teh GPS symbol appeared with these programs:

Navigon

Maps

Layar

Wikitude

Google goggles

It also crashes with SportsTracker. It takes much longer to crash the phone, probably until it really gets a fix. Does it use A-GPS?

Disabling and enabling +/- reboot doesn't solve anything for me. My phone is "no-gps" in the moment.

Jan

PS: It's a BASE Lutea.

you can add co-pilot to your list as well :)

0

Share this post


Link to post
Share on other sites

Posted

Hi,

just found this thread and originally reported it to the "General CM7 thread".

I have the same problem here with literally all GPS programs.

It pretty much co-incidence with the GPS lock. All programm work fine with GPS DISabled.

I can confirm crashes a few seconds after teh GPS symbol appeared with these programs:

Navigon

Maps

Layar

Wikitude

Google goggles

It also crashes with SportsTracker. It takes much longer to crash the phone, probably until it really gets a fix. Does it use A-GPS?

Disabling and enabling +/- reboot doesn't solve anything for me. My phone is "no-gps" in the moment.

Jan

PS: It's a BASE Lutea.

Well I have been running Maps on N41 for a couple of hours with no problems, the change I made was to replace the gps.conf with one published by wbaw when we were having issues with FLB 10, I changed the server to the UK entry. CM running on my test phone at the moment so I don't have any other apps other than GPS Test+ to test it with but going in & out of Maps with a quick & stable 30ft. lock without any crashes or reboots.

0

Share this post


Link to post
Share on other sites

Posted

One thing that seems to work on my Gen2 Blade:

- flash CM7 Nightly39 (Gen1)

- flash cm7_gen2_converter_ver3.zip right after

Has anyone else tried this and can confirm it? (I doubt that it works in N35 since there weren't changes to the GPS libs since N35)

0

Share this post


Link to post
Share on other sites

Posted

Has anyone else tried this and can confirm it? (I doubt that it works in N35 since there weren't changes to the GPS libs since N35)

I can confirm this does not work.

0

Share this post


Link to post
Share on other sites

Posted

Well I have been running Maps on N41 for a couple of hours with no problems, the change I made was to replace the gps.conf with one published by wbaw when we were having issues with FLB 10, I changed the server to the UK entry. CM running on my test phone at the moment so I don't have any other apps other than GPS Test+ to test it with but going in & out of Maps with a quick & stable 30ft. lock without any crashes or reboots.

Could you link this please? :)

0

Share this post


Link to post
Share on other sites

Posted

Could you link this please? :)

Couldn't find a link but would this do?

### GPS FIX - Modified by wbaw - http://wbaw.net ###


### NTP Time server, use a local one for best response time ###


NTP_SERVER=0.europe.pool.ntp.org

# NTP_SERVER=0.uk.pool.ntp.org

# NTP_SERVER=0.asia.pool.ntp.org

# NTP_SERVER=0.oceania.pool.ntp.org

# NTP_SERVER=0.north-america.pool.ntp.org

# NTP_SERVER=0.south-america.pool.ntp.org

# NTP_SERVER=0.africa.pool.ntp.org


XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtra.bin

XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtra.bin

XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtra.bin

DEBUG_LEVEL = 3

INTERMEDIATE_POS=1

ACCURACY_THRES=5000

ENABLE_WIPER=1

SUPL_HOST=supl.google.com

SUPL_PORT=7276

CURRENT_CARRIER=common

DEFAULT_AGPS_ENABLE=TRUE

DEFAULT_SSL_ENABLE=FALSE

DEFAULT_USER_PLANE=TRUE

0

Share this post


Link to post
Share on other sites

Posted

Well I have been running Maps on N41 for a couple of hours with no problems, the change I made was to replace the gps.conf with one published by wbaw when we were having issues with FLB 10, I changed the server to the UK entry. CM running on my test phone at the moment so I don't have any other apps other than GPS Test+ to test it with but going in & out of Maps with a quick & stable 30ft. lock without any crashes or reboots.

Did you do this in the original ROM zip, as the file I've found has amend-scripting and isn't supported by the latest clockwork.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Did you do this in the original ROM zip, as the file I've found has amend-scripting and isn't supported by the latest clockwork.

Just push the gps.conf file with adb. (/system/etc)

edit: remember to

$ adb remount

first, so you can write to /system

edit2: it seems that the new settings get applied if you turn gps off and then back on, so no reboot required

Edited by sm4tik
0

Share this post


Link to post
Share on other sites

Posted (edited)

Just push the gps.conf file with adb. (/system/etc)

edit: remember to

$ adb remount

first, so you can write to /system

edit2: it seems that the new settings get applied if you turn gps off and then back on, so no reboot required

Nope, I built it into a new ROM reflash and no dice. Maps still reboots the phone.

I think the issue lies in the kernel somewhere, as KK's kernel seems to have less reboots.

Edited by Matthew Ferguson
0

Share this post


Link to post
Share on other sites

Posted

I can confirm this does not work.

I can confirm it does work. (i.e. Nightly39 + cm7_gen2_converter_ver3)

I was running this configuration last Friday and used my Blade as a GPS on a 100 mile journey (and back).

Worked great. No reboots.

I've just reverted back to this version (remember to backup!) and gps is working perfectly. No reboots.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.