Jump to content
TechnoLover

[KERNEL] TechnoLover's Kernel Edition 1.5 (25.06.2012)

Recommended Posts

Now I do flash kernel 1.2a for Stock ROM.

I get up fps in Nenamark2 from 21,5 to 27fps. (@1612, perfomance,noop)

We faster then Galaxy S with SGX540: +3fps!!!

LG 2x with tegra2 faster then us on 1fps!

Device is stable!

I have a couple of ideas that could be improved :D

LCD matrix is defined to display 16bit colors (it is a colors map is set), but other devices configured to send the display driver 24-bit and 32 bit color.

We can of course switch the display to 24 bits, but it causes FPS drop lower to 30-40%. But the eye does not change anything colors. Well, quite. I already try it. :)

I think the excess off (actually unused) lcd matrix of color depth (24bit) - it will unload the data bus display controller and the display may reduce the consumption of batteries, as well as disable the unnecessary color depth (32bit) gpu framebuffer - unload the data bus and can increase perfomance.

On weekends I try to do it.

Next I try to increase size RAM for GPU and try to found how do OC system RAM.

Edited by Genrix

Share this post


Link to post
Share on other sites

Good work, but there is the same problem that was in older kernels: if you use CM, you can't change frequency in CM settings. There are no frequencies at all :(

Share this post


Link to post
Share on other sites

hello

I get graphic glitches when using the latest kernel - TechnoLover-Kernel-1.2a-5-20120209-signed.zip; TechnoLover's Kernel 1.2a - 5%

1.Wiped all data using Vache-AmonRA_4_Metal-2.2

2.installed rom t_l_Metal_2.3.6_13_AOSP.zip

3.Installed TechnoLover-Kernel-1.2a-5-20120209-signed.zip; TechnoLover's Kernel 1.2a - 5%

Can be seen when flicking between program list and settings list.

Older TechnoLover-Kernel works fine so I guess this is a gpu issue? Any ideas?

Edited by spacefroguk

Share this post


Link to post
Share on other sites

Hi All

It doesn't work for me... T&L 2.3.6_13 AOSP

Stucked on boot screen, tried both 1% and 5%, busybox 1.19.3 (from market) installed

Any suggestion?

...any idea? it works for everyone except me?

(was the same also with prev ver 1.1)

Thx in advance

Share this post


Link to post
Share on other sites

I see same issues with Cyanogen rom and tecnolover cm kernel.. can you provide zip that reverts enhanced GPU settings? I am willing to test various O/C undervolt settings if required. ;)

hello

I get graphic glitches when using the latest kernel - TechnoLover-Kernel-1.2a-5-20120209-signed.zip; TechnoLover's Kernel 1.2a - 5%

1.Wiped all data using Vache-AmonRA_4_Metal-2.2

2.installed rom t_l_Metal_2.3.6_13_AOSP.zip

3.Installed TechnoLover-Kernel-1.2a-5-20120209-signed.zip; TechnoLover's Kernel 1.2a - 5%

Can be seen when flicking between program list and settings list.

Older TechnoLover-Kernel works fine so I guess this is a gpu issue? Any ideas?

Share this post


Link to post
Share on other sites

hello

I get graphic glitches when using the latest kernel - TechnoLover-Kernel-1.2a-5-20120209-signed.zip; TechnoLover's Kernel 1.2a - 5%

1.Wiped all data using Vache-AmonRA_4_Metal-2.2

2.installed rom t_l_Metal_2.3.6_13_AOSP.zip

3.Installed TechnoLover-Kernel-1.2a-5-20120209-signed.zip; TechnoLover's Kernel 1.2a - 5%

Can be seen when flicking between program list and settings list.

Older TechnoLover-Kernel works fine so I guess this is a gpu issue? Any ideas?

Yeah i also get this problem,

Can't even play modern combat 3 since the GPU hack.

Share this post


Link to post
Share on other sites

Seems to work well for me. Noticing a lot less battery drain while gaming.

Though, Quadrant stops dead before doing the 2d/3d testing. Doesn't seem to affect anything else though.

Share this post


Link to post
Share on other sites

I guess the uv-gpu is different for everyone. Mine is fine so far for the most part, I only have noticed a few odd artifacts in one test in Quadrant 3d, the one with the stairs and corridor.

If anyone wants a 'wow' moment, try 'pinball hd for tegra' , especially if you have a pair of 3d glasses, runs butter smooth with this kernel even at standard 1024mhz.

Share this post


Link to post
Share on other sites

with my t&l the kernel has problems.....i tried riptide and feel better than the old one....but with speedx 3d i have a big big problem the black lines of the tunnel flash continuosly i don't know why...i ' m really sorry but it is hard for me to explain in english technical things...i don't know if is because of the t&l rom but i come back to the old kernel. I wait for a update :D

Share this post


Link to post
Share on other sites

with the new kernel both 1% that 5%, the photographic gallery has some problems. The device goes to block, and I remove the battery to reboot (with cyano 7.23)

Edited by Al3ss10

Share this post


Link to post
Share on other sites

Installed it,

Installed zip so it can overwrite the previous version and now its stuck on the bootup? :(

"Its stuck on the Technolover image boot"

The 1% version.

Edited by Dr.Luigi

Share this post


Link to post
Share on other sites

hello

after 5 minutes of asphalt 6 my MT blocked,I use official 2.3.6 karnel 1.2a 1% 1gh overclock

Share this post


Link to post
Share on other sites

Oh lols,

Me fault,

Installed the CM version,

Works fine now!

Only how do you undervolt and overclock the GPU ?

I dont see any app for it?

Share this post


Link to post
Share on other sites

I can install in my official rom 2.3.6 cm karnel??? (sorry for my english)

Edited by dads

Share this post


Link to post
Share on other sites

How can i control me GPU overclocking and undervolt ?

@dr. luigi, it's hard set, you'll have to compile your own kernel to change it.. i don't know how to do that.

With this new kernel I have noticed after some more testing that some games do show artifacts or flashing pixels.. minecraft ..n64droid for two ..buit none have crashed or anything like that.

also the volume is not as loud as the 1.1a modified by genix which is a shame, i like it to hurt my ears slightly :D (I already have tinnitus, before anyone says anything, i use to be careful but I got it anyway so now I don't care about it anymore ..haha ..in fact it seems to help for a while)

Share this post


Link to post
Share on other sites

May be need set upper voltage level for GPU. But in source not have more high voltages then 1200mV(HIGH). Maybe try add this....write 1300mV level - EXTRIME. :)

GPU get very hot device. If we set 1300mV for GPU, then maybe need lock CPU at 1200mhz. For safe.

May be GPU not be stable and 1300mV too. :D

My device freeze\blocked in Neocore. In other test he is good. :D

Edited by Genrix

Share this post


Link to post
Share on other sites

May be need set upper voltage level for GPU. But in source not present higher voltages. Maybe try add this.... 1300mV. :)

I'm using 380000000 as frequency and 900 or 1000 as voltage if remember well :) and no problem :)

Share this post


Link to post
Share on other sites

OMG, David, you make global undervolt for ALL devices. You change global settings for LOW, NORMAL, HIGH presets. :o

I'm surprised that you did not freeze the device. You are risky. :blink:

Share this post


Link to post
Share on other sites

On Lens MIUI 2.2.3, with the 5% kernel, I have 41 fps, on 1000Mhz, same as default MIUI kernel.

I use Chainfire3D driver too.

Share this post


Link to post
Share on other sites

OMG, David, you make global undervolt for ALL devices. You change global settings for LOW, NORMAL, HIGH presets. :o

I'm surprised that you did not freeze the device. You are risky. :blink:

	F_BASIC(192000000, PLL1,  4, NOMINAL),

	F_BASIC(245760000, PLL3,  3, NOMINAL),

	F_BASIC(384000000, PLL1,  2, NOMINAL),

	/* Sync to AXI. Hence this "rate" is not fixed. */

	F_RAW(1, SRC_AXI, 0, BIT(14), 0, 0, NOMINAL, NULL),

	F_END,
int soc_update_sys_vdd(enum sys_vdd_level level)

{

	int rc, target_mv;

	static const int mv[NUM_SYS_VDD_LEVELS] = {

		[NONE...LOW] = 800,

		[NOMINAL] = 900,

		[HIGH]    = 1000,

	};

Edited by davidevinavil

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×