• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[APP] Google Wallet (APK/CWM ZIP: 1.1-R41v8) [18/12/2011]

23 posts in this topic

Posted (edited) · Report post

Read me first!

There are currently two ways of installing Google Wallet on your Galaxy Nexus. I highly recommend the APK method above the older ZIP method. For instructions on the ZIP method, please email me.

APK method

Prerequisites

You need:


  1. Pull down the notification bar and hit the settings icon next to the date. Then choose "About phone" at the bottom. If "Android version" is NOT listed as "4.0.2", you need to update to a new version. Do that before continuing.

Now, what needs to happen next depends on where you are:

I'm not in the US!

If you're NOT in the US, you'll need to be rooted. Grab Market Enabler from the Android Market and install it.

Run Market Enabler and set yourself as "US T-Mobile".

Now follow the US instructions.

I'm in the US!

Open the Wallet APK on your phone e.g. using ASTRO/File Expert/Root Explorer/the download manager.

Now just open Wallet, and it should correctly authorise.

Troubleshooting

Secure Element not responding!

If you have a Nandroid backup of a version of Wallet that worked, try restoring to that. Otherwise, you're screwed unless you get a new device. The Secure Element in your phone has now locked you out.

Insufficient Privileges. Insufficient secure element privileges for this system image (release-keys)

Err, what? This should only occur if you previously used the ZIP method. If so, you'll need to manually restore the old versions of the files.

This can be achieved by either restoring a Nandroid backup from before you flashed OR by following instructions in this post.

I have something not answered here!

Post in this topic and it'll probably get answered pretty quickly.

Changelog

18/12/2011

Removed old ZIP method. APK should work for most people.

Rewrote OP from scratch. 

Edited by lukegb
1

Share this post


Link to post
Share on other sites

Posted · Report post

New stuffUpdated to 1.1-R41v8 and committed to updating this forum as well as XDA. Hi, paul! :P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Nice work, thanks!

Still trying to work out how to top up my prepaid card from the UK! :blink:

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

can this be added to the kitchen?

thanks

A

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm unfortunately getting force closes whenever trying to add a prepaid card.

Any info I can send to help?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Sorted it. Wiped all application data and then tried again.

I think it was because I lost signal in the middle of adding it last time for a few seconds.

Now... Greggs you say Paul? :D

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Just tried the new build in Subway, phone connected with the payment reader then Wallet reported that it had to close.

-- logcat

W/ActivityManager( 209): Unable to launch app com.google.android.apps.walletnfcrel/10060 for broadcast Intent { act=android.net.conn.CONNECTIVITY_CHANGE flg=0x10000010 (has extras) }: process is bad

W/ActivityManager( 209): finishReceiver called but none active

D/PicasaSyncManager( 1244): active network: NetworkInfo: type: WIFI[], state: CONNECTED/CONNECTED, reason: (unspecified), extra: (none), roaming: false, failover: false, isAvailable: true

D/PicasaSyncManager( 1244): background data: true

E/TelephonyManager( 459): Hidden constructor called more than once per process!

E/TelephonyManager( 459): Original: com.google.android.location, new: com.google.android.gsf

D/StatsUploadService( 459): Upload disabled

I/MediaUploader( 1228): No need to wake up

W/ActivityManager( 209): Unable to launch app com.google.android.apps.walletnfcrel/10060 for broadcast Intent { act=android.net.conn.CONNECTIVITY_CHANGE flg=0x10000010 (has extras) }: process is bad

W/ActivityManager( 209): finishReceiver called but none active

D/PicasaSyncManager( 1244): active network: NetworkInfo: type: WIFI[], state: CONNECTED/CONNECTED, reason: (unspecified), extra: (none), roaming: false, failover: false, isAvailable: true

D/PicasaSyncManager( 1244): background data: true

Edited by gavinlew
0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm getting "Insufficient Privileges. Insufficient secure element priviliges for this system image (release-keys). Please contact Google Support."

Installed, Booted, Rebooted, Fixed Permissions, Boot.

Suggestions?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I am having a little problem with Google Wallet. I had it working fine on my GSM 4.0.1 GN but then updated to 4.0.2. I had to wipe everything before updating (long story) and redid the procedure to install Google Wallet. It runs fine but I am unable to add the prepaid card to the phone. I get the E-Mail from Google whenever I attempt to add the card but it just returns an error.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I am having a little problem with Google Wallet. I had it working fine on my GSM 4.0.1 GN but then updated to 4.0.2. I had to wipe everything before updating (long story) and redid the procedure to install Google Wallet. It runs fine but I am unable to add the prepaid card to the phone. I get the E-Mail from Google whenever I attempt to add the card but it just returns an error.

Are you using a normail gmail account or an Apps account? Apps doesnt work properly with Wallet.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Are you using a normail gmail account or an Apps account? Apps doesnt work properly with Wallet.

It's a normal GMail account

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm a little confused. I flashed the "googlewalletfix_1.1R41v8_ICS_aok_galaxynexus" file in Recovery first. After, I followed the steps, and in adb i got an error when trying to do step 4:

Run adb pull /data/system/packages.xml packages.xml

error: device not found

what gives?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Enable USB debugging in developer settings

0

Share this post


Link to post
Share on other sites

Posted · Report post

Rewrote the first post from scratch.

1

Share this post


Link to post
Share on other sites

Posted · Report post

Rewrote the first post from scratch.

Nice. Any suggested method for those who flash zip after IrX? I have been doing so since Ir3. Was thinking to wait for Paul to add the apk to kitchen and then do full wipe flash.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Edit: Nevermind

Edited by Ryands991
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Which Market Enabler are people using? There are two, and neither seem to work?

**EDIT** If anyone else needs, I used this one in the end -

https://market.android.com/details?id=com.vicono.AndroidMarketEnabler

So, seems to work. Next problem, how do we top up? :)

**EDIT2** Also, I see we have to have the Market set to T-Mobile US to use it too :(

Edited by AndyCr15
0

Share this post


Link to post
Share on other sites

Posted · Report post

...

Open the Wallet APK on your phone e.g. using ASTRO/File Expert/Root Explorer/the download manager.

Now just open Wallet, and it should correctly authorise.

...

I presume that this line about opening the apk in some file manager is just a fancy way of saying "install the apk",

and that a simple old 'adb install com.google.android.apps.walletnfcrel-2.apk' will work just as well?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Nice work, thanks!

Still trying to work out how to top up my prepaid card from the UK! :blink:

P

I'm curious...what method did you use to initially load Wallet and get it working?

I flashed the zip package from within recovery soon after the Ir3 flash pre initial boot. Have since no-wipe (other than d cache only) flashed Ir4 and Ir5 each time with same Wallet zip afterwards pre-boot and run Wallet error free for weeks.

In light of others who report on XDA they have Secure Elements issues I respect your thoughts and comments on this development.

Respectfully,

MoDaCo Kitchen User

0

Share this post


Link to post
Share on other sites

Posted · Report post

Not working. Did the whole packages.xml things and everything went smoothly. I installed the apk and now it just force closes. Doesn't even give me an error.

1

Share this post


Link to post
Share on other sites

Posted · Report post

Not working. Did the whole packages.xml things and everything went smoothly. I installed the apk and now it just force closes. Doesn't even give me an error.

Ditto, packages was fine but this version gives secure elements error.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ditto, packages was fine but this version gives secure elements error.

I can't even get an error. It just force closes the second the application is launched.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Guys Ive got it installed and the us t mobile market enabled at the moment. Running wifi trying to add the google prepaid card?

It keeps either Not doing anything at all, or just gives me an error. No error code given.

Ive restarted, reinstalled,cleared data and cache... still no joy!

Anybody got any tips?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.