• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

2g doesn't work

1 post in this topic


I've tried several roms with my brothers' U8800 and 2G doesn't work with any of them.3G works perfectly.I've tried several versions of MIUI and the latest 2.3.5 rom from Huawei(which I'm currently on).When I switch to 2G the device finds all 2G networks from all providers but doesn't connect.I've only tried to connect to the provider of the sim, however.

When I restart the device in 2G only mode it tells me that the selected network is not available.2G works perfectly with my other phones.

Also, after a day of use with the MIUI roms the device locks itself in the Airplane mode.I cannot turn it off and to fix it I must restart the device.Then 3G works again.Don't have this problem with other roms.

The device is bought from Elisa Finland but I doubt they have locked the device because 3G works.Perhaps it's Superboot causing this?It's also quite hard to get into Clockwork Recovery.With my ZTE Blades I have no issues but with the U8800 it often takes several tries from cold.Works well when using an app to boot into Clockwork Recovery though.


On the other note the battery completely dies when drained fully.It won't charge.I have an external charger purchased with 3 extra LI-ON batteries from eBay and the external charger manages to revive the battery (It recharges it very slowly).I'm guessing it dies because the original battery is a LI-PO, not LI-ON, the battery is faulty or the battery stats just need to be wiped.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.