• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Compass problem in Fish&Chips ROM?

17 posts in this topic

Posted (edited)

I've found that compass doesn't work correctly. E.g. app google sky map is useless - I can turn arround and map's still showing East.I've tested it (*983*0#) and sensors are OK, but compass data doesn't look OK - X=13, Z=-45. Phone on the table. Also accelerometer still shows data in one axis. Is it normal? Or is any application for calibration? If I press "calib" in sensor test it shows "proximity calibration is OK".

Edited by soami
0

Share this post


Link to post
Share on other sites

Posted

I noticed Sky Maps behaving a bit strangely too. The sky seemed to be turning the opposite way to the way I was turning.

0

Share this post


Link to post
Share on other sites

Posted

just to be sure try "tricorder" a very light app that displays all the sensor info. and report your findings here :).

PS- accelerometer will always show a result even when still... This explained by what you should have learned in your first ever physics class lol

0

Share this post


Link to post
Share on other sites

Posted

Yes, exactly. It goes opposite way (or showing eastwards). You can see on picture - phone was horizontally on the table but values of compass are strange.I'd appreciate any advice.

post-942144-0-77195200-1327852002_thumb.

0

Share this post


Link to post
Share on other sites

Posted

just to be sure try "tricorder" a very light app that displays all the sensor info. and report your findings here :).

PS- accelerometer will always show a result even when still... This explained by what you should have learned in your first ever physics class lol

I thought that accelerometer automatically corrects 1G from one axis. I read about it in other forum, so my mistake :)

0

Share this post


Link to post
Share on other sites

Posted

I thought that accelerometer automatically corrects 1G from one axis. I read about it in other forum, so my mistake :)

It might correct itself... i dont know lol.

i assumed it didn't.

are you using the TMV or the SF2?

0

Share this post


Link to post
Share on other sites

Posted

It might correct itself... i dont know lol.

i assumed it didn't.

are you using the TMV or the SF2?

TMV. Your ROM is really perfect and this is the only issue I have. It's nothing important I just like to know what's wrong...

0

Share this post


Link to post
Share on other sites

Posted

I downloaded 2 random compasses and they seemed to be showing north correctly. The compass in tricorder was pointing east though.

0

Share this post


Link to post
Share on other sites

Posted

TMV. Your ROM is really perfect and this is the only issue I have. It's nothing important I just like to know what's wrong...

is this maybe included in the recent update? Because i used the stock TMV ROM for both versions of Fish and Chips and havent had this issue.

I suppose the easy way to find out is to update it and try it. :) anyone having this problem on the SF2 version?

0

Share this post


Link to post
Share on other sites

Posted

Hi all,

just checked my my SF2 compass and it seems to be having the same issue, three different compasses and three different directions...odd...

HTH

Cheers surf

0

Share this post


Link to post
Share on other sites

Posted

Hi all,

just checked my my SF2 compass and it seems to be having the same issue, three different compasses and three different directions...odd...

HTH

Cheers surf

thanks. just checking :)

strange that it is playing up on the TMV. have any of the affected parties installed the firmware update?

0

Share this post


Link to post
Share on other sites

Posted

thanks. just checking :)

strange that it is playing up on the TMV. have any of the affected parties installed the firmware update?

I am on SF2. I think I had the same problem with Fish & Chips v1 and v2.

0

Share this post


Link to post
Share on other sites

Posted

I reinstalled Crescent ROM and then RLS1 to check if there is compass OK. it wasn't. I flashed back Fish and Chips RLS2 and made again sensor test. Compass still doesn't work properly but compass data are different - phone was in same position.

post-942144-0-04924600-1328104512_thumb.

post-942144-0-24451300-1328104519_thumb.

0

Share this post


Link to post
Share on other sites

Posted

I reinstalled Crescent ROM and then RLS1 to check if there is compass OK. it wasn't. I flashed back Fish and Chips RLS2 and made again sensor test. Compass still doesn't work properly but compass data are different - phone was in same position.

When you say Cresent ROM, do you mean the stock Orange/T-Mobile ROM?

0

Share this post


Link to post
Share on other sites

Posted

No, it was "Flibblesan FLB2-R1", very first modified ROM I found here.

0

Share this post


Link to post
Share on other sites

Posted

Hmm, would be interesting to see if the stock ROMs work OK? Looking through the stock rom thread it seems some new ones have been released recently. I wonder if they fix an issue with the compass?

0

Share this post


Link to post
Share on other sites

Posted (edited)

I can try evening. I've got downloaded stock ROM but I forgot to try it yesterday...

Edit: In stock ROM no change - same situation as in custom ROMs. I'm using "Ulysse Gizmos compass" and it works fine. So my only problem is skymaps which is unimportant.

Edited by soami
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.