• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[Tool][Linux] ZTE Porting Tool [v5.0 - Update - Jelly Bean support]


89 posts in this topic

Posted

New Version up!

0

Share this post


Link to post
Share on other sites

Posted

New Version up!

means that I can also port a rom from blade to skate?

0

Share this post


Link to post
Share on other sites

Posted

Yes

0

Share this post


Link to post
Share on other sites

Posted

Thank you very very much. I will try very soon ...! :)

There is a legendary rom I would try. Next week I hope to have good news ...

0

Share this post


Link to post
Share on other sites

Posted

what are the fixes then? does it port more things now to make the rom more stable?

0

Share this post


Link to post
Share on other sites

Posted

...and Skate support

0

Share this post


Link to post
Share on other sites

Posted

Nice tool :) Do you plan on adding all the ZTE "budjet" handsets like the Crescent and racer?

0

Share this post


Link to post
Share on other sites

Posted

Yes, that would be likely, as it is a ZTE Porting Tool.

But we need testers, because I only own a Blade and 1/2 Skate...

0

Share this post


Link to post
Share on other sites

Posted

I change a part is this correct?

wget download.cyanogenmod.com/get/RC/update-cm-7.2.0-RC1-blade-signed.zip

echo "Unzipping..."

unzip update-cm-7.2.0-RC1-blade-signed.zip

cd ..

cd ..

0

Share this post


Link to post
Share on other sites

Posted (edited)

I'll upload all ROMs to my own server, to avoid Download Errors

Edited by XMasterNinni
1

Share this post


Link to post
Share on other sites

Posted

-------------------Porting Process---------------------------

Copying files...<META_INF>

cp: cannot stat `Blade/base_rom/META-INF': No such file or directory

Copying files...<boot.img>

cp: cannot stat `Blade/base_rom/boot.img': No such file or directory

Copying files...</system/bin>

cp: cannot stat `Blade/base_rom/system/bin/akmd2': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/am': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/bmgr': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/hci_qcomm_init': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/hciattach': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/ime': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/input': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/monkey': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/pm': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/qmuxd': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/hci_qcomm_init': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/rild': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/wpa_supplicant': No such file or directory

Copying files...</system/etc>

cp: cannot stat `Blade/base_rom/system/etc/bluetooth': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/dhcpcd': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/wifi': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/firmware': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/apns-conf.xml': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/dbus.conf': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/gps.conf': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/hosts': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/init.bt.sh': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/init.local.rc': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/init.qcom.bt.sh': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/init.goldfish.sh': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/media_profiles.xml': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/resolv.conf': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/sysctl.conf': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/vold.fstab': No such file or directory

Copying files...</system/lib>

cp: cannot stat `Blade/base_rom/system/lib/modules': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/hw': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/egl/egl.cfg': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/egl/libEGL_adreno200.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/egl/libGLESv1_CM_adreno200.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/egl/libGLESv2_adreno200.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/egl/libq3dtools_adreno200.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libauth.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libcm.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libdiag.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libdbus.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libdss.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libdsm.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libgsl.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libgstk_exp.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libmmgsdilib.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libmmipl.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libmmjpeg.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libnv.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/liboemcamera.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/liboncrpc.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libpbmlib.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libqmi.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libqueue.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libril.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libril-qc-1.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libwms.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libwmsts.so': No such file or directory

Editing build.prop...

cp: cannot stat `Blade/base_rom/system/build.prop': No such file or directory

Finished coyping...!

Zipping <port_rom>

zip warning: name not matched: META-INF

zip warning: name not matched: system

zip warning: name not matched: boot.img

zip error: Nothing to do! (try: zip -r Port.zip . -i META-INF system boot.img)

Your zip is here: /Blade/port_rom/port.zip

Just flash the zip in a Recovery

To finish, close the terminal now.

i keep getting this all the time, then it deletes everything?

1

Share this post


Link to post
Share on other sites

Posted

Please read the important note in the readme first...

First start the tool and type in your sudo password, then unzip the ROM you want to port to Blade/port_rom and continue. If there's an download error, just unzip a 2.3.5 or 2.3.7 ROM, that is currently working for the Blade to Blade/base_rom.

I'll fix this soon!

0

Share this post


Link to post
Share on other sites

Posted (edited)

yeh im doing everything normal but it still doesnt work it just keeps giving me the same results then deletes both the roms

also is it possible to port say like one of them chinese roms for the blade to make it english?

Edited by ironzy
0

Share this post


Link to post
Share on other sites

Posted (edited)

Next version comming soon!

You will can choose between two methods:

echo "Porting Tools for Basic ROM Porting "

  echo "------------------------------------------------ "

  echo

  echo "You can choose between two methods..."

  echo

  echo "Method A:"

  echo "-> All in All"

  echo "-> Only for ZTE Skate/ZTE Blade"

  echo "-> Automatically downloads the Stock/CM7 ROM"

  echo "-> Requieres Internet Connection"

  echo

  echo "Method B:"

  echo "-> Doesn not download anything"

  echo "-> Should work with every device"

  echo "-> You have to obtain the base_rom yourself"

  echo "-> Read the tips section first"

  echo "-> For advanced users"

  echo

  echo "  a = Method A  "

  echo "  b = Method B  "

  echo

  echo "  x = Exit"

I also added lot of other things, like an own Tips/Tricks Section...

Edited by XMasterNinni
0

Share this post


Link to post
Share on other sites

Posted

New Version coming today.

Features:

-> More friendly UI

-> Improved Porting Process (thx to sacat)

-> Add ZTE Crescent Support

-> Two methods (read previous page)

Screen:

bildschirmfotoam.pngbildschirmfotoam.png

0

Share this post


Link to post
Share on other sites

Posted

The download link goes to portingtool_v2.1.tar.gz, is that right?

0

Share this post


Link to post
Share on other sites

Posted

Nope it isn't...

I'll fix this, when I'm back at my computer in about 10minutes

0

Share this post


Link to post
Share on other sites

Posted

Hi Xmaster!

I've tried to port a ROM called H3 Blues without succes. a week before I've ported a ROM. The script finishes, i got the port.zip file 92.7 mb but after flashing in recovery i doesn't boot. It stays at the green android logo and the back button stays red. Any suggestions?

0

Share this post


Link to post
Share on other sites

Posted

H3 Blues worked for me. You're doing something wrong.

Are you sure you followed the instructions well and read the important note?

:mellow:

0

Share this post


Link to post
Share on other sites

Posted

H3 Blues worked for me. You're doing something wrong.

Are you sure you followed the instructions well and read the important note?

:mellow:

With Swedish Snow 7 base it works fine :wacko: it's a good ROM! dolby really catched me.. trying to fix WI-FI now :D

0

Share this post


Link to post
Share on other sites

Posted

ZTE V9 would be a great adiction to your device list.

0

Share this post


Link to post
Share on other sites

Posted

@Zunex

Yeah, for some reason, Swedish Snow libs are better for ports than Stock ones...

@HarryPirate

Well, a tab would be more tricky, because of the resolution...

I'm looking forward to add a batch resizer in next release.

0

Share this post


Link to post
Share on other sites

Posted

Jelly Bean support and v5.0 is here!

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hmm all times im trying to start porting tool on windows with cygwin im getting this error. I followed all steps on xda to install cygwin on windows.

post-954811-0-76521200-1343599958_thumb.

Edited by timoti111
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.