XMasterNinni

[Tool][Linux] ZTE Porting Tool [v5.0 - Update - Jelly Bean support]

Recommended Posts

Thank you very very much. I will try very soon ...! :)

There is a legendary rom I would try. Next week I hope to have good news ...

Share this post


Link to post
Share on other sites
ironzy    10

what are the fixes then? does it port more things now to make the rom more stable?

Share this post


Link to post
Share on other sites
raverrr    340

Nice tool :) Do you plan on adding all the ZTE "budjet" handsets like the Crescent and racer?

Share this post


Link to post
Share on other sites
XMasterNinni    110

Yes, that would be likely, as it is a ZTE Porting Tool.

But we need testers, because I only own a Blade and 1/2 Skate...

Share this post


Link to post
Share on other sites
Romu_Android    24

I change a part is this correct?

wget download.cyanogenmod.com/get/RC/update-cm-7.2.0-RC1-blade-signed.zip

echo "Unzipping..."

unzip update-cm-7.2.0-RC1-blade-signed.zip

cd ..

cd ..

Share this post


Link to post
Share on other sites
XMasterNinni    110

I'll upload all ROMs to my own server, to avoid Download Errors

Edited by XMasterNinni

Share this post


Link to post
Share on other sites
ironzy    10

-------------------Porting Process---------------------------

Copying files...<META_INF>

cp: cannot stat `Blade/base_rom/META-INF': No such file or directory

Copying files...<boot.img>

cp: cannot stat `Blade/base_rom/boot.img': No such file or directory

Copying files...</system/bin>

cp: cannot stat `Blade/base_rom/system/bin/akmd2': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/am': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/bmgr': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/hci_qcomm_init': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/hciattach': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/ime': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/input': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/monkey': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/pm': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/qmuxd': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/hci_qcomm_init': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/rild': No such file or directory

cp: cannot stat `Blade/base_rom/system/bin/wpa_supplicant': No such file or directory

Copying files...</system/etc>

cp: cannot stat `Blade/base_rom/system/etc/bluetooth': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/dhcpcd': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/wifi': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/firmware': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/apns-conf.xml': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/dbus.conf': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/gps.conf': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/hosts': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/init.bt.sh': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/init.local.rc': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/init.qcom.bt.sh': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/init.goldfish.sh': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/media_profiles.xml': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/resolv.conf': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/sysctl.conf': No such file or directory

cp: cannot stat `Blade/base_rom/system/etc/vold.fstab': No such file or directory

Copying files...</system/lib>

cp: cannot stat `Blade/base_rom/system/lib/modules': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/hw': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/egl/egl.cfg': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/egl/libEGL_adreno200.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/egl/libGLESv1_CM_adreno200.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/egl/libGLESv2_adreno200.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/egl/libq3dtools_adreno200.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libauth.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libcm.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libdiag.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libdbus.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libdss.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libdsm.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libgsl.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libgstk_exp.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libmmgsdilib.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libmmipl.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libmmjpeg.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libnv.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/liboemcamera.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/liboncrpc.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libpbmlib.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libqmi.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libqueue.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libril.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libril-qc-1.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libwms.so': No such file or directory

cp: cannot stat `Blade/base_rom/system/lib/libwmsts.so': No such file or directory

Editing build.prop...

cp: cannot stat `Blade/base_rom/system/build.prop': No such file or directory

Finished coyping...!

Zipping <port_rom>

zip warning: name not matched: META-INF

zip warning: name not matched: system

zip warning: name not matched: boot.img

zip error: Nothing to do! (try: zip -r Port.zip . -i META-INF system boot.img)

Your zip is here: /Blade/port_rom/port.zip

Just flash the zip in a Recovery

To finish, close the terminal now.

i keep getting this all the time, then it deletes everything?

Share this post


Link to post
Share on other sites
XMasterNinni    110

Please read the important note in the readme first...

First start the tool and type in your sudo password, then unzip the ROM you want to port to Blade/port_rom and continue. If there's an download error, just unzip a 2.3.5 or 2.3.7 ROM, that is currently working for the Blade to Blade/base_rom.

I'll fix this soon!

Share this post


Link to post
Share on other sites
ironzy    10

yeh im doing everything normal but it still doesnt work it just keeps giving me the same results then deletes both the roms

also is it possible to port say like one of them chinese roms for the blade to make it english?

Edited by ironzy

Share this post


Link to post
Share on other sites
XMasterNinni    110

Next version comming soon!

You will can choose between two methods:

echo "Porting Tools for Basic ROM Porting "

  echo "------------------------------------------------ "

  echo

  echo "You can choose between two methods..."

  echo

  echo "Method A:"

  echo "-> All in All"

  echo "-> Only for ZTE Skate/ZTE Blade"

  echo "-> Automatically downloads the Stock/CM7 ROM"

  echo "-> Requieres Internet Connection"

  echo

  echo "Method B:"

  echo "-> Doesn not download anything"

  echo "-> Should work with every device"

  echo "-> You have to obtain the base_rom yourself"

  echo "-> Read the tips section first"

  echo "-> For advanced users"

  echo

  echo "  a = Method A  "

  echo "  b = Method B  "

  echo

  echo "  x = Exit"

I also added lot of other things, like an own Tips/Tricks Section...

Edited by XMasterNinni

Share this post


Link to post
Share on other sites
XMasterNinni    110

New Version coming today.

Features:

-> More friendly UI

-> Improved Porting Process (thx to sacat)

-> Add ZTE Crescent Support

-> Two methods (read previous page)

Screen:

bildschirmfotoam.pngbildschirmfotoam.png

Share this post


Link to post
Share on other sites
Bruja    2

The download link goes to portingtool_v2.1.tar.gz, is that right?

Share this post


Link to post
Share on other sites
Zunex    15

Hi Xmaster!

I've tried to port a ROM called H3 Blues without succes. a week before I've ported a ROM. The script finishes, i got the port.zip file 92.7 mb but after flashing in recovery i doesn't boot. It stays at the green android logo and the back button stays red. Any suggestions?

Share this post


Link to post
Share on other sites
XMasterNinni    110

H3 Blues worked for me. You're doing something wrong.

Are you sure you followed the instructions well and read the important note?

:mellow:

Share this post


Link to post
Share on other sites
Zunex    15

H3 Blues worked for me. You're doing something wrong.

Are you sure you followed the instructions well and read the important note?

:mellow:

With Swedish Snow 7 base it works fine :wacko: it's a good ROM! dolby really catched me.. trying to fix WI-FI now :D

Share this post


Link to post
Share on other sites
XMasterNinni    110

@Zunex

Yeah, for some reason, Swedish Snow libs are better for ports than Stock ones...

@HarryPirate

Well, a tab would be more tricky, because of the resolution...

I'm looking forward to add a batch resizer in next release.

Share this post


Link to post
Share on other sites
timoti111    7

Hmm all times im trying to start porting tool on windows with cygwin im getting this error. I followed all steps on xda to install cygwin on windows.

post-954811-0-76521200-1343599958_thumb.

Edited by timoti111

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.