• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

XMOD: Region / Device / Root patched Google Wallet

763 posts in this topic

Posted (edited)

WARNING

If you plan to wipe your device, switch ROM on your device or otherwise do anything unusual (including 'clearing data' on wallet), it is highly recommended that you use the 'reset wallet' option in the Wallet app settings. Failure to do this could render Wallet inoperable on your device!

Is this to include dirty flashes of the same ROM?

I stopped using GW because I was running nighties on SynergyROM (TW) and it had become more of a pain to reset all the time. I know dirty flashing with it would wipe out GW. I'm running AOKP now. Is it safe to assume that dirty flashing with it will also wipe out the /system/app data?

Edited by clambert11
0

Share this post


Link to post
Share on other sites

Posted

I don't know about 3rd times a charm! Got GW running on my GNEX, Galaxy SIII (At&t) & Nexus 7. Just tried all the tricks I learned on my Galaxy Note II (At&T) and got as far as signing in to get the no secure element warning. Anyone else having any luck with the SGH I317?

0

Share this post


Link to post
Share on other sites

Posted

This version will not work on JB 4.2. New one coming soon? Thanks ^^

0

Share this post


Link to post
Share on other sites

Posted

Hey there. Any idea if the 'any credit/debit card' option is working with UK issued cards yet ?

It appears to have added and generated a virtual master card for me but a McDonalds turned me down :( [big sad face]

0

Share this post


Link to post
Share on other sites

Posted

I second the jellybean update.. been missing this app since I moved over to cm10 nightly. Any word on an update?

0

Share this post


Link to post
Share on other sites

Posted

I second the jellybean update.. been missing this app since I moved over to cm10 nightly. Any word on an update?

It works for me on JB 4.1.2. I'm running AOKP Milestone 1 FWIW.

0

Share this post


Link to post
Share on other sites

Posted

Hmmm, its not showing up on my apps list. Do you know what permissions it should have?

0

Share this post


Link to post
Share on other sites

Posted (edited)

I second the jellybean update.. been missing this app since I moved over to cm10 nightly. Any word on an update?

Working for me on CM10 Nightly 11-20-12. In the GW settings Reset Google Wallet and then Mod the build.prop

ro.product.model=Galaxy Nexus

ro.product.name=yakju

ro.product.device=maguro

wipe dalvik cache

UPDATE: after updating to CM10 Nightly 11-22-12 I started getting the Unfortunately Wallet has stopped during boot and when I tried to start the application. I then restored a number of previous roms that GW worked on and keep getting the same error. Did full wipe and resets when flashing. I have no clue what happened.

UPDATE II: Figured it out - The GW apk got renamed being appended with "- copy" Everything is working fine with CM10 Nightly 11-23-12

Edited by Hammermann
0

Share this post


Link to post
Share on other sites

Posted

Hmmm, its not showing up on my apps list. Do you know what permissions it should have?

rw-r--r-- Make sure to wipe dalvik cache too
1

Share this post


Link to post
Share on other sites

Posted (edited)

HI there,

Great work on this app.

Ive installed onto my SGS3 using push method app works fine.

I still get this error in Logcat:


E/DeviceCapabilityManagerImpl(16147): OperatorName=, Operator=23410, Product=m0x

x, Model=GT-I9300 not supported

Has anyone else found this problem?

Edit:

Oops gotta edit build.prop sorry guys ;)

Edited by luckyjames
0

Share this post


Link to post
Share on other sites

Posted

Hey guys, anyway to get this working on the Nexus 4? I have a US play account with US credit cards, but I'm in Bermuda and it's says it's not available in my region... not sure what I would need to do to get it working. I would appreciate any guidance.

0

Share this post


Link to post
Share on other sites

Posted

Updated to version 1.5-R87-v15! :)

P

2

Share this post


Link to post
Share on other sites

Posted

Any sign of UK cards working, Paul?

0

Share this post


Link to post
Share on other sites

Posted

Just installed this on my rooted Galaxy Note II by putting the apk in /system/app/ and /data/app/ and changing the permissions. Rebooted the phone and then unfreezed the app using Titanium Backup. It launches, gives me the setting up wallet, this may take 5 minutes. Then it crashes within a few seconds with unfortunate ly wallet has stopped working.

Any help would be appreciated!

0

Share this post


Link to post
Share on other sites

Posted

Just installed this on my rooted Galaxy Note II by putting the apk in /system/app/ and /data/app/ and changing the permissions. Rebooted the phone and then unfreezed the app using Titanium Backup. It launches, gives me the setting up wallet, this may take 5 minutes. Then it crashes within a few seconds with unfortunate ly wallet has stopped working.

Any help would be appreciated!

Having exactly the same problem, on the very same device.

0

Share this post


Link to post
Share on other sites

Posted

Installed on my Nexus 4 ... I had this when it first came out for the Galaxy Nexus and I had the $10 from Google ... Any idea why I don't have it now please?

Also I can't add any UK card :(

0

Share this post


Link to post
Share on other sites

Posted

The prepaid card was discontinued by Google...

P

0

Share this post


Link to post
Share on other sites

Posted

Just installed this on my rooted Galaxy Note II by putting the apk in /system/app/ and /data/app/ and changing the permissions. Rebooted the phone and then unfreezed the app using Titanium Backup. It launches, gives me the setting up wallet, this may take 5 minutes. Then it crashes within a few seconds with unfortunate ly wallet has stopped working.

Any help would be appreciated!

Having exactly the same problem, on the very same device.

the note2 is missing the correct libs for wallet to work.

you need a new (leaked) rom with them enabled

0

Share this post


Link to post
Share on other sites

Posted

Using r81 I had managed to get this installed and had two cards synced from my online Wallet account. After installing a new ROM and r87 I can get wallet working but it forever hangs on "Adding Card...". I've seen a few posts to this effect but no sign as to how or if it can be resolved?!

0

Share this post


Link to post
Share on other sites

Posted

The prepaid card was discontinued by Google...

P

So is this now useless for any new UK users?
0

Share this post


Link to post
Share on other sites

Posted

Yeah so what is point of having the region code removed if it only works in America with american cards lol

0

Share this post


Link to post
Share on other sites

Posted

Using r81 I had managed to get this installed and had two cards synced from my online Wallet account. After installing a new ROM and r87 I can get wallet working but it forever hangs on "Adding Card...". I've seen a few posts to this effect but no sign as to how or if it can be resolved?!

I know for me it's just a matter of editing the build.prop to make my SG3 look like a htc_jewel. After I do that I can I can add cards. When I'm done you just edit the build.prop back to my SG3 settings. Hopefully you were able to figure it out. I see the post is a day old.

0

Share this post


Link to post
Share on other sites

Posted

I know for me it's just a matter of editing the build.prop to make my SG3 look like a htc_jewel. After I do that I can I can add cards. When I'm done you just edit the build.prop back to my SG3 settings. Hopefully you were able to figure it out. I see the post is a day old.

I know nothing about this stuff but I'll have a go and see if it works on my Nexus 4 or completely borks it :-/ Thanks!
0

Share this post


Link to post
Share on other sites

Posted

I know nothing about this stuff but I'll have a go and see if it works on my Nexus 4 or completely borks it :-/ Thanks!

You need to be careful with Google Wallet. If you screw up it could render the secure element useless. Make sure you image backup (TWP or nandroid) with a clean install of GW. Also always reset GW before installing a new ROM. It's also not recommended to use TiBu to restore GW.

I'd wait to see what others say about the Nexus 4 before jumping into it myself. :) You've got bigger balls than me. :)

0

Share this post


Link to post
Share on other sites

Posted

No luck on the LG Optimus G (LG E-970 on AT&T) The permissions keep changing each time I reboot and the apk does not show up in Tittainium or the tray. I'm sure that running on ICS 4.0.4 is not helping. I was hoping that being a Nexus 4 in sheep's clothing it might have given me a glimps of working but not a hint. Any thoughts. Otherwise a very sharp phone for $99 at Best Buy!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.