KonstaT

[DEV][ROM][8.1.] CyanogenMod 10 (Android 4.1.2)

3135 posts in this topic

On the topic of MDP composition (the debug.composition.type=mdp setting), it appears that it doesn't work correctly because the MSM7227's MDP variant does not support premultiplied alpha. Well, I made the driver ignore the flag for premultiplied alpha. With this hack, MDP composition kind of works. Of course some parts of the UI look a little bit funky, though.

But the most importantly, performance differences between MDP composition and OpenGL (GPU) composition are not that clear. In some ways it's better with MDP, in others OpenGL composition performs better.

0

Share this post


Link to post
Share on other sites

I have an OLED Blade and the screen off animation is a bit buggy. The screen turns off with animation and then flashes on again for a second. Any solutions?

0

Share this post


Link to post
Share on other sites

Okay guys, I'm pretty much confused. Do you think I should flash the 16.11 or 18.11 and patch the other things manually? Where can I find e.g. the HQ-Youtube patch and how can I flash it? The same as flashing a custom rom?

Thanks

I would suggest go for 16.11 ROM. It is stable ROM with no issues with Camera app and even Youtube HQ works (may be S/W encoding), but it works. You don't need any other patch.

0

Share this post


Link to post
Share on other sites

I would suggest go for 16.11 ROM. It is stable ROM with no issues with Camera app and even Youtube HQ works (may be S/W encoding), but it works. You don't need any other patch.

Yes, I'm still using the 16.11 build plus YT HQ patch with some tweaks for better performance and UI smoothness.

Works very well.

0

Share this post


Link to post
Share on other sites

Thanks for the update......... 24.11 rom works okay for me...(some artifacts on camera video pre view, may try Camera ICS as posted previous, but don't use) wifi stable for me

Made some tweaks from a previous post....

"- Go to Settings->Developer options: click on the OFF button in the upper right corner (it must be ON). Scroll down and find "Window animation scale", "Transition animation scale" and "Animator duration scale" and change them to ".5x"."

Over clocked to 710Mhz - for me this is 100% stable..again thanks

Edited by twatter
0

Share this post


Link to post
Share on other sites

Here is quick summary of my FM radio experiment. These are the commits that I had (with some minor adjustments to get everything compiled).

Framework:

https://www.codeauro...3fc359317f72ee9

https://www.codeauro...594631624efe7e6

https://www.codeauro...0440552628cd431

si4708 driver from CM7:

https://github.com/C...e_fm_si4708.cpp

FM radio app from CAF:

https://www.codeauro...fs/heads/jb_rel

These are already merged in CM10:

https://www.codeauro...33e20f70dadb33d

https://www.codeauro...b0cc0ebbb004edf

FM radio is switched on in kernel but then gets stuck in for loop in framework. Nothing happening in the audio system. Any volunteers to add FM support? ;) Any ideas what I'm missing here?

In logcat:


D/FMRadio ( 1716): Load preferences

D/FMRadio ( 1716): =====================================================

D/FMRadio ( 1716): Country :1

D/FMRadio ( 1716): RadioBand :4

D/FMRadio ( 1716): Emphasis :1

D/FMRadio ( 1716): ChSpacing :1

D/FMRadio ( 1716): RdsStd :1

D/FMRadio ( 1716): LowerLimit :87500

D/FMRadio ( 1716): UpperLimit :108000

D/FMRadio ( 1716): =====================================================

D/FMRadio ( 1716): onCreate - Height : 800 - Width : 480

E/FMRadio ( 1716): bindToService: Context with serviceconnection callback

D/FMRadio ( 1716): onCreate: Start Service completed successfully

D/FMRadio ( 1716): FMRadio: onstart

D/FMRadio ( 1716): FMRadio: onresume

D/FMRadio ( 1716): Load preferences

D/FMRadio ( 1716): =====================================================

D/FMRadio ( 1716): Country :1

D/FMRadio ( 1716): RadioBand :4

D/FMRadio ( 1716): Emphasis :1

D/FMRadio ( 1716): ChSpacing :1

D/FMRadio ( 1716): RdsStd :1

D/FMRadio ( 1716): LowerLimit :87500

D/FMRadio ( 1716): UpperLimit :108000

D/FMRadio ( 1716): =====================================================

D/FMRadio ( 1716): Load preferences

D/FMRadio ( 1716): =====================================================

D/FMRadio ( 1716): Country :1

D/FMRadio ( 1716): RadioBand :4

D/FMRadio ( 1716): Emphasis :1

D/FMRadio ( 1716): ChSpacing :1

D/FMRadio ( 1716): RdsStd :1

D/FMRadio ( 1716): LowerLimit :87500

D/FMRadio ( 1716): UpperLimit :108000

D/FMRadio ( 1716): =====================================================

D/FMService( 1716): is A2DP device Supported In HALfalse

D/FMService( 1716): onstart

D/FMService( 1716): onBind

D/FMService( 1716): onCallStateChanged: State - 0

D/FMService( 1716): onCallStateChanged: incomingNumber -

D/FMService( 1716): onDataActivity - 0

D/FMService( 1716): ACTION_HEADSET_PLUG Intent received

D/FMService( 1716): mReceiver: ACTION_HEADSET_PLUG

D/FMService( 1716): ==> intent: Intent { act=android.intent.action.HEADSET_PLUG flg=0x40000010 (has extras) }

D/FMService( 1716): state: 1

D/FMService( 1716): name: Headset

E/FMRadio ( 1716): onServiceConnected: mCallback

E/FMRadio ( 1716): ServiceConnection: onServiceConnected:

D/FMService( 1716): fmOn: RadioBand :4

D/FMService( 1716): fmOn: Emphasis :1

D/FMService( 1716): fmOn: ChSpacing :1

D/FMService( 1716): fmOn: RdsStd :1

D/FMService( 1716): fmOn: LowerLimit :87500

D/FMService( 1716): fmOn: UpperLimit :108000

V/FMRadio ( 1716): enable: CURRENT-STATE : FMOff ---> NEW-STATE : FMRxStarting

D/FmTransceiver( 1716): Opened 40

D/FmTransceiver( 1716): turning on 1

D/fmradio_si4708( 1716): FMRadio on

D/FmTransceiver( 1716): Calling fmConfigure

V/FmConfig( 1716): In fmConfigure

V/FmConfig( 1716): fmConfigure() : FM Srch Alg : OLD

D/FMService( 1716): Analog Path is not supported

D/FMRadio ( 1716): Starting listener 40

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

V/FMRadio ( 1716): RxEvtList: CURRENT-STATE : FMRxStarting ---> NEW-STATE : FMRxOn

D/FMService( 1716): FmRxEvEnableReceiver

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMService( 1716): mReceiver.enable done, Status :true

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMService( 1716): setLowPowerMode: false

D/FMRadio ( 1716): Received <0>

D/FMService( 1716): setLowPowerMode done, Status :true

D/FMRadio ( 1716): Got READY_EVENT

D/FMService( 1716): mAudioManager.setFmRadioOn = true

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMService( 1716): In startFM

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

I/AudioService( 386): AudioFocus requestAudioFocus() from [email protected][email protected]

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMService( 1716): FM registering for registerMediaButtonEventReceiver

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

I/AudioService( 386): Remote Control registerMediaButtonIntent() for PendingIntent{4106d350: PendingIntentRecord{4124c8f0 com.quicinc.fmradio broadcastIntent}}

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMService( 1716): FMRadio: sending the intent

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

V/AudioService( 386): FM Intent received

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMService( 1716): mAudioManager.setFmRadioOn done

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FmRxRdsData( 1716): In rdsOn: RDS is true

D/FMRadio ( 1716): Received <0>

D/FmRxRdsData( 1716): In rdsOptions: rdsMask: 23

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMService( 1716): registerRdsGroupProcessing done, Status :true

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMService( 1716): enableAutoAF: true

D/FMRadio ( 1716): Received event. Count: 1

D/FmRxRdsData( 1716): In rdsOn: RDS is true

D/FMRadio ( 1716): Received <0>

D/FmRxRdsData( 1716): In enableAFjump: AFenable : true

D/FMRadio ( 1716): Got READY_EVENT

D/FmRxRdsData( 1716): Currently set rds_group_mask : 0

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FmRxRdsData( 1716): After enabling the rds_group_mask is : 0

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMService( 1716): enableAutoAF done, Status :true

D/FMService( 1716): setInternalAntenna done, Status :true

D/FMRadio ( 1716): Got READY_EVENT

D/FMService( 1716): getInternalAntenna: false

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>
In dmesg:

<6>[10-06 10:08:49.369999] [1716: quicinc.fmradio]snd_hph_amp_ctl:0

<6>[10-06 10:08:49.649999] [1716: quicinc.fmradio]snd_hph_amp_ctl:1

Any genius can take forward KonstaT's work regarding FM radio and make it functional on our Blade?

0

Share this post


Link to post
Share on other sites

how do get previous version of these roms tried the date they were released but on mediafile says not available.

0

Share this post


Link to post
Share on other sites

Double post :(

Edited by [email protected]
0

Share this post


Link to post
Share on other sites

how do get previous version of these roms tried the date they were released but on mediafile says not available.

Post #2564

0

Share this post


Link to post
Share on other sites

thanks deano! i see you got aokp rom and wbaw tpt but the rom requires 220mb system and wbaw tpt is 215mb how did you manage to get that on and also looking for a stable rom which is better konstat 9/10 or the one akops..Thanks for the link.

0

Share this post


Link to post
Share on other sites

thanks deano! i see you got aokp rom and wbaw tpt but the rom requires 220mb system and wbaw tpt is 215mb how did you manage to get that on and also looking for a stable rom which is better konstat 9/10 or the one akops..Thanks for the link.

215mb is more than enough for AOKP-CM10

0

Share this post


Link to post
Share on other sites

Hy,

Is anyone tried out MTP, and PTP connection? Because it always craches my Settings app, after i check one of this port communications :(

0

Share this post


Link to post
Share on other sites

Hey guys, I haven't been on the forums for a while...I see alot has happened which is great! :)

I've installed the latest version (24.11) and everything is working great except I'm experiencing a significant battery drain issue. In the screenshots attached, it appears that the "cell standby" is consuming a significant amount of battery. All data connections except cell signal are turned off (bluetooth, 3g, wifi), brightness is on minimum, no apps are running in background processes, I performed a clean install and I have used the search function but no one else appears to have this issue with the current version.

If anyone could provide suggestions or solutions to this problem, it would be greatly appreciated. :)

>I have an OLED GEN 2 TPT Blade.

post-795374-0-86684200-1354150731_thumb.

post-795374-0-72317900-1354150759_thumb.

0

Share this post


Link to post
Share on other sites

After installing this ROM I felt the battery was draining way too much. But after the second charge its really good, lasts all day long easily.

0

Share this post


Link to post
Share on other sites

Hey guys, I haven't been on the forums for a while...I see alot has happened which is great! :)

I've installed the latest version (24.11) and everything is working great except I'm experiencing a significant battery drain issue. In the screenshots attached, it appears that the "cell standby" is consuming a significant amount of battery. All data connections except cell signal are turned off (bluetooth, 3g, wifi), brightness is on minimum, no apps are running in background processes, I performed a clean install and I have used the search function but no one else appears to have this issue with the current version.

If anyone could provide suggestions or solutions to this problem, it would be greatly appreciated. :)

>I have an OLED GEN 2 TPT Blade.

seem like you phone is always awake.

0

Share this post


Link to post
Share on other sites
Hey guys, I haven't been on the forums for a while...I see alot has happened which is great! :)

I've installed the latest version (24.11) and everything is working great except I'm experiencing a significant battery drain issue. In the screenshots attached, it appears that the "cell standby" is consuming a significant amount of battery. All data connections except cell signal are turned off (bluetooth, 3g, wifi), brightness is on minimum, no apps are running in background processes, I performed a clean install and I have used the search function but no one else appears to have this issue with the current version.

If anyone could provide suggestions or solutions to this problem, it would be greatly appreciated. :)

>I have an OLED GEN 2 TPT Blade.

Try to install "BetterBatteryStats" from Play and it can show you what is consuming battery so much

0

Share this post


Link to post
Share on other sites

Early days yet (and I have seen Konsta's confirmation of no difference in WiFi etc. between recent versions) BUT..........

have upgraded from early version (28/09 I think) to 16/11. Noticed MASSIVE improvement in wireless signal performance at home. Constant signal connection in all rooms where previously would drop to 3G.

Will try over next few days, and then try out latest version and report back.

UK Orange San Fran, originally GEN1, TPT'd to GEN2.

2

Share this post


Link to post
Share on other sites

i have working camera but when i switch to camorder or pan i get lots of glitch on preview however when i play back video its o.k can see slight frame overlapping etc....anyone else camcorder o.k but camera work fine,,,,

0

Share this post


Link to post
Share on other sites

Again, same questions every page, answer is on the previous page and the page before and the page before that.......

Edited by elrond_bs
3

Share this post


Link to post
Share on other sites

Hi,

My phone is getting very slow those times. I'm not sure this is linked to the ROM (I'm using the latest build) but have the impression this is due to my SD card, as the icons for the applications moved to my SD can take more than 5 minutes to appear on my home screen after a reboot. I installed an app called "System Test" which tells me my writing speed to SD is 3.0 MB/s and reading speed is 1.0 MB/s.

So, two questions relative to that :

- Can anyone tell me if those values look normal, and if not, what they should normally be ?

- If I change SD card, knowing I'm using S2E, is there any way I can "clone" my current SD card to the new one, including the /sd-ext/ partition ?

Thanks for your support.

0

Share this post


Link to post
Share on other sites

Again, same questions every page, :angry: answer is on the previous page and the page before and the page before that.......

No wonder KonstaT is fed up with this. The real questions for real problems are lost in the countless useless posts, because you don't know how to use search or just read 1 or 2 pages back. :huh:

read thru 129-131 no issue of camcorder only people with wifi issue and battery drainage problem and people with camera problem to revert back to previous released rom.

Edited by mostertruck
0

Share this post


Link to post
Share on other sites

Hey guys, I haven't been on the forums for a while...I see alot has happened which is great! :)

I've installed the latest version (24.11) and everything is working great except I'm experiencing a significant battery drain issue. In the screenshots attached, it appears that the "cell standby" is consuming a significant amount of battery. All data connections except cell signal are turned off (bluetooth, 3g, wifi), brightness is on minimum, no apps are running in background processes, I performed a clean install and I have used the search function but no one else appears to have this issue with the current version.

If anyone could provide suggestions or solutions to this problem, it would be greatly appreciated. :)

>I have an OLED GEN 2 TPT Blade.

have you tried wipeing battery stat in clockwork.....charge battery full take off charge boot into clockwork wip battery...might help you.

0

Share this post


Link to post
Share on other sites

I am currently on Stock Gen2 TPT. So, the Partition layout is: 37.5MB cache, 220MB system, 162.5MB data. Now, everything is fine. No issues. ROM working greatly. But, I am thinking of upgrading to Custom Gen2 TPT. The Partition layout is: 38MB cache, 215MB system, 204MB data. And, there's something like "it will unlock your full RAM." I have the Dell XCD35. And, it says its possible to unlock full RAM. Joy, joy, joy. I am happy with a lot of things the custom TPT is providing. So, I just need to ask you all one thing, especially KonstaT. Should I or should I not upgrade? :wacko:

Note: When I access any "Info" app it says, usually, 90-100MB/412MB RAM available. Shite. Anyway, I atleast know that 'around' 512MB is unlocked on my Stock Gen2.

Please. Really badword confused here.

0

Share this post


Link to post
Share on other sites

Soz guys if I've missed something, but lots of posts on this and just moving back to my Blade. Is everything working as it should with the 2 latest roms!

0

Share this post


Link to post
Share on other sites

@ stephen m - some people have issues with wifi, try to see for youself, I had none. 24.11 has issues with video files playback, 18.11 is ok.

@ mostertruck - try the camera from 4.2 (for ARМ6, posted here) or Camera ICS

@ RZRV8 - it always shows around 420MB for 512MB RAM. The rest are reserved for the system, but are used. Unlocking of RAM is for some models with 256MB RAM, not for you. Use TPT to increase your internal memory (used for installing apps) - you need one with at least 160MB for system to use this ROM.

Edited by elrond_bs
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.