KonstaT

[DEV][ROM][8.1.] CyanogenMod 10 (Android 4.1.2)

3135 posts in this topic

New build up. I also made a trimmed gapps package.

cm-10-20120718-KonstaKANG-blade.zip

http://www.mediafire...70265jh2cwr6dg2

md5:97480ce21071c8baabbf4c2fef241b6a

gapps-jb-medium-20120711-signed.zip

http://www.mediafire...qats078fkd756ti

md5:e87b4bc9a419965f15af62823fbe4992

cm10-RIL-fix.zip

http://www.mediafire...23elkbjkllr5na5

md5:72c17b8e563f0198418a9d04feabd6e2

-new CM10 features merged (some will still force close)

-superuser included and working root access (pop-up keeps appearing even you've ticked remember, you can still flash the zip from superuser homepage)

-audio playback fixed

-RIL fix with flashable zip

-system size with medium gapps ~145mb

5

Share this post


Link to post
Share on other sites

Yep - this is the same as in ICS. The fix was to comment out line 310 ie.

wM.setCountryCode(country, true);

In telephony/java/com/android/internal/telephony/MccTable.java.

It's a very dirty hack but should at least allow telephony for now.

3

Share this post


Link to post
Share on other sites

-RIL fix with flashable zip (phone will force close/soft reboot until PIN in entered)

The RIL fix restarts my recovery when I try to flash it.

0

Share this post


Link to post
Share on other sites

its like fun on the move with builds..... let me try new build and post my opinion.....

0

Share this post


Link to post
Share on other sites

KonstaT in Tilal's thread he says project butter completed, maybe you can port it to our blade?

0

Share this post


Link to post
Share on other sites

KonstaT in Tilal's thread he says project butter completed, maybe you can port it to our blade?

Project butter is actually working on today's build, the thing is that without HW acceleration it still lags. But once that's working, things should be nice.

1

Share this post


Link to post
Share on other sites

Project butter is actually working on today's build, the thing is that without HW acceleration it still lags. But once that's working, things should be nice.

What do we need to make HW acceleration work? Libs?

0

Share this post


Link to post
Share on other sites

screenshot of new build CM10..... thanks to KonsTat and all my favourite developers who helped my slim developing rom(KonsTat)..... Amazing everything s working except.. u know all wt it is......

post-977121-0-36267000-1342625023_thumb.

post-977121-0-78168000-1342625032_thumb.

post-977121-0-69798300-1342625040_thumb.

post-977121-0-59209000-1342625044_thumb.

post-977121-0-75361400-1342625059_thumb.

Edited by flixblixclix
2

Share this post


Link to post
Share on other sites

What do we need to make HW acceleration work? Libs?

Prolly so...libs from qualcom...the eternal quest...

2

Share this post


Link to post
Share on other sites

Prolly so...libs from qualcom...the eternal quest...

They gave us the GPU libs though last time. We were OK on that front. :)

1

Share this post


Link to post
Share on other sites

Can someone make gen3 converter? ;P

Edited by themref
0

Share this post


Link to post
Share on other sites

Yep - this is the same as in ICS. The fix was to comment out line 310 ie.

wM.setCountryCode(country, true);

In telephony/java/com/android/internal/telephony/MccTable.java.

It's a very dirty hack but should at least allow telephony for now.

I added a patch for dirty hack to stop the phone from crashing. It's in the second post under frameworks/base.

I also updated the flashable patch.

cm10-RIL-fix.zip

http://www.mediafire...23elkbjkllr5na5

md5:72c17b8e563f0198418a9d04feabd6e2

2

Share this post


Link to post
Share on other sites

Can someone make gen3 converter? ;P

You can use the one from my CM9 thread.

2

Share this post


Link to post
Share on other sites

don't know if it's anything related with the rom, but i cannot move any apps to sdcard - anyone having the same issue ? tried formatting sdcard completely, both from rom and also from recovery - also, "system" under system settings fc - normal at this stage ?

0

Share this post


Link to post
Share on other sites

don't know if it's anything related with the rom, but i cannot move any apps to sdcard - anyone having the same issue ? tried formatting sdcard completely, both from rom and also from recovery - also, "system" under system settings fc - normal at this stage ?

I am also facing this problem with moving applications to sd. I also notice there was 2 gallery and camera apps so I removed gallery2.apk from system. I also can't access the wallpapers from launcher. RIL is working fine tho, nice work konstat.

Edited by Hayden3430
0

Share this post


Link to post
Share on other sites

I am also facing this problem with moving applications to sd. I also notice there was 2 gallery and camera apps so I removed gallery2.apk from system. I also can't access the wallpapers from launcher. RIL is working fine tho, nice work konstat.

I might have to update the sdcard path to jb standards.

Which gapps did you install? It should replace the AOSP gallery with Google gallery.

I removed all wallpapers from the launcher (saved me ~10mb from system) and live wallpapers are also removed. You can choose wallpapers from the gallery.

1

Share this post


Link to post
Share on other sites

I might have to update the sdcard path to jb standards.

Which gapps did you install? It should replace the AOSP gallery with Google gallery.

I removed all wallpapers from the launcher (saved me ~10mb from system) and live wallpapers are also removed. You can choose wallpapers from the gallery.

I did have the same issue with double camera/gallery icons using the GApps from the first post.

0

Share this post


Link to post
Share on other sites

I did have the same issue with double camera/gallery icons using the GApps from the first post.

Yeah, it seems they're both there. I don't have duplicated icons though. You can remove the Gallery2.apk from system if you like.

I'll update the gapps package sometime later. 'Official' jb gapps was released to goo.im today.

1

Share this post


Link to post
Share on other sites

I did have the same issue with double camera/gallery icons using the GApps from the first post.

Yeah I also used your medium gapps that are in the first post, the gallery2.apk wasn't working but the other one did so I removed the gallery2 to avoid confusion. Seeing as your the only one porting cm10 to the blade this time, I think it would be better to include a pure cyanogemod build, instead of slim, just a thought though.

0

Share this post


Link to post
Share on other sites

Seeing as your the only one porting cm10 to the blade this time, I think it would be better to include a pure cyanogemod build, instead of slim, just a thought though.

There is instructions in the second post for you to compile 'pure cyanogenmod' if you like - we'll never have an official build. Full CM10 build and full JB gapps won't probably even fit stock /system partition size on Blade, so...

I'm not a fan of bloat. It doesn't matter if it's bloat from your phone manufacturer, carrier or custom ROM maker.

3

Share this post


Link to post
Share on other sites

I have read on some posts saying that the phone won't connect to networks unless you use command line in the terminal app. Just want to know if i can receive calls and also call someone with the latest build?

0

Share this post


Link to post
Share on other sites

the builds in this thread are not for daily use. I suggest you read all of the posts and especially the first one which say this is only for advanced users

0

Share this post


Link to post
Share on other sites

the builds in this thread are not for daily use. I suggest you read all of the posts and especially the first one which say this is only for advanced users

and also " This is mainly for developers/testers"

0

Share this post


Link to post
Share on other sites

You can use the one from my CM9 thread.

Confirmed.

Three generations old and these libs are working fine even now. :)

Edited by Snap.IT
1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.