• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance) CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission) ROMs must give full credit to the original author ISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Won't go into clockwork recovery

8 posts in this topic

I have done an unlock to a ZTE crescent using one of the guides which has given me:

  • Android 2.3.5
  • Kernel of
  • Build number r0_de-branded_blade2

Since doing this my keyboard is not right and driving me crazy. 10 min to type a four sentence SMS. I installed Go Keyboard, which helped a lot, but was not able to change my ROM.

The ROM isn't presently changeable as I can't get into clockwork. If I try to enter recovery from off (power + down volume) I go into FTM. If I use Quickboot to reboot to recovery it hangs at the Green Android dude.

I have both Recovery Manager and ROM Manager installed. I've tried both with no luck to reinstall clockwork. Recovery Manager only ever says "currently installed recovery: unrecognized". ROM Manager was able to download and install ClockworkMod, but will not boot into it. On an aside here-ROM Manager shows a full phone list on their site, but not the app. The app list only shows about ten phones and I none of them are the right ClockworkMod for the crescent. So, when I go back to Recovery Manager and install (both or there I get the unrecognized problem and can't boot into recovery.

I'd really like to try a new ROM so I don't throw this phone at the wall out of frustrations with typing.


Share this post

Link to post
Share on other sites

sounds like clockworkmod recovery is not yet installed.

look over the forum on how to install it.

Fastboot it over is favorite.

or you could TPT it, but this will delete the entire phone's operating system (rom) so quite destructive.

It will also re-partition the phone. So if you do this then you need to have another rom ready to install and consider the partition sizes for the rom your going to use.

Be careful to use the correct files in the right manner or you risk bricking the phone.

Good Luck



Share this post

Link to post
Share on other sites

installing clockworkmod was part of the unlock... or so I beleive. I can't recall which process I followed, might have been this one:

but all require the clockworkmod install, don't they?


Share this post

Link to post
Share on other sites

in attempting to do this the fastboot method as shown here: http://sanfranciscoandroid.co.uk/android/how-to-install-clockworkmod-recovery-on-the-orange-san-francisco-ii-zte-crescent/ I've gotten nowhere. With windows XP it went to the green guy again, but no joy for 15-20 min. Just hung there. For some reason the mac utility can't see the crescent. Hrmph... :(


Share this post

Link to post
Share on other sites

yeah I've not had a great deal of luck fastbooting with windows. (driver problems etc)

works well under linux (ubuntu), but seems not many have access to such a setup.

there is always this method:

then failing that TPT it, but have another rom ready to flash.


Share this post

Link to post
Share on other sites

right OK, worked on getting Crescent working with fastboot and windows XP tonight.

Try this out:

Disconnect phone from Windows XP machine

first download this: http://rollestonpark...ZTE-Cresent.rar

extract and install (this is the driver for crescent when it's booted up properly, you may have already done this part)

now i'd normally say install the android sdk with platform-tools this is large and you actually only need adb and fastboot

These are zipped here: http://rollestonpark...drivers/adb.zip unzip to a folder.

However these files may depend on other stuff in the android sdk (not sure on this) so they may not work on their own (but can try)

check phone is on and booted up and usb debugging set to on.

Plug in phone

open a command prompt and goto the location where the adb file is

type: adb devices

if driver is OK then your phone should be listed

Extract this zip to a folder somewhere: http://rollestonpark.../usb_driver.zip

now this driver is for when the phone is in bootloader mode.

type at the command prompt: adb reboot bootloader

wait a few moments for green android

windows should now say that it needs a driver

navigate through the menus and get it to load the driver from the folder from usb_driver.zip file

OK, so now you should have the driver working in bootloader.

at the command prompt where fastboot is, type: fastboot devices

something random should come up (meaning it can see the phone)

if your still unsure if fastboot can see your phone, then type: fastboot reboot

this should reboot the phone. If so then do: adb reboot bootloader (after phone has booted up)

OK so now have your recovery.img file ready in the same folder as fastboot

This will flash Clockworkmod recovery:

fastboot flash recovery name-of-recovery-file.img

if that went OK, then type: fastboot reboot

this should boot you phone backup again

Now shutdown and press and hold vol- and power to get into CWM recovery.

Make sure you using the right recovery file for your phone and that it ends in .img

Hope this helps


Edited by chris231

Share this post

Link to post
Share on other sites

After three days struggle, I finally found out what was stopping this working for me.

I am running CyanogenMod9 IceCreamSandwich. Under Settings: Developer options: there is an entry "Root access". This was set to "Apps only" and that was the cause of my problems. I didn't have su rights to the system. Simply changed to "Apps and ADB in there and suddenly everything works. :)

Maybe this is an explanation for others in difficulty?


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.