• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Default Storage ICS Rom

14 posts in this topic

Posted

When I change the default storage to SD card on 926 and 934 after a while and always on a reboot it returns to Internal storage.

ANy app on the card then gives app not installed message when trying to open.

Its a nusaince but any help to resolve would be appreciated.

0

Share this post


Link to post
Share on other sites

Posted

Try to reboot as soon as you have changed storage

0

Share this post


Link to post
Share on other sites

Posted (edited)

This problem has bugged me in all ICS versions and I've tried many things to fix it but none seem to work. I am now using Infusion rom which when installed was defaulted to Internal storage but after changing it to sdcard it has stayed on sdcard even after many reboots.

Edited by Cyda
0

Share this post


Link to post
Share on other sites

Posted

I'm having this issue too. I have tried using Infusion to solve the problem, but so far it hasn't worked.

0

Share this post


Link to post
Share on other sites

Posted

Same s***... I hate when it changes to internal...

0

Share this post


Link to post
Share on other sites

Posted

i found that this problem is caused by the SDcard... i was setting up two G300's and noticed one reset back to internal storage after a reboot, where as the other never...

i backed up the SDcard then formatted it in windows as fat32, that fixed the problem for me :D

0

Share this post


Link to post
Share on other sites

Posted

That can't be it. I've formatted my SD several times since having a B9xx build and have always had this issue.

0

Share this post


Link to post
Share on other sites

Posted (edited)

How do you change the default storage? I'm having problems getting ES Explorer to find the EXT SD card - it only sees the internal.

Just seen it's under Storage/Default

Edited by BillBong
0

Share this post


Link to post
Share on other sites

Posted

That can't be it. I've formatted my SD several times since having a B9xx build and have always had this issue.

it fixed the problem for me, not to mention this dose not happen for everyone...

like in my case, i had one that did not have the problem, and one one that did have the problem..

both different size and brand of SDcard... but both using the same rom...

if you have more than one SDcard or have a friend / family with an SDcard you could try testing them and see if is makes a difference,

i found that changing this can have it set the default storage to SDcard at boot (build.prop)


#/*Support ICS double sdcard. The value may be external_sd or internal_sd*/
persist.sys.main_storage=external_sd
[/CODE]

if it still defaults to internal storage with this set it probably means that the SDcard is no been recognised at boot, making it think its not there,

and defaulting back to internal starage

0

Share this post


Link to post
Share on other sites

Posted

It's true, it doesn't happen for everyone, I've never seen this happen, whenever I've changed to external it's always stayed that way.

0

Share this post


Link to post
Share on other sites

Posted (edited)

DO NOT TRY THIS, IT CAN BOOTLOOP YOUR PHONE!!

I had to restore from backup a few times trying to work this out.

I found that if I change the files in /system/etc external_sd.fstab to internal_sd.fstab and internal_sd.fstab to external_sd.fstab.

Then reboot my 32 GB SD card is mounted to /mnt/sdcard and the internal 2GB card is mounted to /mnt/sdcard2.

Now its working like I want but it I don't understand why?

Edit: I did this on the latest Infusion ROM.

Edited by cchalk
0

Share this post


Link to post
Share on other sites

Posted

it looks like this only happend in ICS 4.0

0

Share this post


Link to post
Share on other sites

Posted

I think the problem is that it takes Android marginally longer to mount a larger SD card, so it decides one isn't mounted and defaults to internal, until it does mount, when it gets set as SD2. It's infuriating and messes up my whole phone experience. Messing about with the fstabs will fix it, but it's a bit of a faff.

0

Share this post


Link to post
Share on other sites

Posted

hello all. I have flashed a few roms but don't really know what I am doing so forgive me..

My phone now has a virtual 2gb sd card in internal storage it's confusing me and my apps...

How can reset the internal memory ? Please?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.