• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM] RacerMod 1.7 [19/04/2013] CyanogenMod 7.2 port with 2.6.35.7 kernel & CWM Recovery 5.0.2.8

389 posts in this topic

Posted

whoa!! havent been to modaco for few weeks and just saw this!!

i've tried the 1.4 on my freddo and beside the wifi everything is perfect!!

thanks mikeioannina!!... ^_^

0

Share this post


Link to post
Share on other sites

Posted

i meant months not weeks.. lol

btw mine stable at 725.. ^_^d

0

Share this post


Link to post
Share on other sites

Posted

When I trie to enable wifi teathering the phone just reboot, even with other teathering software from playstore the result is the same, it reboot's

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi, you've done a very nice job there, your rom works really good, but i have a problem, it doesn't recognize my sim card, is this normal?, i've one of that weird racers with a different camera.

edit: that happened because your boot script detect my phone like a gen2 when it is a gen1, i just copied and renamed the gen1 boot file like gen2, and i forgot to do the same with the libs, i do this and everything works

i'll try it a few days and if i get a bug i'll report it

Edited by Aloxi Heiligsohn
1

Share this post


Link to post
Share on other sites

Posted

Hello, thank you for the excellent firmware. I have a few questions:

How to set the screen calibration in the original state it was when the firmware (software used for the calibration of the firmware - I do not like the result.)

What do you recommend settings for performance tuning.

thanks

Sorry for the google translate

0

Share this post


Link to post
Share on other sites

Posted

So far so good, it all has been working GREAT except for the screen sensitivity (it was better in the ROM I had previously, if I remember correctly, it was this one http://www.modaco.co...t-cm7-237-roms/ , but it was deleted) :/

One detail: the boot/check_generation.sh file is wrong for my phone (chilean zte racer gen1), so I had to modify it a bit, and replace "generation=2" with "generation=1"

This is the script I'm talking about:


#!/sbin/sh

check_gen1=`cat /proc/mtd | grep "mtd1: 0048"`

if [ "$check_gen1" != "" ]

then

echo "generation=1" > /tmp/gen.prop

else

echo "generation=2" > /tmp/gen.prop

fi

For the record:

# cat /proc/mtd

dev: size erasesize name

mtd0: 00500000 00020000 "recovery"

mtd1: 00500000 00020000 "boot"

mtd2: 00180000 00020000 "splash"

mtd3: 00080000 00020000 "misc"

mtd4: 02800000 00020000 "cache"

mtd5: 0dc00000 00020000 "system"

mtd6: 0a280000 00020000 "userdata"

mtd7: 01500000 00020000 "oem"

mtd8: 00180000 00020000 "persist"

Anyways, thank you VERY MUCH for your work!

1

Share this post


Link to post
Share on other sites

Posted

hi mike, i have use your 1.4 rom for my zte freddo for about two weeks now. the phone seems to be stable at 729mhz and somehow i like the sensitivity of the touchscreen.. feels almost like a capacitive touchscreen now.. lol

however i'd like to report some glitches that i have found:

1. wifi: as we all now, it isn't working yet.. :D

2. bluetooth: it works but sometimes you need to enable it couple of times.

3. screen orientation: works fine but sometimes it splashes a green screen before rotating from portrait to landscape and vice versa.. and sometimes the green screen is gone by itself.. not a big deal for me though..

4. i dunno which sensor that deal with this. i am using an app named google sky map for locating stars, etc. it seem like the compass on the phone only working when the phone is held flat but not working if the phone is held upward..

that is all that i have found so far but the phone is blazing fast now!!

great work mike and thanks.. you have given this old phone a new life... ^_^d

0

Share this post


Link to post
Share on other sites

Posted

Thanks for all the answers, I have not built a new version yet because I was busy during the holidays. I'm working slowly on RacerMod, don't think that I forgot you :P

3

Share this post


Link to post
Share on other sites

Posted

Great to see you back mike!

1

Share this post


Link to post
Share on other sites

Posted

Hi Mike, I think the problem is that the screen goes white in the ics-dev kernel . When I was building a ICS with gingerbread kernel he don't boot at all ,but he doesn't go to white screen.

0

Share this post


Link to post
Share on other sites

Posted

Some download statistics from my website:

27 Dec 2012 - 15 Jan 2013

170 downloads/RacerMod-1.4-Racer.zip

93 downloads/gapps-gb-20110828-minimal.zip

69 downloads/CWM-5.0.2.8-1.3.zip

53 downloads/RacerMod-1.4-Carl.zip

16 downloads/RacerMod-1.3-Racer.zip

9 downloads/RacerMod-1.3-Carl.zip

I'm impressed by how many people download my rom but only very few participate in this thread.

3

Share this post


Link to post
Share on other sites

Posted

I'm impressed by how many people download my rom but only very few participate in this thread.

I actually installed your 1.4 version yesterday on my Gen1 Racer but hadn't got the time to test it very thoroughly. :) Some thoughts, though...

- The dock bar often disappears, for whatever reason.

- Using Google Maps for a few seconds didn't reboot the phone (used to happen A LOT on every 3D application, either it's fixed or maybe I just didn't stress it enough).

- Compcache still doesn't work (used swap stays at 0 after enabling and rebooting).

- I have to test if the selected wifi sleep policy is honoured (it wasn't on RacerBoy's versions, it always dropped the connection when the screen turned off even if "never" was selected).

- The touch screen precision is God-awful, but I think it uses closed libraries, so there's nothing that can be done about it (hopefully I'm wrong :P).

- Haptic feedback can be completely disabled with this kernel, yay!

- The answer button doesn't work in CWM 5.0.2.8, must enable the back button and use the power button to select menu entries.

That's mostly what I gathered after playing with it for five minutes. I didn't test GSM/UMTS connectivity, phone calls or SMS. Anyway, I must say this is looking really great. Thanks a lot for your work on a newer kernel for the ZTE Racer, it was sorely, sorely needed. :)

0

Share this post


Link to post
Share on other sites

Posted

- The dock bar often disappears, for whatever reason.

- Using Google Maps for a few seconds didn't reboot the phone (used to happen A LOT on every 3D application, either it's fixed or maybe I just didn't stress it enough).

- Compcache still doesn't work (used swap stays at 0 after enabling and rebooting).

- I have to test if the selected wifi sleep policy is honoured (it wasn't on RacerBoy's versions, it always dropped the connection when the screen turned off even if "never" was selected).

- The touch screen precision is God-awful, but I think it uses closed libraries, so there's nothing that can be done about it (hopefully I'm wrong :P).

- The answer button doesn't work in CWM 5.0.2.8, must enable the back button and use the power button to select menu entries.

Thanks for the feedback.

-You mean the launcher dock bar? It disappears for some unknown reason (maybe the bad touchscreen driver is related to this) Current solution is to install another launcher like LauncherPro

-We still don't have full 3D acceleration... In fact this is the part I spend most of my time to find out what's wrong and fix it but haven't found anything yet :(

-I haven't tried compcache because I spent all my time in fixing the bigger problems first

-I can't test anything about wifi because I don't own a Racer, I own a variant of Racer (ZTE Carl) that uses different wifi (which doesn't work with the newer kernel, no sources released from zte or any other manufacturer that work)

-The touchscreen calibration is bad. There is no good method to calibrate these older touchscreens in gingerbread. I've done my best to have a usable driver but it doens't work the same for all the people. In the next release I'll probably include a second touchscreen driver with disabled dual touch hacks and hope that it's working better.

-In CWM 5.0.2.8 I changed the buttons from answer/decline to home/back. These are the buttons that all other phones use in recovery.

2

Share this post


Link to post
Share on other sites

Posted

Thanks for the feedback.

-You mean the launcher dock bar? It disappears for some unknown reason (maybe the bad touchscreen driver is related to this) Current solution is to install another launcher like LauncherPro

-We still don't have full 3D acceleration... In fact this is the part I spend most of my time to find out what's wrong and fix it but haven't found anything yet :(

-I haven't tried compcache because I spent all my time in fixing the bigger problems first

-I can't test anything about wifi because I don't own a Racer, I own a variant of Racer (ZTE Carl) that uses different wifi (which doesn't work with the newer kernel, no sources released from zte or any other manufacturer that work)

-The touchscreen calibration is bad. There is no good method to calibrate these older touchscreens in gingerbread. I've done my best to have a usable driver but it doens't work the same for all the people. In the next release I'll probably include a second touchscreen driver with disabled dual touch hacks and hope that it's working better.

-In CWM 5.0.2.8 I changed the buttons from answer/decline to home/back. These are the buttons that all other phones use in recovery.

- this is the dock thing you talking about? http://forum.cyanoge...cons-disappear/

this is how I solved it: http://forum.cyanoge...ar/#entry111133

menu -> settings -> adw settings (or just straight to adw settings) -> UI settings and the second section down will be called "hidden dockbar", and right under that header the button next to "Dockbar" will be checked by default. Uncheck it.

- as I said, the calibration worked fine in other build. can you just take the settings from there? also, I noticed something: it works OK when pressing the screen quickly, but it doesn't when pressing "normally" (i.e., slowly). can it be too "reactive"? is there a setting to configure the speed to which the screen should react?

- also, the home, menu and back buttons seem to be badly configured. I'd say they are too below in the screen. when you press the top of them, you may end pressing objects in the screen.

I'd just ask the other devs here in this subforum or try copying their settings and see if they work.

Sorry if I wasn't too clear, english is not my first language and I don't know much about android dev.

I hope this helps.

0

Share this post


Link to post
Share on other sites

Posted

I actually installed your 1.4 version yesterday on my Gen1 Racer but hadn't got the time to test it very thoroughly. :) Some thoughts, though...

- The dock bar often disappears, for whatever reason.

- Using Google Maps for a few seconds didn't reboot the phone (used to happen A LOT on every 3D application, either it's fixed or maybe I just didn't stress it enough).

- Compcache still doesn't work (used swap stays at 0 after enabling and rebooting).

- I have to test if the selected wifi sleep policy is honoured (it wasn't on RacerBoy's versions, it always dropped the connection when the screen turned off even if "never" was selected).

- The touch screen precision is God-awful, but I think it uses closed libraries, so there's nothing that can be done about it (hopefully I'm wrong :P).

- Haptic feedback can be completely disabled with this kernel, yay!

- The answer button doesn't work in CWM 5.0.2.8, must enable the back button and use the power button to select menu entries.

That's mostly what I gathered after playing with it for five minutes. I didn't test GSM/UMTS connectivity, phone calls or SMS. Anyway, I must say this is looking really great. Thanks a lot for your work on a newer kernel for the ZTE Racer, it was sorely, sorely needed. :)

About compcache: you need to insmod the zram.ko, lzo_compress.ko and lzo_decompress.ko modules. Try that and report if it works

2

Share this post


Link to post
Share on other sites

Posted

I'll test your rom and send my feedback

:)

0

Share this post


Link to post
Share on other sites

Posted (edited)

I'm working on the kernel now. I downloaded the CAF msm kernel & comparing trees. Found the initial 2.6.32 kernel tree that ZTE started making changes from. Now I'm trying to find the 2.6.35 kernel initial branch, I'm close.

Hope that all this work will help me source the gralloc problem.

For anyone interested, here are the sources: https://github.com/mikeNG/android_kernel_zte_msm7x27-caf

Edited by mikeioannina
3

Share this post


Link to post
Share on other sites

Posted

Hello guys, I have a little surprise for you. :D

Gralloc problem is probably fixed!!!!!!! That means we have fully working CRT-on & CRT-off animations, working rotation animation & probably full hardware 3D acceleration.

I spent 6 days looking into the kernel source and I found a line that ZTE had commented out. I removed the comment and everything works now!

A new release is coming when I test everything, I've included a new touchscreen driver too, hope that it's better.

4

Share this post


Link to post
Share on other sites

Posted

Hello guys, I have a little surprise for you. :D

Gralloc problem is probably fixed!!!!!!! That means we have fully working CRT-on & CRT-off animations, working rotation animation & probably full hardware 3D acceleration.

I spent 6 days looking into the kernel source and I found a line that ZTE had commented out. I removed the comment and everything works now!

A new release is coming when I test everything, I've included a new touchscreen driver too, hope that it's better.

:o ..........

congrats mike :D ;)

0

Share this post


Link to post
Share on other sites

Posted

Thanks, Mike

Your ROM is the best of the ones I've tried

2

Share this post


Link to post
Share on other sites

Posted

OMG!! Wow!! :o

That's awesome mike!!

We appreciate your effort and your dedication!

1

Share this post


Link to post
Share on other sites

Posted

Well, there are still some issues, the screen is distorted for a little after the boot logo and before the bootanimation, but it works fine after the bootanimation.

2

Share this post


Link to post
Share on other sites

Posted

Does the digital compass work for Racer gen1?? this has always been a sticking point for me not to move away to CM7 based ROMs.

Richard S.

0

Share this post


Link to post
Share on other sites

Posted

it's amazing....

good work mike...thanks for the best rom

my phone like having a new life now :D

0

Share this post


Link to post
Share on other sites

Posted (edited)

Does the digital compass work for Racer gen1?? this has always been a sticking point for me not to move away to CM7 based ROMs.

Richard S.

I don't see a reasor for it not to work... on my phone it always worked.

Edited by mikeioannina
2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.