• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

ICS Build 940 Re-Root and No CWM - Manually Delete Files?

5 posts in this topic

Posted · Report post

Hi All,

Sorry for this long post, but I think it's necessary. I posted recently on this same topic, but I didn't really understand my situation, so didn't ask a very good question. I understand my situation better now, so it's worth re-asking (I think).

I've got my G300 running ICS 4.0.3 Build 940. I got this stage by upgrading from stock Voda GB 889 (I think) to ICS via the full update method here:

http://www.modaco.com/topic/357413-ics-repack-403-b940-u8815-ota-release-rom/

However, I cannot root the phone as there is no room left in the system area. This seems to be a common problem with 940. However, I do not have CWM installed, nor have I ever had it installed. I had rooted at stock GB, but obviously, that doesn't carry over.

I cannot install CWM without root (or can I?), so I need to find some way to clear some space in the /system area or find another full upgrade package which does provide enough room in the /system area for root to complete. My ultimate goal is to get back to stock Voda software, either GB or ICS.

So, I see three possible methods of achieving my ultimate goal of getting back to stock Voda GB or ICS. Any advice on any method would be very, very much apprciated.

  • Run a full update.app that takes me to a rootable version of ICS. Is this even possible now that I'm at ICS and don't have CWM? I think my bootloader is locked though as I'm at ICS, so would need someway of unlocking it, correct?
  • Somehow manually mount the /system on my Mac with read-write permissions and delete a few files (wallpapers?) and attempt a re-root, hopefully with enough room in /system to complete the job.
  • Obtain access to a Windows PC, run unlockbootloader.exe to partial root, and then install superuser.apk from Play store. I tried this with the Mac rooting scripts, but this did not work.
  • Attempt a root using the method described here, for gingerbread. This seems dangerous, but somebody recommended it, just very nervous as I only get one chance!

In summary, how to I root a device at ICS 4.0.3 build 940?

Thanks again,

Sam

0

Share this post


Link to post
Share on other sites

Posted · Report post

I had this problem a while back. I ended up flashing a different build of ICS via the update.app route.

When I did that it rooted no problem. I think it may have been 940 I was on too.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for giving me hope! Any idea which update.app you used?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I think I had 934 on the PC and used that but I think all of them were OK except for 940 as far as rooting goes.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi All,

I've solved the problem. So, for anybody else that has this issue, the thin end of the wedge approach works. I had to wipe a hard drive and install Windows on it to get it to work (vomit), but it has.

Use unlockbootloader.exe to do a partial root. I had to do this twice. The first time I didn't run as Admin in Windows 7, so that may have been the problem.

Install superuser.apk from Google Play

Install and run SuperUser Update Fixer from Google Play

I can't take credit for the fix, I got it from this thread on Moneysavingexpert of all places! (Check out post 709).

As I said, I did the whole process twice, but it finally worked!

Thanks for the other suggestions. I think I'll at CWM and then get back to stock Voda Ten years ago I would have loved to have been trying out all kinds of ROMs, but with 2 little ones, the time just isn't there, and if something goes wrong with the hardware, I need to be able to return it. Thanks again for your help.

-Sam

Edited by sjb2016
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.