snorkerz

Cheap Chinese phone won't download Apps

2 posts in this topic

I have just acquired a Jaiyu G1 running Android 2.3.6. The seller claimed it to be a MTK6515 but searching that on the web shows a different phone. This is the actual phone

post-1003070-0-96530200-1357228447_thumb

Unfortunately, it can not download any apps and after quite a while with the Amazon Appstore help-team it appears that the OS has been modified and is now unstable.

System Update & Build Number shows G1LMO 20120813-080659

Baseband: MAUI.11AMD.W11.50.SP.V14.P2, 2012/07/11 15:46

Kernel: 2.6.35.7 [email protected] #1 Thu Sep 6 20:45:46 CST 2012

Model JY-G1

Whenever I attempt to download an app I get

Sorry!

The application Browser (process com.androd.browser) has stopped unexpectedly.

Please try again.

[Force close]

I have a second (chinese) browser on the system which seems to get the same error - not sure because the dialog is in chinese. Have tried to download a different browser, but can't because I can't download!

I am totally new to Android, so although I am well versed in IT (my heritage goes back to DOS 5), I am looking for a relatively simple fix. I have no idea what 'rooting' is or any similar terms, so be gentle with me.

It would seem that if it were possible to install a clean (un modified) version of Android Gingerbread that would be the simplest solution - simply dump the existing buggy install. However, if that is not practical, any other suggestions would be much appreciated.

Edited by snorkerz
0

Share this post


Link to post
Share on other sites

Well, go to settings, applications,and tick the first box

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.