Sign in to follow this  
kyan31

[ICS][4.0.3]Lightning ROM For The Huawei Ascend G300 ★ADDONS AVAILABLE★ ✮CM-TOGGLES✮ ✰UPDATED 17/03/2013✰ DISCONTINUED

Recommended Posts

Ilfirin    0

Oh, I've seen that coming. All wiped, all working. I guess, I have to wait to five reboots to start zipaligns which (i guess) caused the problem. So we will wait.

Share this post


Link to post
Share on other sites
tillaz    2,790

forget it Tillaz smile.png but thanks any way, not work. I´m going to do the hard way. restore infusion and make a carbon backup smile.png

kayn would need to sign it with the same key has has signed the rom with for it to ever work

Share this post


Link to post
Share on other sites
tillaz    2,790

Oh, I've seen that coming. All wiped, all working. I guess, I have to wait to five reboots to start zipaligns which (i guess) caused the problem. So we will wait.

should be ok with those files removed, sure its the script causing the problem

#!/system/bin/sh
# Optimize SQlite databases of apps
# Taken from thunderbolt! by pikachu01 @ XDA
# Smart Optimizing by ImbaWind @ XDA
# Adrenaline Engine Specified


if [ -e /data/adrenaline/engine/etc/sq_c ]; then
echo "SQlite Counter File Exists"
CNT=/data/adrenaline/engine/etc/sq_c
SC=`cat $CNT`
if [ $SC -eq 0 ]; then
echo "1" > $CNT
echo "First Boot"
exit
elif [ $SC -eq 1 ]; then
echo "2" > $CNT
echo "Second Boot"
exit
elif [ $SC -eq 2 ]; then
echo "3" > $CNT
echo "Third Boot"
exit
elif [ $SC -eq 3 ]; then
echo "4" > $CNT
echo "Forth Boot"
exit
elif [ $SC -eq 4 ]; then
echo "Fifth Boot"
echo "Now Optimizing"
rm -f /data/adrenaline/engine/etc/sq_c
touch /data/adrenaline/engine/etc/sq_c
echo "0" > /data/adrenaline/engine/etc/sq_c
for i in \
`busybox find /data -iname "*.db"`;
do \
/system/xbin/sqlite3 $i 'VACUUM;';
/system/xbin/sqlite3 $i 'REINDEX;';
done;

if [ -d "/dbdata" ]; then
for i in \
`busybox find /dbdata -iname "*.db"`;
do \
/system/xbin/sqlite3 $i 'VACUUM;';
/system/xbin/sqlite3 $i 'REINDEX;';
done;
fi;


if [ -d "/datadata" ]; then
for i in \
`busybox find /datadata -iname "*.db"`;
do \
/system/xbin/sqlite3 $i 'VACUUM;';
/system/xbin/sqlite3 $i 'REINDEX;';
done;
fi;


for i in \
`busybox find /sdcard -iname "*.db"`;
do \
/system/xbin/sqlite3 $i 'VACUUM;';
/system/xbin/sqlite3 $i 'REINDEX;';
done;
fi;
else
touch /data/adrenaline/engine/etc/sq_c
echo "0" > /data/adrenaline/engine/etc/sq_c
echo "First Installation"
echo "Now Optimizing"
for i in \
`busybox find /data -iname "*.db"`;
do \
/system/xbin/sqlite3 $i 'VACUUM;';
/system/xbin/sqlite3 $i 'REINDEX;';
done;

if [ -d "/dbdata" ]; then
for i in \
`busybox find /dbdata -iname "*.db"`;
do \
/system/xbin/sqlite3 $i 'VACUUM;';
/system/xbin/sqlite3 $i 'REINDEX;';
done;
fi;


if [ -d "/datadata" ]; then
for i in \
`busybox find /datadata -iname "*.db"`;
do \
/system/xbin/sqlite3 $i 'VACUUM;';
/system/xbin/sqlite3 $i 'REINDEX;';
done;
fi;


for i in \
`busybox find /sdcard -iname "*.db"`;
do \
/system/xbin/sqlite3 $i 'VACUUM;';
/system/xbin/sqlite3 $i 'REINDEX;';
done;
fi;[/code]

Share this post


Link to post
Share on other sites
Moe29    0

the stock browser force closes every time I start it. Is there a fix for this? thanks ;-)

I used to get force closes with V4 , I found out if I go to manage apps and choose this application and do clear data and clear cache , the application works fine afterward

Share this post


Link to post
Share on other sites
Moe29    0

Is anyone getting ring tone breakup with V5 ?

Ring tone still breaking up when ringing after flashing the rom

Share this post


Link to post
Share on other sites
kyan31    2,002

Ok, I will remove those sqlite scripts and release a new update tommorow. Hopefully everything will be ok. However, those scripts were always there since V1 so this probably isn't the problem :blink:

Share this post


Link to post
Share on other sites
Pirex69    3

Ok, I will remove those sqlite scripts and release a new update tommorow. Hopefully everything will be ok. However, those scripts were always there since V1 so this probably isn't the problem :blink:

can you sign the huawei all backup?

Share this post


Link to post
Share on other sites
tillaz    2,790

However, those scripts were always there since V1 so this probably isn't the problem blink.png

yeah, but no of those scripts would of started working until R3.5 \ R4

as the permissions had not been set for them until 3.5, then if busybox was not included until R4, this is the point where they are fully active ;)

Share this post


Link to post
Share on other sites
kyan31    2,002

yeah, but no of those scripts would of started working until R3.5 \ R4

as the permissions had not been set for them until 3.5, then if busybox was not included until R4, this is the point where they are fully active wink.png

Ah ok, that explains a lot... pretty much everything actually! So now that I know what is causing these FC's, a new Lightning ROM will be released soon :)

Share this post


Link to post
Share on other sites
blaster99999    20

Is anyone getting ring tone breakup with V5 ?

Ring tone still breaking up when ringing after flashing the rom

yes im having stuttering breakup ring tone dont know how to fix it

Share this post


Link to post
Share on other sites
tillaz    2,790

yes im having stuttering breakup ring tone dont know how to fix it

sounds like the exact same problem i had back on my AtomicMod ROM for the zte skate

for me though it was when playing music, it would stutter (especially when pulling down the status bar, or making any other touches on the display)

after long hours of trying to track down the problem, i found it was atually caused by an init.d script >> LoopySmoothness

check if your music dose the same, as this script could be the cause on here as well

if you remove it you might need a factory reset for the changes to be removed, like most scripts

Share this post


Link to post
Share on other sites
kyan31    2,002

sounds like the exact same problem i had back on my AtomicMod ROM for the zte skate

for me though it was when playing music, it would stutter (especially when pulling down the status bar, or making any other touches on the display)

after long hours of trying to track down the problem, i found it was atually caused by an init.d script >> LoopySmoothness

check if your music dose the same, as this script could be the cause on here as well

if you remove it you might need need a factory reset for the changes to be removed, like most scripts

Lol I have that tweak too :P

That will also be removed/edited to stop the stuttering music.

Share this post


Link to post
Share on other sites
kyan31    2,002

I'm testing a new version of Lightning ROM now, it will contain fixes for the FC's and the stuttering ringtone. Sorry for all the inconvenience :P

Share this post


Link to post
Share on other sites
Ilfirin    0

Hello again. I didn't test stuttering ringtone, but I see, kyan is working on himself.

What could I do is test of 25 reboots. And everything seems working.

So there should be R6 final.

Just one thing. Maybe I've been overlooking it and I am suggesting to self something, but now i'm finding (with not ignorable size) stored logs on sd card and things look a bit slower. So i suggest disable logging again, after all, it's just about disabling and enabling init.d script.

And I would like to humbly recommend my little f.request about better messaging app (from cyanogen), with "remove unicode characters" feature.

And some last things.

- At running application list (long home press) I couldn't find button for remove all, which i get used to, but I could live with it.

- After boot and pin, trebuchet is restarted. It didn't happend after clear flash, it appears later together with gapps force closing. Sqlite solfe gapps, but this remains. At error log I couldn't found something usefull, just plenty of DropBoxManagerService, Sensors, chromium and dalvikvm GC_ errors. Also WifiSerice, msm7672a.hwcomposer and so on. On of the reason I want to diable logs again, it's horror :)

Thanks again for great rom.

Share this post


Link to post
Share on other sites
kyan31    2,002

Hello again. I didn't test stuttering ringtone, but I see, kyan is working on himself.

What could I do is test of 25 reboots. And everything seems working.

So there should be R6 final.

Just one thing. Maybe I've been overlooking it and I am suggesting to self something, but now i'm finding (with not ignorable size) stored logs on sd card and things look a bit slower. So i suggest disable logging again, after all, it's just about disabling and enabling init.d script.

And I would like to humbly recommend my little f.request about better messaging app (from cyanogen), with "remove unicode characters" feature.

And some last things.

- At running application list (long home press) I couldn't find button for remove all, which i get used to, but I could live with it.

- After boot and pin, trebuchet is restarted. It didn't happend after clear flash, it appears later together with gapps force closing. Sqlite solfe gapps, but this remains. At error log I couldn't found something usefull, just plenty of DropBoxManagerService, Sensors, chromium and dalvikvm GC_ errors. Also WifiSerice, msm7672a.hwcomposer and so on. On of the reason I want to diable logs again, it's horror :)

Thanks again for great rom.

Thanks for all the testing, a new version will be out soon. I will also create a flashable zip to disable logging if you wish :)

A screenshot:

post-969101-0-03636700-1363545355_thumb.

I am also trying to remove the apps from the app drawer (beats, toggle settings, supersu) but it has problems, so I might have to do that later.

Edited by kyan31

Share this post


Link to post
Share on other sites
kyan31    2,002

NEW UPDATE

Lightning ROM 5.5.0

Changelog:

  • Fixed FC's
  • Fixed ringtone stutter
  • Added superuser options in settings
  • Home locked in memory
  • New bootanimation
  • Enabled logging
  • Other stuff

DOWNLOAD

As always, full wipes may not be needed, but are recommended.

Edited by kyan31

Share this post


Link to post
Share on other sites
atin    0

NEW UPDATE

Lightning ROM 5.5.0

Changelog:

  • Fixed FC's
  • Fixed ringtone stutter
  • Added superuser options in settings
  • Home locked in memory
  • New bootanimation
  • Enabled logging
  • Other stuff

DOWNLOAD

does this require a total wipe?

Thanks btw.

I flashed it without and its a mess still...Update.. I fixed permissions and now seems ok... touch wood...BUT.. I'm now getting persistent OTA update reminders even though I have the update already!

Edited by atin

Share this post


Link to post
Share on other sites
tillaz    2,790

does this require a total wipe?

Thanks btw

i would say yes, or the stuff he has removed that causes the problems will still be present, (not removed)

doing the format system option would be a good idea

Share this post


Link to post
Share on other sites
kyan31    2,002

does this require a total wipe?

Thanks btw

No.

i would say yes, or the stuff he has removed that causes the problems will still be present,

Ok maybe :P

Edited by kyan31

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.