• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Google maps causes phone to hang and then reboot...

7 posts in this topic

Posted

Hi,

I recently bought an Orange SF2 for my dad and installed Fish 'n Chips R7 onto it for him. He mentioned to me recently that he wasn't able to use Google maps, and so I cleared the cache and app data but it still caused the phone to hang.

I performed a full wipe and reinstalled the ROM, but it still hangs a few seconds after opening the maps application. The GPS Test app seems to work fine, so I believe the GPS itself is ok.

Since then I have tried several ROMs listed as suitable for 'Daily Use' from the list I found on this forum (http://www.modaco.com/topic/353611-list-guides-roms-and-recoveries-updated-240113/), but Google Maps hangs on every one.

I've tried to search an answer, but haven't found anything so far. Hope someone can offer some advice.

Thanks in advance for any help.

0

Share this post


Link to post
Share on other sites

Posted

Hi,

I just tried it on my sf2 running CM7, seems to work fine. What roms did you try?

Good to see my list being used too!! :D

Cheers surf

0

Share this post


Link to post
Share on other sites

Posted

It's a great list, thanks for posting it and for your reply!

So far I have tried AndroIum, Dazzozos CM7 & CM9, Fisn 'n Chips RLS7 & RLS8, Sebastian404s debranded, and Flibblesans FLB2! In between these I have tried the usual factory reset/wipe cache/wipe dalvik, and I even threw in a format system for good measure, but it's always the same result. Google maps opens and may appear to work normally for 1-5 seconds before it locks up. During this period I can sometimes press the Menu key and get into the settings (where I have tried clearing the cache), but when I return to the map it will always hang.

I'm tempted to put the Orange stock firmware back onto the device and see if Google maps works then. If not then I guess it might have some kind of hardware fault and I could try to return it to Orange. Some of the posts in this thread have made me think it might be hardware related ---> http://www.modaco.com/topic/341091-zte-blade-constant-freezesreboots/

Putting the stock ROM back on should be easy enough, but I just had a quick look for the stock recovery and couldn't find any download links.......I'd be willing to try anything else you can suggest before I go for the last resort option....?

0

Share this post


Link to post
Share on other sites

Posted (edited)

No worries! Seems you've tried a few roms then lol, you'd think one of those would work ok. If nobody else has any ideas then maybe go with your returning to stock plan..

If you search near the back of the forum there's a few threads about returning to stock.http://www.modaco.com/topic/356711-request-step-by-step-guide-on-returning-to-ftm-unlocking-and-flashing/ I believe you can flash a standard rom or try the ZTE tool, maybe someone could confirm this?

Good luck, surf

Edited by surfungus
0

Share this post


Link to post
Share on other sites

Posted

If you simply install one of the stock orange images it includes ftm so you'll revert back to stock recovery.

Not sure if Orange will notice it's been unlocked though.

As for the problem itself, have you tried underclocking the phone using an overclock app?

Also, does this hanging only happen when charging?

The only time I've had hanging or restarting of the phone is when:

1. The phones been charging whilst using gps and generates a LOT of heat.- is your phone running hot?

2. I've overclocked the phone to much- has this phone been overclocked before? -Perhaps that's what has damaged it?

Oh one other thing to bare in mind is some roms include a "GPS fix". Maybe that's causing you problems. I know stock and androlim don't have this, so maybe try with them.

And finally, the obvious, apart from a test app, do other GPS apps cause a problem? You could try downloading something like android speedometer to see if you can replicate the problem. Are you also updating Google maps to the latest version? Do the freezes occur with just maps or navigation too? Have you tried using a2sd gui to move dalvik cache to sd ext and free up more space on your device?

0

Share this post


Link to post
Share on other sites

Posted

I just tried underclocking the max CPU one notch down from 787 to 480, but it didn't help. It hangs whether the phone is charging or not, and whether I use WiFi or 3G. The phone does appear to get warm, but not as warm as some others I have used in the past. There seems to be plenty of space on the device so I haven't tried moving the dalvik cache. Both the version of Maps included on the ROM and the updated versions from Play behave in the same way.

I've never overclocked the phone deliberately in the past. The FNC R7 ROM has been on it since purchase so I don't know if maps has ever worked. GPS test apps seem to work ok, so I'm wondering if it's a GPU related issue...

The device now has the stock firmware, kernel and recovery installed, but maps still doesn't work. However Google maps no longer hangs (I can see the search bar and access the menu at any time), but the actual map area remains black at all times. Similarly when I use Navigation, the GPS locks on and I receive voice instructions, but the centre of the screen is just black. The borders surrounding the blank map area are showing the correct information.

Looks like I'll have to take a trip to the EE store this weekend, but I reckon I'm in for a hard time because everything else about the phone appears to work just fine. I'm just running some stability and benchmark apps to see if I can cause an issue elsewhere. The phone no longer has Clockwork recovery so I'm hoping they won't be able to tell in-store that I've been tampering.

I appreciate the help guys and I will post back here when I have some news, good or bad.

0

Share this post


Link to post
Share on other sites

Posted

That's a weird problem you have. Yes you may as well try and return it. Let us know how it goes and good luck!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.