• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[Guide] How To Flash CWM / Gapps / and Root The Vowney V5

90 posts in this topic

Posted · Report post

INDEX

Post 1: Index

Post 2: Pulling the stock recovery to make sure proper drivers are installed

Post 3: Flashing CWM recovery

Post 4: Flashing Root and Gapps (Google apps)

Post 4: Increase recovery partition to 7MB and flash TWRP - full touch recovery

5

Share this post


Link to post
Share on other sites

Posted · Report post

INSTRUCTIONS TO PULL THE STOCK RECOVERY

download the tool we will be using and extract it to a folder on your desktop

http://www.solidfile...m/d/1b4a043d9b/

and then extract "SP_Flash_Tool_v3.1304.0.119.rar" into a folder called SP_Flash_Tool

open the folder and you should see this below, right click on the highlighted item in the screenshot and select run as administrator.

image.png

select the tab shown in the screenshot below

image.png

select the text file that is inside the extracted folder and press open.

image.png

select the "read back" tab shown below

image.png

press the add button then double click the highlighted item in the screenshot

image.png

change the file name from ROM_0 to recovery.img and press save

image.png

image.png

IMPORTANT PART MAKE SURE THIS IS DONE CORRECT (copy & past the values below)

edits the start address to say >> 0x2D80000

and the length to say >> 0x600000

exactly like the screenshot below, then press ok

image.png

shut down your vowney v5 and remove the battery, press the "read back" button shown below in the screenshot (next to stop)

now plug your phone into the PC (with the battery still out) and it should start to pull the recovery.img from the phone

the percentage bar at the botton will go to 100% in red then again in blue, so be patient.

and don't worry if you get an error the first time, just try again but with the battery in (some need it in some need it out)

image.png

4

Share this post


Link to post
Share on other sites

Posted · Report post

INSTRUCTIONS TO FLASH CWM RECOVERY

download the tool we will be using and extract it to a folder on your desktop

if you downloaded the tool from the first guide for pulling the stock recovery delete it and use this one,

its the same tool but has all the new stuff you need in the correct places.

http://www.solidfile...m/d/e7410e92e5/

open "SP_Flash_Tool_v3.1304.0.119"

image.png

you should see this below, right click on the highlighted item in the screenshot and select run as administrator.

image.png

select the tab shown in the screenshot below

image.png

select the text file that is inside the extracted folder and press open. it should be at CWM MTK6589/

image.png

you should now see this below, make sure the text in the red box is pointing to the correct place of the recovery.img

just make sure this is at the end of the location CWM MTK6589/recovery.img (it should already be like this but just check)

image.png

press the "Download" button shown below

image.png

this alert will pop up, don't worry about it and press "yes" as we are only flashing the recovery partition.

image.png

shut down your vowney v5 and remove the battery.

now plug your phone into the PC (with the battery still out) and it should start to flash CWM

the percentage bar at the bottom will go to 100% in red then again in yellow, so be patient.

after it completes successfully put the battery back in (or remove it then put back in)

Press and hold Volume-Up but don't let go,

now press the power button until the phone boots up.

There will be a small sentence at the left bottom corner => RECOVERY MODE

select this and you should boot into CWM, from here you can easily root and install Gapps.

see the post below for root & Gapps (Google apps)

4

Share this post


Link to post
Share on other sites

Posted · Report post

How to root with CWM Recovery

download this and add it to your sdcard

http://api.viglink.c..._13707303837066

boot into CWM if not already there.

select

install zip from sdcard

navigate to the .zip you just added to the sdcard and select it

press yes, wait till it finishes and reboot.

How to install Gapps (Google Apps)

download this and add to your sdcard

http://api.viglink.c..._13707313405958

boot into CWM if not already there.

select

install zip from sdcard

navigate to the .zip you just added to the sdcard and select it

press yes, wait till it finishes and reboot.

4

Share this post


Link to post
Share on other sites

Posted · Report post

How To Increase Recovery Partition to 7MB And Flash TWRP - Full Touch Recovery

- First Complete Post #2 and #3 so you have proper drivers installed and know how to connect the phone

- Download The Video And Follow Instructions, its straight forward as i have put the package together for you

- Video Instructions http://www.solidfile...m/d/5e02464cf6/

- TWRP package - http://www.solidfile...m/d/59ebdff35e/ (its big because you need to flash the stock rom)

this will wipe all user data and remove cwm if you have it installed, so i highly recommend using Go Backup before starting.

-

0

Share this post


Link to post
Share on other sites

Posted · Report post

Great Job ... I Installed CWM yesterday .. very easy to follow. :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

my v5 came prerooted , is there any benefit with flashing this cwm , as mine as it already on?

0

Share this post


Link to post
Share on other sites

Posted · Report post

my v5 came prerooted , is there any benefit with flashing this cwm , as mine as it already on?

Mine i thought it came pre rooted but after trying to install google play i could not do it and i did not have any access to super user features now i do

so this guide kind of saved me :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

my v5 came prerooted , is there any benefit with flashing this cwm , as mine as it already on?

Mine came rooted but I'm pretty sure it just came with the stock android recovery, so I backed it up as the guide instructs, then installed CWM and made nandroid backup. I always feel better once I make CWM backup.. :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi tillaz,

My V5 is poorly after trying to do a factory reset data, can I install cwm only from your instructions ?

I tried to pull the stock recovery, no go, % bar does not start to move and following your pics I do not have 1 to 5 png in pic 6 to save.... and at the bottom of pic 9 where you have nad and usb, I had emmc. wondering if it is because my rom is screwed.

think if I could get cwm on there I might get it working with another rom

0

Share this post


Link to post
Share on other sites

Posted · Report post

I tried to pull the stock recovery, no go, % bar does not start to move and following your pics I do not have 1 to 5 png in pic 6 to save.... and at the bottom of pic 9 where you have nad and usb, I had emmc. wondering if it is because my rom is screwed.

I also had emmc and other differences on my screen, and couldn't get it working at first. Tried to install other drivers, with no joy either. Then removed the sim and sd cards as well as the battery and it worked. Made a nandroid backup and installed another rom.

Thanks Tillaz. Been relying on you with the Blade, then the G300, and now the V5. Much appreciated.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I also had emmc and other differences on my screen, and couldn't get it working at first. Tried to install other drivers, with no joy either. Then removed the sim and sd cards as well as the battery and it worked. Made a nandroid backup and installed another rom.

Thanks Tillaz. Been relying on you with the Blade, then the G300, and now the V5. Much appreciated.

Thanks for the advice e45cream, did try it earlier, pulled everything and still would not work, unless im doing something else wrong of course, probably am, not having a good day!!!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I made a few mistakes the first few times too. I kept clicking the Download tab instead of the Download Button next to the stop button. Take your time and have another go.. :)

Edited by Rico_89
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi tillaz,

My V5 is poorly after trying to do a factory reset data, can I install cwm only from your instructions ?

I tried to pull the stock recovery, no go, % bar does not start to move and following your pics I do not have 1 to 5 png in pic 6 to save.... and at the bottom of pic 9 where you have nad and usb, I had emmc. wondering if it is because my rom is screwed.

think if I could get cwm on there I might get it working with another rom

ignore the 1 to 5 png they are the screenshots for the guide, not sure why they where been saved there.

but your problem is because of drivers if the bar is not moving,

the phone should automatic install them when its plugged in without the battery (after you have pressed the read back button)

are you running the .exe as administrator ?

lastly you should use this tool, remove all traces of "MTK" and "VCOM" then start the guide again

http://forum.xda-developers.com/attachment.php?attachmentid=1236660&d=1343886482

0

Share this post


Link to post
Share on other sites

Posted · Report post

When I plugged in my phone, nothing happened and I thought it hadn't worked again. I was looking on the Web for ages for possible solutions. When I minimised the browser to have another go, I noticed a little pop-up window with a green circle and realised that it had worked, so perhaps you need to give it a lot more time each go.

0

Share this post


Link to post
Share on other sites

Posted · Report post

When I plugged in my phone, nothing happened and I thought it hadn't worked again. I was looking on the Web for ages for possible solutions. When I minimised the browser to have another go, I noticed a little pop-up window with a green circle and realised that it had worked, so perhaps you need to give it a lot more time each go.

Still no go, get this screen half way ,,,what do I do with it?

post-946859-0-02214200-1371495786_thumb.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Still no go, get this screen half way ,,,what do I do with it?

post-946859-0-02214200-1371495786_thumb.

on the first guide are you double clicking this and changing it to the correct info

image.png

image.png

then pressing save.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

im using windows 8 not sure if that matters, I do not get the option in "read back block start address" to select read method

also when I open scatter file I get "android_scatter_emmc.txt", you do not get emmc in your screen shot

Edited by bryfly
0

Share this post


Link to post
Share on other sites

Posted · Report post

have you tried to just flash cwm using the second guide ? if not i would give that a go.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

have you tried to just flash cwm using the second guide ? if not i would give that a go.

yes tried that earlier that did not work either, how long should it take before the % bar starts moving

been sitting there now for 10 min and no movement......

Can I get cwm on any other way, or something else I can try?

Edited by bryfly
0

Share this post


Link to post
Share on other sites

Posted · Report post

yes tried that earlier that did not work either, how long should it take before the % bar starts moving

couple of seconds after you plug in the phone,

the fact that is not even going to 100% in blue "then" failing makes me think its a driver problem as there is no communication between the phone and computer.

it also could be a windows 8 compatibility problem (driver or the program)

try doing this in the screen recording i just made or the equivalent on win 8 (save's me writing it out lol)

http://www.solidfile...m/d/6c531adfab/

0

Share this post


Link to post
Share on other sites

Posted · Report post

couple of seconds after you plug in the phone,

the fact that is not even going to 100% in blue "then" failing makes me think its a driver problem as there is no communication between the phone and computer.

it also could be a windows 8 compatibility problem (driver or the program)

try doing this in the screen recording i just made or the equivalent on win 8 (save's me writing it out lol)

http://www.solidfile...m/d/6c531adfab/

Thanks for taking the trouble to help me out, followed the video and still will not work. looks like I do have a paper weight, sending it back under warranty probably not worth the effort or cost, as they are likely to say it is something I did and charge to do it.

As I can get into settings and apps do not think its terminal just need to re=flash a rom or change a setting or similar.....wish I had not reset to factory now!!!

Still Waiting for merimobile to translate the factory menu to english

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for taking the trouble to help me out, followed the video and still will not work. looks like I do have a paper weight, sending it back under warranty probably not worth the effort or cost, as they are likely to say it is something I did and charge to do it.

As I can get into settings and apps do not think its terminal just need to re=flash a rom or change a setting or similar.....wish I had not reset to factory now!!!

Still Waiting for merimobile to translate the factory menu to english

Try a different USB port, the main ones that are at the back of your pc. Also, if you can, try a different pc running windows 7.

0

Share this post


Link to post
Share on other sites

Posted · Report post

have a read of this, sounds like the same problem on win 8

http://chinaphoneare...ead.php?tid=636

post #4 might be your answer

"Have you disabled digital driver signature? For flashtool you need MTK6589 USB VCOM drivers!

Open device manager, open flashtool, plug in your phone and install driver manually with open flashtool!

First you have MT65xx Preloader in device manager for two seconds when you plug, double click and install driver manually.

Then you should have MediaTek PreLoader USB VCOM Port! Now it should be installed correctly."

here are the VCOM drivers from the site

http://www.solidfiles.com/d/9662ae99a8/

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

have a read of this, sounds like the same problem on win 8

http://chinaphoneare...ead.php?tid=636

post #4 might be your answer

"Have you disabled digital driver signature? For flashtool you need MTK6589 USB VCOM drivers!

Open device manager, open flashtool, plug in your phone and install driver manually with open flashtool!

First you have MT65xx Preloader in device manager for two seconds when you plug, double click and install driver manually.

Then you should have MediaTek PreLoader USB VCOM Port! Now it should be installed correctly."

here are the VCOM drivers from the site

http://www.solidfiles.com/d/9662ae99a8/

Thanks for advice re the launcher may have been deleted, followed your advice re installed new one and phone is working ok at the moment, guess when I did factory reset it wiped out the launcher, re cwm etc, will give it a go later, bit reluctant to touch it anymore at the moment...lol

thanks to all who gave me assistance.......

Edited by bryfly
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.