• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Cannot get FastBoot to work

7 posts in this topic

Posted

Hi,

 

I've just gotten my hands on a ZTE Blade V (from Virgin Mobile at £59.99).

 

I'm trying to follow the instructions to get ClockWorkMod installed on this thing, but I'm having a hell of a time trying to get it to work :-(

 

I have followed the instructions in the other thread, but it seems like the hardware IDs in this device are different to those in the drivers provided in the other thread.

 

Here is what I have done (on a fresh Win7 x64 system):

 

1. Install ZTE Drivers in Windows

2. Enable USB Debugging on Phone

3. Connect phone to PC. Device is detected and ADB drivers loaded.

4. Issue "adb reboot recovery"

5. Phone reboots into recovery (it says Android System Recovery <3e>) at the top.

6. Windows trys to pick up the device drivers but FAILS. I have two devices in Device Manager under unknown devices, both named Android. I have tried updating each driver using the instructions in the other thread and the contents of the fastboot_driver_B3.zip file, but no joy.

 

The device IDs of the two devices are:

 

USB/VID_05C6&PID_901D&MI_00

USB/VID_05C6&PID_901D&MI_01

 

The vendor ID seems to be Qualcomm.

 

Does anyone have any ideas?

 

I realise not much activity regarding this phone at the moment, but I would really like to get ClockWorkMod on it.

 

Thanks!

0

Share this post


Link to post
Share on other sites

Posted

You need to download the ZTE fastboot drivers.  See target's post here.

0

Share this post


Link to post
Share on other sites

Posted (edited)

You need to download the ZTE fastboot drivers.  See target's post here.

 

That is what I've tried, but Windows refusing to install them. Says that no applicable drivers are found in the folder I point to.

 

If I open the android_winusb.inf file in that archive, all of the device ids start with VID_18D1

;ZTE Blade 3
%SingleBootLoaderInterface% = USB_Install, USB\VID_18D1&PID_D00D

My device ID in Device Manager starts VID_05C6, which is why I believe it isn't detected.

 

Also 

 

In Target's post, he says:

Install the fastboot driver
1) Right click My Computer and select properties then the hardware tab then device manager
2) You will see an entry for Android with a yellow exclamation error. Double click this and select update driver
3) Select install from a specified location and hit next
4) Browse to where you unzipped the fastboot driver in the first part and run through the wizard

I have two devices with description "Android" (each with different device ids), not one.

 

:-(

Edited by pinko1
0

Share this post


Link to post
Share on other sites

Posted

Hmm.  Also running Win7 x64, when my Blade is in bootloader, in Device Manager I have "Android Phone" at the top, and under that "USB Modem Phone ADB port".  The device id of the latter is VID_18D1.

 

What happens if you disable both devices then scan for changes?

0

Share this post


Link to post
Share on other sites

Posted

Wait a sec... you're trying to do this from recovery?  It should be from bootloader...

1

Share this post


Link to post
Share on other sites

Posted

Wait a sec... you're trying to do this from recovery?  It should be from bootloader...

 

Haha. God. I am such an idiot

 

I must have read those original instructions 25 times, everytime I read "adb reboot bootloader" as "adb reboot recovery".

 

3 hours I've spent on this...

 

Seriously, thanks for the help.

 

Not only is my phone working, but you've saved my sanity!

0

Share this post


Link to post
Share on other sites

Posted

Ha, easily done.  Glad you got it working.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.