• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance) CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission) ROMs must give full credit to the original author ISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Can we summarize all the threads ?

3 posts in this topic

So I have the 4.0.4 ICS.


I don't know all the terms like CFW and NAND and blahblah and I don't really have the time to read 300 pages of replies...


I want to update to the 4.1.2 or 4.2 JB


I did root the phone on 4.0.4, but it was a semi successful root, as superuser and overclocking worked fine, but things such as "change the extension of system files" would not work.


I now get the "This device is not allowed to update" error when I try the official airborne update.


I also need the WIFI G3 and GPS.


What can I do ? I tried to flash the zip files from SD but I constantly get the ro.product.device error.


Most links people are refering to are dead.


How do I flash a firmware ? Can't I just flash the official JB firmware ? 

How do I unroot my phone so that I can make the official update ? 


Please help


Share this post

Link to post
Share on other sites

I managed to update to the 4.1.2 version with the PC installer, I just needed the right version of the firmware and most of the links were down, but I finally found one.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.