• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Exchange Server 2003 Always-Up-To-Date notifications HOWTO

93 posts in this topic

Posted

When the E200 came I was excited to read about a new feature in the 2003 Smartphone OS spec that allows it to be notified of new emails by Microsoft Exchange Server 2003. For anyone who doesn’t know how it works let me quickly explain:

1. You receive an email on your Exchange Server.

2. The Exchange Server creates a special email that has a GUID as its subject and a few characters in the body of an email.

3. The Email is then sent by the Exchange Server to an Email to SMS gateway.

4. The gateway sends the subject and body of the email concatenated together as a SMS to your phone.

5. The phone receives the SMS, deletes it immediately and then initiates a GPRS connection to your Exchange Server and Syncs.

The advantages of this are pretty obvious, i.e. reduced GPRS costs if your volume of emails are quite low, as well as the advantage of getting the email on your phone reasonably soon after the email arrives on the Exchange Server.

I looked around the Net and found no instructions at all about how to make it work. Fortunately it’s actually pretty easy.

This is what you need to have.

1. Exchange Server 2003.

2. The Mail recipient needs to be set up to use Outlook Mobile Access and the Always-Up-To-Date notifications need to be enabled. You can check this from Active Directory Users and Computers.

3. You should also be able to Sync via your Exchange Server. Some reports have indicated that Non SSL connections are not working. I haven’t personally checked this since I’m using an SSL certificate for my connection.

This is what you need to do:

1. In Exchange Server add a new mobile carrier called Orange and set the smtp domain to @orange.net

2. Stick the E200 in the USB cradle.

3. Open Active Sync.

4. Click on Tools and Options.

5. On the Sync Options Tab click on Configure next to the Server heading.

6. Click on Connection next to the “Server Connection” heading.

7. Click on Device Address

8. Use the “Service Provider” option and enter your mobile number in the "Device Phone Number".

9. Click on Schedule and Choose the Option “When New Items Arrive” as required for peak or off peak.

I have encountered a problem with it but I need to do some more testing to be sure. If the SMS does not arrive for whatever reason, the Exchange Server does not immediately appear to send another email to the SMS gateway if a second email arrives for you. It seems as if Exchange is waiting for you to Sync before it sends another notification. I’m not sure if this is intended or maybe a glitch at my end.

Overall it’s a very cool feature and great for people who want to have the same functionality as a Blackberry. However unless I can get a cheaper SMS gateway option from Orange it really is not worth it for me.

0

Share this post


Link to post
Share on other sites

Posted

I have to disagree with you a bit...

I set my E200 to the following:

Address device using: Service Provider

Service Provider Name: Orange

And put my mobile number in the right box.

And the push activesync is working. I get my new messages automatically. So it seems that you don't really need the sms gateway if you're with Orange. Can anyone else confirm that they are using the Service Provider method instead of SMTP Address? Cos I might be hallucinating....it's happened before :lol:

0

Share this post


Link to post
Share on other sites

Posted

My god.

You are a genius. It works exactly as you say.

Thanks for your more thorough analysis on this.

It works very quickly indeed via Orange. I wonder if we are being charged for it.

This really does make the E200 a valuable business phone. I now have emails pushed to me within seconds of them being delivered to my Exchange Server.

I'll ammend the HOWTO later.

0

Share this post


Link to post
Share on other sites

Posted

We are having SBS2003 installed this coming weekend - is setting this up easy? Are there any good sources of information?

Thanks -

Tony

0

Share this post


Link to post
Share on other sites

Posted

I don't seem to be able to do this?

I have a device SMS address, but the other options are greyed out! :lol:

Could you take a screenshot of the dialogue? Did you have to do anything to get Orange to appear on the list?

Thanks,

P

0

Share this post


Link to post
Share on other sites

Posted

I have the same thing: service provider name is disabled.

How does Exchange know where to send notifications, don't I need to setup something at the Exchange Server first? Under "Global Settings - Mobile Services" is the possibility to add a mobile carrier, but adding an entry there did not make it available as a service provider in ActiveSync for me.

0

Share this post


Link to post
Share on other sites

Posted

In Exchange Server 2003 in global settings -->Mobile Services I added a new mobile carrier. Called it Orange and used @orange.net as the smtp domain. I then added my own mobile number in the Exchange snap in for users and computers.

I noticed that if I didn't do that I wasn't given the option to add anything into the settings and the device address didn't appear.

Once I added Orange as the mobile carrier those options all appeared.

0

Share this post


Link to post
Share on other sites

Posted

Hi John

Can you state which tab and where you put your mobile number - a screenshot would be nice. I am quite sure i have done as you say - but i still cannot get the service providor to stop being greyed out.

Cheers

Bugs

0

Share this post


Link to post
Share on other sites

Posted

Yeah, I'm having trouble too, where in the user details do you specify the mobile number?

Thanks,

P

0

Share this post


Link to post
Share on other sites

Posted

I've added two screenshots.

First one shows where you add the mobile carrier.

Second the Active directory and users phone number.

desk2.jpg

desk1.jpg

0

Share this post


Link to post
Share on other sites

Posted

Just a further few thoughts.

I think i may have rebooted the Exchange Server after adding orange as the mobile carrier.

It might also be worth mentioning that it seems to need the E200 to be connected to the craddle the first time for the settings to be transfered to the phone. Subsequent changes can be made either from the phone or from the active sync application on the desktop.

If it still doesn't work you might also want to check the up-to-date notifications are enable for the exchange account you are working with and that all the mobile settings are enabled when you right click on the mobile services options and choose properties within the Exchange system manager.

0

Share this post


Link to post
Share on other sites

Posted

Hi Guys

I still cannot get this working - are you sure there is nothing else you had to do?

I have made the exchange changes - Mobile Carrier & update phone numbers, but still the "corporate service providor" section is greyed out.

Any ideas?

Bugs

oh.. and i have rebooted the exchange server too.... :lol:

0

Share this post


Link to post
Share on other sites

Posted

No idea i'm afraid.

However i do think that the mobile carrier option is simply a way of fixing which smtp - sms gateway your users can actually use. It would seem having read some posts on the net that Microsoft are planning on launching a new web site that will allow you to find a mobile carrier that works with AUTD. In that case the fact that "Orange" set as my mobile carrier works whilst connecting to @orange.net suggests that you might be able to get it to work by using "[email protected]" in the device smtp address setting. Unless something totally different is going on, that is actually what's happening when I specify orange as the mobile carrier.

Does that make sense or am I totally not understanding what's happening with AUTD?

Here's a quote via Google groups from a Microsoft Exchange guy called Greg Bolles posted on December 3rd.

The Microsoft Corporate Messaging site is not yet live. Microsoft is

actively working with mobile operators to provide support for the SMS-based

up-to-date notifications. If your mobile operator supports direct

SMTP-addressing of your device, then you can configure your server/device to

send/receive the up-to-date notifications without the need of Microsoft

Corporate Messaging service.

Exchange System Manager: Select the Mobile Services icon under the Global

Settings folder and right-click to select the Properties page. On the

General tab, make sure that the "Enable notifications to user specified SMTP

addresses" is checked.

2003 Mobile Device: In the Active Sync program, select Tools, Options...,

Server tab, Options... button, Device Address... button. Select the "Device

SMS Address" radio button and type in the SMTP address of the device in the

edit box below.

Be advised that some mobile operators may not let through SMTP messages that

have a blank RFC821 "From:" field. They consider these messages to be spam

and filter them out. Exchange sends out the up-to-date notifications as

such to avoid the user receiving NDR's when the operator's SMTP gateway is

down or the message could otherwise not be delivered. Here again, Microsoft

is actively working on a solution to this get around this problem

0

Share this post


Link to post
Share on other sites

Posted

From my experience, you will need a carrier that support conversion of email to sms without altering the content or the form of the original email.

Most carrier actually only send alert SMSs that are not an exact copy of the email into an SMS.

What's imortant is that the SMS must contain the subject (it's a hex string) and the content which is a alphanumeric encoded string.

There are two ways of using the system, which more ore less are in fact the same.

Through the operator or through SMTP. When you set up through the Operator you have to set up Exchange with the information of the operator which is basically only the domain used by the operator to send the SMSs.

Using operator:

Set up on the phone: Use operator

Set up on the Exchange Server 2003: Operator(s) + domain name

Sync the phone, you will get a list of the Operators set up on the Exchange Server. choose the correct Operator for your phone

Set up on the phone: phone number

Using smtp:

Set up on the phone: Use smtp

Set up on the phone: SMS address (which is an email adress that will send the email to the phone as SMS)

Don't forget to put the sync frequency to Up "when new message..." (I forgot this one at first and couldn't figure out why it would not work for a while).

Basically, if you set up as using the operator and the domain is operator.com and your phone number as 1234, it is actually the same as using smtp with an adress of [email protected]

The difference with MIS (used with Exchange 2000) is that you set up the mode and the phone number on the phone and not on Exchange.

With MIS you had to set up everything from the server, now it is the user that does the setup from his phone.

If your operator does not send the email but just an alert that won't work and you will have to use SMTP with a gateway that will forward emails to SMSs with no alteration.. I don't beleive there is such a service for free. So if your operator won't push emails as SMSs, you probably gonna have to pay for an SMS for each email that comes in, plus for the GPRS traffic generated by each synch...

If someone has got a solution to send SMSs from an email without changing the content, that'll be great!

0

Share this post


Link to post
Share on other sites

Posted

Hi,

New server installed, tested and OK.

Activesync with the server works a treat when in the cradle in the office but remotely I get the message "Error Unable to connect. Varify your Dial up or proxy settings are correct, and try again".

It seemes not to be trying to contact the Server over the Internet / via gprs. How does one tell it to do this? Any hints how to set it up on the phone?

Any help would be appreciated!

Tony.

0

Share this post


Link to post
Share on other sites

Posted

Ok chaps, I have got a little further:

Setup domain to https://domain.com

server to domain.com.

It connects but failsto sync, coming up the error "Syncronisation failed. Try again, and if the condition persists, reset your device. Error code 0x80004005".

It may be that the ISA server is not passing it onto the Exchange Server. Or even though I have certificates disabled, it may still be giving a problem.

Anyone any bright ideas?

Tony.

0

Share this post


Link to post
Share on other sites

Posted

Now setup the ISA Server to publish the Exchange-Server-ActiveSync destination set. Still same error!

Running out of options! Argggg!

0

Share this post


Link to post
Share on other sites

Posted

OK - when I attempt to connect to OMA, I get a 401.1 error - acess denied due to invalid credentials (the IIS wont allow unauthenticated access). It also never asks for name / password!

Try it on my original SPV & it gets in fine - asks for password, comes up with the cetificates warning & bang, it's in. ActiveSync doesnt work (can't disable SSL).

I suspect, for some reason, the E200 isnt responding to requests for name / passwords or something like that?

0

Share this post


Link to post
Share on other sites

Posted

This thread has proved very helpful & I now have all but the last step working.

Could someone clarify how they are getting the "up to date" email notification to the sms inbox on their mobile. I have setup the orange email service - but this is only sending a notification. Therefore the message arrives ok - but the sms message is not deleted nor acted upon (I presume because it only has the subject line & not the message body).

Are you using an email to SMS gateway service - if so - which one

Many thanks in advance

Nigel

0

Share this post


Link to post
Share on other sites

Posted

Hi

After a few days of tootling around the newsgroups I've finally got my system to work.

If you want to get AUTD go to the ActiveSync Options/Schedule/Wireless Schedule and set the options there. If you want a regular schedule set that for every n minutes or hours and if you want it when new mail arrives just set it to 'When new items arrive' - be aware that it doesn't just notify you, it will actually download the mail to your phone.

The other thing you need to do is go to the Sync Options/Connection/Connection/Device Address and put an entry in the Device SMS Address - it will be your phone number in the format [email protected] - don't use the Corporate Service Provider, from what I can tell it's not available yet and I believe the MS Corporate Provider provisioning service isn't ready.

The above is how my systems is set-up and working, let me know how you get on with it. I am assuming that you've set-up the details of your Exchange server and user account/password correctly in ActiveSync as well.

One other thing, I also have certificates disabled on my E200 just for testing purposes at the moment but it is through a SSL connection.

0

Share this post


Link to post
Share on other sites

Posted

thanks fenice

I moved away from the corporate provider & things still work to the point of the SMS message arriving on the phone. It arrives - but the phone does nothing with it - i.e. it does not trigger a pickup. From what I can gather - this is because the email alert function of orange strips the message body of the message & only "alerts" the user of the email - this does not seem to be enough info to trigger a pickup!

Are you in the UK? Are you using orange email from www.orange.net with the alert function activated?

Many thanks

Nigelm

0

Share this post


Link to post
Share on other sites

Posted

Hi

Yes, I'm in the UK. I'm sorry but I misread your post, I thought you were talking about using Exchange Server 2003 with AUTD, that's what you need to get your mail automatically downloaded to your phone. I do have an email account at orange.net and it does alert me when mail arrives but it is only for that, SMS notification - it doesn't download your mail, you do need Exchange 2003 for AUTD to work to it's full potential. The reason it doesn't trigger a pickup is that Exchange sends a 'special' type of SMS that triggers the smartphone to sync with an Exchange server.

0

Share this post


Link to post
Share on other sites

Posted

I have exchange 2003 with all the up to date notifications enabled & SSL active synch enabled & working.

An email hits my inbox, exchange forwards that message to [email protected], my orange email alert gets forwarded to the phone & nothing happens - the message just sits in the SMS inbox

What am I missing here??

Thanks

Nigelm

0

Share this post


Link to post
Share on other sites

Posted

Ok, just for clarification. You say that '... exchange forwards that message' - it actually should send an SMS message to orange.net and your original email sits on your exchange server until it syncs. Is that what's happenening to you or are you saying that there's just the SMS in your inbox?

Have you tried syncing your phone by cable to your exchange server and does it work? Is there any firewall on your systems and is port 443 open? Do you have the Exchange server set-up correctly? Have you made any changes to the phone settings?

0

Share this post


Link to post
Share on other sites

Posted

- sorry - my mistake - it forwards a notification message to my orange email which then sends an alert.

- phone synchs via cable link & via SSL via GPRS

- it all seems to come back to that sms that arrives on the phone - the smartphone does not seem to recognise them as up to date alerts. I am assuming this is because they lack the message body??

Any thoughts?

thanks

Nigelm

Ok, just for clarification. You say that '... exchange forwards that message' - it actually should send an SMS message to orange.net and your original email sits on your exchange server until it syncs. Is that what's happenening to you or are you saying that there's just the SMS in your inbox?

Have you tried syncing your phone by cable to your exchange server and does it work? Is there any firewall on your systems and is port 443 open? Do you have the Exchange server set-up correctly? Have you made any changes to the phone settings?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.