Jump to content


Photo

Needing serious help with 8390

- - - - -

  • Please log in to reply
7 replies to this topic

#1
rpiceman

rpiceman

    Newbie

  • Members
  • Pip
  • 7 posts
I'm in Dallas Texas and I have a Mitac 8390. I'm not able to get my phone to come on. The battery went dead and I fully recharged it until the green light came on. but now the phone won't turn on. The face clock looks to be working, but it displays the same time all the time. Is there any service centers or tech help I can get in the US.

Rpiceman

  • 0

#2
ebcoelho

ebcoelho

    Newbie

  • Members
  • Pip
  • 13 posts
  • Location:Florianopolis, Brazil
  • Devices:Mitac Mio8390

I'm in Dallas Texas and I have a Mitac 8390.  I'm not able to get my phone to come on.  The battery went dead and I fully recharged it until the green light came on.  but now the phone won't turn on.  The face clock looks to be working, but it displays the same time all the time.  Is there any service centers or tech help I can get in the US.
Rpiceman

<{POST_SNAPBACK}>


when u turned on the phone the front display is working? if yes i have the same problem... :D

  • 0

#3
sirc1228

sirc1228

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Mio 8390

when u turned on the phone the front display is working? if yes i have the same problem... :D

<{POST_SNAPBACK}>


Damn, it's just happened to me today. I'm wondering if Mitac set a time bomb on these phones. Any help would be appreciated!!!

  • 0

#4
markgamber

markgamber

    Enthusiast

  • Members
  • PipPipPip
  • 273 posts
  • Location:Lancaster, PA USA
  • Devices:E200

Damn, it's just happened to me today. I'm wondering if Mitac set a time bomb on these phones. Any help would be appreciated!!!

<{POST_SNAPBACK}>


Sorry to hear about this but mitac isn't competent enough to have done it on purpose. All I can tell you is to leave it in the charger for a few hours and then try to start it up into the boot menu. Hold down the asterisk and both softkeys when you turn on the phone. If that works, simply go to option 5 to reboot the phone and you'll be set. If that doesn't work, try a hard reset. Hold in the volume button (press in the center of the button, not up or down exclusively) while turning on the phone. It should vibrate when it comes on. If that works, great, but it will wipe out anything you have saved on the phone. If neither of those work, I don't really know what to tell you.

  • 0

#5
markgamber

markgamber

    Enthusiast

  • Members
  • PipPipPip
  • 273 posts
  • Location:Lancaster, PA USA
  • Devices:E200

I'm in Dallas Texas and I have a Mitac 8390.  I'm not able to get my phone to come on.  The battery went dead and I fully recharged it until the green light came on.  but now the phone won't turn on.  The face clock looks to be working, but it displays the same time all the time.  Is there any service centers or tech help I can get in the US.
Rpiceman

<{POST_SNAPBACK}>


Oh...the only way you could have gotten it serviced would be to send it to China, have it repaired and sent back, all at your expense. And it is VERY expensive to do that, like on the order of at least a couple hundred dollars, if I recall correctly. I know of one 8390 owner who did that but that was a long time ago and mitac doesn't appear to support this phone at all any more. If it's at all possible, sell it and get something else. I recent bought an E200 in great shape off ebay for $187 which included shipping from the UK and now I'm trying to determine if I want to sell my 8390 or smash it with a hammer.

Sorry to be the messenger but that's the way it is with this bullsh*t company and it's bullsh*t products.

  • 0

#6
sirc1228

sirc1228

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Mio 8390

Oh...the only way you could have gotten it serviced would be to send it to China, have it repaired and sent back, all at your expense. And it is VERY expensive to do that, like on the order of at least a couple hundred dollars, if I recall correctly. I know of one 8390 owner who did that but that was a long time ago and mitac doesn't appear to support this phone at all any more. If it's at all possible, sell it and get something else. I recent bought an E200 in great shape off ebay for $187 which included shipping from the UK and now I'm trying to determine if I want to sell my 8390 or smash it with a hammer.

Sorry to be the messenger but that's the way it is with this bullsh*t company and it's bullsh*t  products.

<{POST_SNAPBACK}>


Yeah, I saw your comment about 8390 being suck on the thread and I'm secondly motioning it. I'll try to do all those thing you've said. My phone looks fairly new and tried to keep in best shape. It's just bad that the phone put me down. Best of luck to me........ Thanks......

  • 0

#7
rpiceman

rpiceman

    Newbie

  • Members
  • Pip
  • 7 posts
I had to send the 8390 back to china. It was $75.00 shipping to china. I got it back and so far it works great. I didnt have to pay for the repair or for the shipping back becuase they told me that it was still under warranty. This is my first smartphone and I'm not sure how to do all the fancy things with it. It does look like they loaded the latest software versions. I have yet to find any thing that is in chinese. All menus are in english. I was told that the problem i think was that they had to fully replace an RF board. I downloaded the service pack 1, but only on my PC. I dont think i'm going to install seeing that i'm not have a problem yet. Any cool ideas to do on the phone would be apprecaited. Short of hitting it with a hammer.... haha

  • 0

#8
Skeese

Skeese

    Diehard

  • Members
  • PipPipPipPip
  • 385 posts
  • Gender:Male
cool ive never had a problem with my 8390 yet like these guys. anyways can you go into settings then to about and tell me what you see

Mine is -------------------------------

Version 4.20.0 (build 13291)
Radio Version R4.0.4 MBE4303601 P2

Operator: 4.20.13291.0
Manufacturer: 42.0.0.0
Microsoft: 4.20.13291.0
Language:4.20.13291.0
File System 4.20.13291.0


when did you get your phone back? install a game and see if you need the GAPI signing fix

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users