Jump to content


Photo

C550 not charging, no switch on

- - - - -

  • Please log in to reply
5 replies to this topic

#1
dave55

dave55

    Newbie

  • Members
  • Pip
  • 16 posts
Hi
I seem to have a dead C550. Left it chargin on a usb quite happy. Next day dead phone, no charge light wont switch on. Tried friends battery still no joy...Please help is it the bin for it ?

Dave

  • 0

#2
Laser_iCE

Laser_iCE

    Diehard

  • Members
  • PipPipPipPip
  • 427 posts
  • Location:Brisbane AU
  • Devices:HTC Touch Dual (P5500)
Just to make sure, the battery was also from a C550? Have you tried leaving it sitting on the AC charger? Letting it sit on USB is normally no good as there isnt enough voltage going through it.

  • 0

Posted Image
MSN: gman ## at ## live.com


#3
dave55

dave55

    Newbie

  • Members
  • Pip
  • 16 posts

Just to make sure, the battery was also from a C550? Have you tried leaving it sitting on the AC charger? Letting it sit on USB is normally no good as there isnt enough voltage going through it.


Hi

The friends battery was from a c600 fully charged, still would not switch on.. Its now on the ac charger but no lights nothing, looks like a dead one

Dave

  • 0

#4
dave55

dave55

    Newbie

  • Members
  • Pip
  • 16 posts

Hi

The friends battery was from a c600 fully charged, still would not switch on.. Its now on the ac charger but no lights nothing, looks like a dead one

Dave


Just an update.. The phone started to boot the orange start up screen days later after being left the turn itself off and then nothing for at least 20 mins, then the same, orange start up screen then nothing, kept trying to to a hard reset but could never get it to activate. Left a few days with battery out then tried a hard reset . This time it caught the press zero to continue screen which i did it then went blank and stayed like that for a few minutes doing nothing like a normal reboot..

Finally it said no sim press to continue which i did and it just hung on no sim screen. Getting desperate i did it again with a sim in from a hard reset. This time i got past the valid sim screen and it then said Cold reboot phone restarting which it did.. ( heart Pumping madly) and wahoo :rolleyes: :( :) its back to normal..

What happened, corrupt firmware ? who know's. Just one thing when i take battery out it loses date and time is this normal or has the onboard battery died. Don't seem to remember it doing this.

Dave

  • 0

#5
fluffcat1

fluffcat1

    Hardcore

  • MoDaCo Gold
  • PipPipPipPipPipPip
  • 1,556 posts
  • Devices:8500 amongst others...

Just one thing when i take battery out it loses date and time is this normal or has the onboard battery died. Don't seem to remember it doing this.

Dave


The backup battery is either flat or faulty. Give it a good few hours charge after the main battery shows full then try it.

Check your warranty at http://service.htceurope.com/ if it is faulty.

Richard

  • 0
'....It's been out in Japan nearly 3 weeks - where's yours?'

#6
dave55

dave55

    Newbie

  • Members
  • Pip
  • 16 posts

The backup battery is either flat or faulty. Give it a good few hours charge after the main battery shows full then try it.

Check your warranty at http://service.htceurope.com/ if it is faulty.

Richard


Damm :rolleyes: :( :) Its crashed again won't switch on again, the odd flash on the red LED then tries to start, Is the backup battery causing this problem ?. Can it be replaced ? Going to have to catch it again and try to get it to reboot.. It appears to charge the battery even though its got no led's showing

Dave

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users