Jump to content


Photo

Windows Media Player and sleep mode

- - - - -

  • Please log in to reply
7 replies to this topic

#1
MarkBR

MarkBR

    Newbie

  • Members
  • Pip
  • 36 posts
  • Devices:HTC Legend, Advent Vega R8 Rom
Apologies if this is obvious, but I'm new to WM 5.0 ...

On the radio application, I can press the power button briefly to put the MDAC3 to sleep and continue to listen to the radio, saving the battery from powering the screen and disabling the front controls so they won't accidentally be pressed while the device is in my pocket.

However, listening to mp3 music on Windows Media Player 10, the same doesn't happen - the music stops until the power button is pressed again, which is a pain and means I have to leave the MDAC3 fully active in my pocket.

Does anyone know of a fix/workaround to this, or is this just a limitation of Media Player 10?

Thanks for any help!

  • 0

#2
mandt

mandt

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,309 posts
  • Location:Milton Keynes UK
  • Devices:Diamond, Kaiser
This is a good workaround, and you get some good software to boot!

Install Matt Armstrongs Device Lock from >HERE<, its a little app that lets you set the 'device lock' to a hardware key.
After you've installed it in the settings you can tell the program to run an app of your choice (Media player :) ) after it has locked your phone

  • 0

#3
MarkBR

MarkBR

    Newbie

  • Members
  • Pip
  • 36 posts
  • Devices:HTC Legend, Advent Vega R8 Rom
Thanks Mandt - I'll give it a go!

  • 0

#4
MarkBR

MarkBR

    Newbie

  • Members
  • Pip
  • 36 posts
  • Devices:HTC Legend, Advent Vega R8 Rom
Awesome mandt - it really does the job! Very impressed - thanks very much for your help.

  • 0

#5
mandt

mandt

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,309 posts
  • Location:Milton Keynes UK
  • Devices:Diamond, Kaiser
Two thank-yous in one thread!

If only all posters were as courteous as you :)

  • 0

#6
mungosdad

mungosdad

    Newbie

  • Members
  • Pip
  • 16 posts
  • Devices:orange spv m2000
Hi, Ive got the same problem, can't listem to media player and turn the screen off at the same time. Ive downloaded and installed the device lock program, and I've mapped the web/walk hardware button to device lock, but I cant get it to do what I want.
This is what I do:
I start a song in media player and press the device lock hrad button. the phone is now locked. When i then press the on/off button the the music stops as well.

Can somebody please tell me what I should be doing.

Thanks

  • 0

#7
MarkBR

MarkBR

    Newbie

  • Members
  • Pip
  • 36 posts
  • Devices:HTC Legend, Advent Vega R8 Rom

Hi, Ive got the same problem, can't listem to media player and turn the screen off at the same time. Ive downloaded and installed the device lock program, and I've mapped the web/walk hardware button to device lock, but I cant get it to do what I want.
This is what I do:
I start a song in media player and press the device lock hrad button. the phone is now locked. When i then press the on/off button the the music stops as well.

Can somebody please tell me what I should be doing.

Thanks


OK, this is how I got it working on mine....

In the DeviceLock settings (under the system tab), I selected 'Blank Screen'.

I start a song in media player and select DeviceLock (haven't mapped a button as I use web/walk for radio!)
The screen then blanks, the device is locked but the music continues.
The only oddity is pressing a button causes the buttons to light up, but they do not operate.
I then press on/off, the unit lights up and I can select 'Unlock' and confirm.


Not sure where you've gone wrong, as once its locked the on/off button should just light the screen and allow you to unlock. Perhaps get it working without mapping the button first to get it right, and then map afterwards.

  • 0

#8
mungosdad

mungosdad

    Newbie

  • Members
  • Pip
  • 16 posts
  • Devices:orange spv m2000
thanks for that, got it working now. I hadn't specified blank screen in the device lock settings. Its working great now.
Cheers

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users