Jump to content


Photo

SPV C500 doesn't charge the battery

- - - - -

  • Please log in to reply
2 replies to this topic

#1
moerdarbin

moerdarbin

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:SPV C500
I own Orange SPV C500 since May. For a month I used to charge it with USB cable connected to PC. But one day it stopped to charge the battery. Now if I connect it, the battery seems to be charging (orange diode shines and the charge-icon appears) but after few seconds it ends and the phone tells me the battery is full charged. If I remove the charger, the battery shows the right state - now about 50%.
I have also wall charger and two spare batteries and it's still the same. I also tried Hard Reset.

Do you have any ideas? Have you ever seen this problem?
I'm not in the UK now so I can't visit Orange shop for a consultation.

Any suggestions are welcome.

  • 0

#2
joe194b

joe194b

    Newbie

  • Members
  • Pip
  • 12 posts
  • Location:UK
  • Devices:SPV M700
I had this problem too and it turned out to be a duff battery.

regards Joe

  • 0

#3
moerdarbin

moerdarbin

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:SPV C500

I had this problem too and it turned out to be a duff battery.

regards Joe


Hi Joe, thanks for your reply. It seems you're right. I'm just testing borrowed battery and the phone seems to charge it without a problem. If it's OK during next days I'll buy a new battery.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users