Jump to content


Photo

Problems with the X1

- - - - -

  • Please log in to reply
10 replies to this topic

#1
andyboo

andyboo

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:Sony ericsson w960i
Hey guys, I got my X1 today, from Clove.co.uk! I believe i am the first person in Canberra (australia) to have one =] and that makes me proud.

But the X1 that has been bugging heaps for the day i got it. The X1 is a great phone, just some lil things that get really annoying me, but maybe not you guys out there. So this is for people who are considering getting the X1, just letting you guys know what im experiencing.

First off, every time i send an sms, moments later you will get a notification that says it has been sent, that is good and all, but when you hit dismiss, it dose not go away right away, and takes couple of seconds to get rid of, and in that time, everything lags. I.E. close the qwerty keyboard after touching the dismissed, it will not rotate back to landscape right in its normal speed, it takes longer.

Second, the optical joystick will come back on after you have disabled it! The whole day i have been disableing the optical joystick every 30min or so cause it would suddenly come back on ><"

Third off. There is no easy way to copy sim contacts on the phone with out making duplicates and then getting rid of the sim contacts so that you can attach a photo of the contact to the actual number. I have been searching every setting on the phone were i could just copy my sim contacts to the phone, and say just only see contacts on the phone and not sim and phone....it was stressing me out!

Fourth and last. Trying to make an .MP3 file as my msg tone.... I though it would be easy as, just add your mp3 to your mico SD card, and start using the media panel and it would pick up the .MP3 and that would hopefully add it to the list of choices you could choose to make it as your msg tone. WRONG! I have put the mp3 file all over the place. Root of the SD card and the internal memory of the X1. Still no luck. To make them as your ringtone is easy, just press, hold, and relase on the file you want, and it will give you an option to set it as your ringtone....but not your new message tone.

Well guys....if you actually read all that, i say thanks and sorry. Thanks for actually reading, and sorry that you have to read all that verbal diarrhea....

ALSO! The things i mentioned above before might only be effecting me like i said before, so please do not pressume all X1 is like this, and if you do experience these things and they do not bug you.... I need to learn to be more like you guys, LOL

p.s.

If any of you guys have a fix for these things please let me know =[

  • 0

#2
Chris Moore

Chris Moore

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:Sony Xperia X1i
Have a look at the Xperia Tweak thread to solve most of your problems...

  • 0

#3
andyboo

andyboo

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:Sony ericsson w960i

Have a look at the Xperia Tweak thread to solve most of your problems...


Yeah i should of done that then to express my rage, lol.

The tweak thread your talking about would it be this one by any chance?

http://forum.xda-dev...ad.php?t=440035

  • 0

#4
davsug

davsug

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Shadow, Excalibur, Touch
and let's not forget the bluetooth bug. got my X1 yesterday, and the BT has already randomly shut off 4 or 5 times. I was just playing with it and noticed the BT icon disappear a minute ago. This is going back on the shelf until they patch it.

  • 0

#5
andyboo

andyboo

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:Sony ericsson w960i
Now i have discovered another one >< the delete button on my keyboard at times works and dosent, mostly dosent >< ARGHHHH

  • 0

#6
j7seven

j7seven

    Newbie

  • Members
  • Pip
  • 12 posts
  • Devices:Samsung Omnia 7, Dell Streak
  • Twitter:@jonoble

Now i have discovered another one >< the delete button on my keyboard at times works and dosent, mostly dosent >< ARGHHHH


I have this problem quite frequently too. It's not that it doesn't work, it's just that it sticks in delete (i.e. delete forwards), rather than backspace (delete backwards) which it should do by default (i.e. without hitting the Fn (blue square) key first). I should note that the Fn indicator isn't being displayed at the time. I can work around it by hitting the Fn key (which shows the indicator), then hitting bs/del twice, first to delete (forwards) then to backspace, after which it works fine until the next time.

It's definitely not a case of the Fn key sticking, because none of the other keys that have a secondary function display this behaviour.

I'll have to look at that Xperia Tweak app - the message sent notification annoys me too.

Oh, while I'm on - does anyone know how to make Skype use the "correct" speaker? I want to use it as though I was making a normal phone call, not use it as a speaker phone.

  • 0

#7
melkenglas

melkenglas

    Newbie

  • Members
  • Pip
  • 2 posts
Hey

After waiting a friking year I got it! I am so happy.

But I need to adress a problem of wich I hope some can help me.

Via the WLAN > opera > I go to youtube try to play a vid...But nothing happings except the notification can not make a connection to network.

Tried Explorer same story downloaded flaslite 3 nothing there.

I can internet so it must me so settings I am missing?

Help me
B)

  • 0

#8
angamb

angamb

    Regular

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Norwich, England
  • Devices:Samsung Galaxy Note II
  • Twitter:@gadgetonomy
Ok, there's a handful of software problems, that in my opinion can be fixed with tweaks etc... But there are a few hardware problems you might like to note.

My battery cover refused to stay on. I was forced to get a small screwdriver and push the little metal tabs (near the SE logo) down a bit lower. This has been noted in other forums. The battery cover is a pain to get off if you don't have long fingernails.

The soft-reset button is under the said battery cover! I mean who decided that was a good idea??

The speaker is situated in a place that is often covered up by the palm of your hand (if you are right handed) and subsequently blocks the sound. The same can be said for the positioning of the camera lens, which frequently gets covered by fingers as you hold the phone in a natural camera position.

Notification LED's that are just too dim to see as they are located in between the keyboard and top panel.

And if that's not bad enough take a look at this link for details of a potential problem with case cracking:
http://forum.xda-dev...ad.php?t=447211

However, at the risk of contradicition, I do actually think this is one of the best HTC based devices built so far. There are plenty of rave reviews about it but I think it's good to point out a few niggles!

  • 0

#9
johnchan

johnchan

    Regular

  • Members
  • PipPip
  • 60 posts

I have this problem quite frequently too. It's not that it doesn't work, it's just that it sticks in delete (i.e. delete forwards), rather than backspace (delete backwards) which it should do by default (i.e. without hitting the Fn (blue square) key first). I should note that the Fn indicator isn't being displayed at the time. I can work around it by hitting the Fn key (which shows the indicator), then hitting bs/del twice, first to delete (forwards) then to backspace, after which it works fine until the next time.

It's definitely not a case of the Fn key sticking, because none of the other keys that have a secondary function display this behaviour.


This is EXACTLY the same problem I have. I have a X1i (UK). How about you?

I'll note I also have CE Star (for chinese entry/viewing), do you have this installed to? Could this be the common software causing this VERY annoying problem?

  • 0

#10
kuztardd

kuztardd

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:k8001
the x1 is a lovely piece of kit, but, fresh from the box it has a few frustrations that are easily ironed out.... but if u are not a nerd like the rest of us, and don't use forums to find out your answers then the phone can be deemed as not naturally perfect.
once u have tweaked the hell out of this phone it is amazing. but really, u shouldn't have to, should u?

two things that are annoyoing me this morning are :
1) if u send a text message when u don't have a signal, it stores the message but wont send it automatically when u do have signal (other SE phones used to)

2) if u set an alarm to go off but your phone is off at that time, u don't get alerted.

or is it only me with those problems?

  • 0

#11
evos_87

evos_87

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:X1i
okay, i dont know if u guys got this, or its just my phone.

it seems that when i slide my phone open, the screen rattles a bit.
its a bit hard to explain, but when the screen is slides out, try to shake it a bit. my screens seems to rattle for some reason. what i mean here is the whole screen part of the phone rattle a bit. as if its not held firm to the slider. is this normal?

i took it back to sony ericsson center, and they say that its actually like that. it happens so that the device can actually slides.

i dont know if this how it suppose to work or not, cuz i havent got a clue on how the slider on this things works. sorry for my bad english

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users