Jump to content


Photo

Cyanogen 3.9.6 for Sapphire / Magic (tested on Vodafone Magic)

- - - - -

  • Please log in to reply
4 replies to this topic

#1
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,366 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
This is a very straightforward port of Cyanogen's awesome 3.9.6 ROM to run on the HTC Sapphire / Magic (tested on the Vodafone Magic).

Apply as any other update.zip (via modified recovery image).

http://content.modac...hire-signed.zip

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#2
LadFromWales

LadFromWales

    Decisions, decisions...

  • Members
  • PipPip
  • 90 posts
  • Location:Pembrokeshire, Wales, UK, Earth, The Universe
  • Interests:The Ladies, Phones, Computers, Coffee
  • Devices:Google Nexus One, HTC Magic
  • Twitter:@LadFromWales
Paul,
Can I ask what you have done to this rom?
Have you taken CM's rom and applied your own tweaks or have you taken another rom and applied parts from CM?

I'm just wondering because you appear to have trimmed apps, changed the phone name, and sounds are missing where they were included in CM's 3.9.5

I do love the ROM, though! Compcache works and I've found that it has to be a dealbreaker as far as me keeping a crippled magic is concerned. It allows me to almost seamlessly switch between the Browser and Messages apps without eachother having to reload which is fantastic, it's now as good as a standard Sony Ericsson!

For odd reasons I need to push a /system/lib/libwebcore.so from an older rom (CM's 3.6.8.1) to get Browser to even start. The only other tweak I can think of, is taking the audio config files from another rom, as I am guessing the files present in the rom are designed for the Dream, though I've not made a call or used AD2P to confirm that yet.

Cheers though!

  • 0

May put something useful here soon, maybe...


#3
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,366 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
That's kinda odd... I literally just renamed 1 file in the boot.img to add sapphire support, so nothing should be missing (and nothing IS missing on my magic!). Maybe try reapplying?

Browser, wifi etc. etc. all worked OOTB.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#4
LadFromWales

LadFromWales

    Decisions, decisions...

  • Members
  • PipPip
  • 90 posts
  • Location:Pembrokeshire, Wales, UK, Earth, The Universe
  • Interests:The Ladies, Phones, Computers, Coffee
  • Devices:Google Nexus One, HTC Magic
  • Twitter:@LadFromWales
Yeah it does seem odd. I've tried countless reflashes and wipes and even different SD cards to get browser to run with the newer libwebcore.so
I'm not sure if there is some files somewhere that survive a wipe followed boot and system getting formatted while an update occurs. Perhaps something is surviving that is preventing the newer libwebcore.so from working. Other people get weirder problems with their 32B magics, like WiFi not working, the G-Sensor, or even not able to boot the rom at all!

Can you change my forum name to 'LadFromWales' ?

Slowly getting round the many millions of places I visit removing the 85!

Cheers :)

  • 0

May put something useful here soon, maybe...


#5
macada

macada

    Newbie

  • Members
  • Pip
  • 1 posts

Yeah it does seem odd. I've tried countless reflashes and wipes and even different SD cards to get browser to run with the newer libwebcore.so
I'm not sure if there is some files somewhere that survive a wipe followed boot and system getting formatted while an update occurs. Perhaps something is surviving that is preventing the newer libwebcore.so from working. Other people get weirder problems with their 32B magics, like WiFi not working, the G-Sensor, or even not able to boot the rom at all!

Can you change my forum name to 'LadFromWales' ?

Slowly getting round the many millions of places I visit removing the 85!

Cheers :(


I have created this howto.
Hope this helps because if very useful.

http://wiki.ousli.or...CyanogenMod_ROM

Regards

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users