Jump to content


Photo

[VIDEOTORIAL] How To Flash Omnia i900 & i910 on Windows 7, Vista & XP (Noob Friendly)

* * * * * 2 votes

  • Please log in to reply
145 replies to this topic

Poll: Some polls to help me help you ;) (153 member(s) have cast votes)

Whas this helpful?

  1. Yes, Now I'm able to flash my omnia! jay! (93 votes [64.14%])

    Percentage of vote: 64.14%

  2. Nope, I didn't understand anything at all! (27 votes [18.62%])

    Percentage of vote: 18.62%

  3. Yeah, kinda, still some questions, but it helped (25 votes [17.24%])

    Percentage of vote: 17.24%

Vote Guests cannot vote

#41
phille

phille

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:Samsung Omnia i900

Have you vlited your windows build? If you don't know what that means you haven't. Because if you did that might be the issue.

The program still says it's waiting for rebooting...

Service stopped successfully
Calculating file parameters(DISKIMAGE)....
Calculating file parameters(DISKIMAGE) Done!!
OnDeviceChange: DBT_DEVICEARRIVAL
-------------------------------------------------------------------------------------
PDA Device 1 ready to download!
-------------------------------------------------------------------------------------
PDA 1 starts downloading...
Don't plug it out until the label becomes blue!!!
-------------------------------------------------------------------------------------
EBOOT will be written.
Total 1 PDA region(s) will be written .
-------------------------------------------------------------------------------------
Downloading EBOOT...
PDA Reboot to download Eboot twice!!!
-------------------------------------------------------------------------------------
Service stopped successfully
OnDeviceChange: DBT_DEVICEARRIVAL
PDA Device not found.

  • 0

#42
reborn64

reborn64

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:Samsung Omnia i900
excellent stuff, worked the first time ;)

  • 0

#43
ChromeNewt

ChromeNewt

    Newbie

  • Members
  • Pip
  • 28 posts
  • Location:Suffolk, UK
  • Devices:Orange San Francisco
  • Twitter:@chromenewt

Have you vlited your windows build? If you don't know what that means you haven't. Because if you did that might be the issue.

Nope, not vlited at all. It's a mystery. ;)

  • 0

#44
mikevhl

mikevhl

    Regular

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Location:Arnhem, Netherlands
  • Devices:Samsung Omnia i900

The program still says it's waiting for rebooting...

Service stopped successfully
Calculating file parameters(DISKIMAGE)....
Calculating file parameters(DISKIMAGE) Done!!
OnDeviceChange: DBT_DEVICEARRIVAL
-------------------------------------------------------------------------------------
PDA Device 1 ready to download!
-------------------------------------------------------------------------------------
PDA 1 starts downloading...
Don't plug it out until the label becomes blue!!!
-------------------------------------------------------------------------------------
EBOOT will be written.
Total 1 PDA region(s) will be written .
-------------------------------------------------------------------------------------
Downloading EBOOT...
PDA Reboot to download Eboot twice!!!
-------------------------------------------------------------------------------------
Service stopped successfully
OnDeviceChange: DBT_DEVICEARRIVAL
PDA Device not found.


that probally means that it didn't find the drivers for the omnia in flashing-mode. What happens when you try flashing your omnia without selecting a eboot file? and are you using vista or 7?

  • 0

#45
leap_ahead

leap_ahead

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,275 posts
  • Gender:Male
  • Location:limassol
  • Devices:i900
flash rom complete ..thanks... but how i can flash radio with this ?

  • 0

Official i900BDHJ3/BDHJ3 Windows Mobile 6.1 20271 133Mb - i900DXIF1 Radio


#46
^nighthawk^

^nighthawk^

    Newbie

  • Members
  • Pip
  • 49 posts
  • Devices:Samsung Galaxy S

flash rom complete ..thanks... but how i can flash radio with this ?


Install the vista modem driver if you can find the right one (works on 7 32-bit also). If your on 64-bit...it may work if you do an F8 and stop the driver signing on boot.

Once done, plug in omnia, let windows mobile device center find it.

Then follow the normal steps to untick the device so windows mobile device center does not launch.
Use the grandprix tool to flash a rom as described in this thread but also include the phone part you want to flash.
It will fail when it switches to radio usually and will then act like it is installing a driver, it may even say it fails....let it.
Then remove the omnia, plug it back in.
Try the grand prix again (i think i may have rebooted after the failed driver install) with the phone part.
It worked the next time around.

There is probably a cleaner way, but this seems to work for me on multiple pc's.

  • 0

#47
mikevhl

mikevhl

    Regular

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Location:Arnhem, Netherlands
  • Devices:Samsung Omnia i900

Install the vista modem driver if you can find the right one (works on 7 32-bit also). If your on 64-bit...it may work if you do an F8 and stop the driver signing on boot.

Once done, plug in omnia, let windows mobile device center find it.

Then follow the normal steps to untick the device so windows mobile device center does not launch.
Use the grandprix tool to flash a rom as described in this thread but also include the phone part you want to flash.
It will fail when it switches to radio usually and will then act like it is installing a driver, it may even say it fails....let it.
Then remove the omnia, plug it back in.
Try the grand prix again (i think i may have rebooted after the failed driver install) with the phone part.
It worked the next time around.

There is probably a cleaner way, but this seems to work for me on multiple pc's.


This might work, but I think it's innescesarry to flash phone parts, this process isn't really noob-friendly and isn't required for getting WM6.5 on your omnia, so I won't include it. Thanks for the advice though, I would've answered that it's impossible to flash on 7/vista

  • 0

#48
^nighthawk^

^nighthawk^

    Newbie

  • Members
  • Pip
  • 49 posts
  • Devices:Samsung Galaxy S

This might work, but I think it's innescesarry to flash phone parts, this process isn't really noob-friendly and isn't required for getting WM6.5 on your omnia, so I won't include it. Thanks for the advice though, I would've answered that it's impossible to flash on 7/vista


Sorry didnt want to spam your very helpful thread just was answering the question of leap.

  • 0

#49
mikevhl

mikevhl

    Regular

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Location:Arnhem, Netherlands
  • Devices:Samsung Omnia i900

Sorry didnt want to spam your very helpful thread just was answering the question of leap.

haha thanks and no problem:P

Edited by mikevhl, 10 February 2010 - 09:10 PM.

  • 0

#50
TekkenOmnia

TekkenOmnia

    Newbie

  • Members
  • Pip
  • 19 posts
@leap_ahead

how did you flash it? because i cant flash mine here... it always say PDA Device not found.. can you help me?

  • 0

#51
LiveDuo

LiveDuo

    Newbie

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Nikosia
VERY IMPORTANT

TIP:
WE SHOULD RUN "USDL Grandprix AS" ADMINISTRATOR

  • 0

#52
TekkenOmnia

TekkenOmnia

    Newbie

  • Members
  • Pip
  • 19 posts
@LiveDuo

i Did that already but nothing happens still "PDA DEVICE NOT FOUND"

  • 0

#53
mikevhl

mikevhl

    Regular

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Location:Arnhem, Netherlands
  • Devices:Samsung Omnia i900
it might be that you DO need to install drivers on vista, can you please report wether you use windows vista or 7?

  • 0

#54
MimomaN

MimomaN

    Enthusiast

  • Members
  • PipPipPip
  • 172 posts
  • Gender:Male
  • Location:CAiRO
  • Devices:Omnia I900
  • Twitter:@Non
Thanks for the great tutorial man

in the last part you said :
" it will say "tap the screen to setup your device" on your omnia, do this. But instead of going on, wait ~3 minutes for your phone to restart by itself and present you the screen with "tap the screen to setup your device" again. this time continue the device setup and you're done. "

when " tap the screen to setup your device" appeared i pressed on the screen and waited as you said , 5 and 10 minutes but the phone didn't restarted !!
so what ?
i completed the setup and i didn't make this step , any thing bad could happen or something wrong ??

  • 0

#55
devil_bur

devil_bur

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:samsung i900
thank you very much, now i didn't need to change to xp nor finding xp iso thx

  • 0

#56
sx1

sx1

    Newbie

  • Members
  • Pip
  • 21 posts
  • Devices:Galaxy S, Desire
Hi when I come to the grand prix & I switch on the phone, i get an error "usdl has stopped responding...blah blah" & my phone starts up like it does normally.

BTW my first flahs & im flashing from 6.1 to 6.5.

  • 0

#57
Mudvayne622

Mudvayne622

    Newbie

  • Members
  • Pip
  • 8 posts
  • Devices:Samsung Omnia i910
You should really slow down the video even more. Is the EXEcutor 2.7 program required? i have an i910 and i use winrar to extract my .bin file. is that all that EXEcutor is doing?

  • 0

#58
mikevhl

mikevhl

    Regular

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Location:Arnhem, Netherlands
  • Devices:Samsung Omnia i900

You should really slow down the video even more. Is the EXEcutor 2.7 program required? i have an i910 and i use winrar to extract my .bin file. is that all that EXEcutor is doing?

Yes, I didn't know that that was possible on winrar as well :D and the program is EXEcutor indeed

  • 0

#59
mikevhl

mikevhl

    Regular

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Location:Arnhem, Netherlands
  • Devices:Samsung Omnia i900

Thanks for the great tutorial man

in the last part you said :
" it will say "tap the screen to setup your device" on your omnia, do this. But instead of going on, wait ~3 minutes for your phone to restart by itself and present you the screen with "tap the screen to setup your device" again. this time continue the device setup and you're done. "

when " tap the screen to setup your device" appeared i pressed on the screen and waited as you said , 5 and 10 minutes but the phone didn't restarted !!
so what ?
i completed the setup and i didn't make this step , any thing bad could happen or something wrong ??

No that's fine, it's just that if you get a sms and the phone reboots very shortly after that, the sms gets lost. You won't have any problems at all :D

  • 0

#60
mikevhl

mikevhl

    Regular

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Location:Arnhem, Netherlands
  • Devices:Samsung Omnia i900

thank you very much, now i didn't need to change to xp nor finding xp iso thx

You're very welcome :D

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users