Jump to content


Photo

Fastboot failed when updating ROM`(PROBLEM SOLVED!)

- - - - -

  • Please log in to reply
No replies to this topic

#1
Down to earth Swede

Down to earth Swede

    Regular

  • Members
  • PipPip
  • 64 posts
I had the old leaked (modified) 2.000.05_AAP_GEN2 ROM that I was updating to 2.000.16.

Did the things described to use the new ROM with the old download tool (since it isn't possible for this particular ROM to be updated with the new tool)
That is, extracting to temp directory with the new tool (with the liquid not plugged in) and then using that file with the old tool (talked about in another thread).

Everything was good (the normal long process where loads of stuff is being done in the tool) but then I got the "Fastboot failed error" a couple of times, with a couple of retries and finally a "Can remove USB Cable. Restoration is needed." message.

I restarted the phone and it took forever to startup again.
But it did!
And now it says that the build number is "Acer_Liquid_2.000.16_EMEA_GEN1", i.e the newer version of the ROM.
But all my apps and settings are stil there.

What the h-ll is going on here?
I noticed one thing that was a bug before. In apps that uses maps, except for google maps itself, there used to be an orange square in the left corner.
It is now gone!
Does that mean that the flash still worked in some strange way, even though it was clearly stated that "Restoration is needed".
If so, I must be extremely lucky to still keep everything (had done a backup with mybackup and astro before this though) AND also get the phone updated.
But I guess something isn't as it should be with this thing...
Any other way to find out if everything is OK?
What should I otherwise do?
The reason for me to move to 2.000.16 and not the new leaked 2.1 was that I wanted to do a nandroid backup from an official ROM(like 2.000.16) before updating.


EDIT : PROBLEM SOLVED!

I just tried to flash again and now it worked as it should all the way!
Don't know what was wrong the first. And what it was about the bug that disappeared.

One thing I notice in the new version though is that the quick search (from the menu) still just works in portrait mode. Nothing happens when I turn the phone to landscape. Is this the same with all newer roms?

Edited by Down to earth Swede, 05 April 2010 - 01:25 PM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users