Jump to content


Photo

MILESTONE 2.1 update and root guide

* * * * * 1 votes

  • Please log in to reply
23 replies to this topic

#21
placca

placca

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Motorola Milestone (Russian)

Intro
Here is my 2.1 update and root guide. Firstly I would like to thank the community for these files used in this guide, without them we would not have root.

I have tried this process on my UK MILESTONE using the following:

  • UK MILESTONE.
  • 2.1 UK SBF (non-service).
  • 90.73 bootloader.
I cannot guarantee you will have the same success as me if you try a different bootloader version or SBF country/version.

Before you start, a few points to make:
  • I am not responsible if your phone becomes bricked from this. It worked perfectly for me without a single hitch but for you it could be different.
  • Flashing a non-service SBF will WIPE the phone, so you will start from a blank slate.
  • If you don't know what root is, then read up on it first. It may not be for you. Chances are if you are happy with your phone and you don't find it lacking, then you don't need root.
  • Please read the WHOLE guide before starting, if you find yourself confused, then do NOT start. Ask first - you may break your phone.
  • It is recommended you do this on a computer that isn't going to crash or power down mid-update. A laptop plugged in with a good battery is recommended.
PrerequisitesProcedure
So, if you've got this far and have decided to take the plunge and downloaded all the prerequisites, then you're ready to get started!

Follow these steps carefully and you'll have your MILESTONE with rooted 2.1!
  • Charge your phone battery up FULL. While your phone is charging, install the USB drivers and RSD Lite.
  • When the phone has finished charging, shut it down and unplug the USB cable from the phone.
  • Load the phone up into bootloader mode by holding the UP direction button on the D-PAD of the phone (up as in towards the screen) and pressing the power button until you see the screen light up.
  • You should be presented with the following text:
    Bootloader
    <version number>
    Battery OK
    OK to Program
    Connect USB
    Data Cable
  • Connect your USB cable to the phone and the last two lines should change to:
    Transfer Mode:
    USB
  • Now you can load up RSD Lite using the icon on your desktop. Follow the steps in this image, selecting the 2.1 SBF you wish to flash (not the vulnerable recovery, that is later).
    Posted Image
  • Wait for RSD Lite to finish (The Status column will read Finished and the Result column should read PASS).
    If you get anything else or it seems to be taking forever, please ask here and do not interrupt the program or phone.
  • When your phone boots up and asks you to set it up, shut it down and repeat step 3 of this guide.
  • Once into the bootloader again, you can flash the vulnerable recovery SBF. Repeat step 6, but this time select the vulnerable recovery SBF and not the 2.1 SBF. This update should take a few seconds/minutes, and the phone will start back up once this is done with RSD Lite reading a Finished and PASS result in their respective columns.
    Again, if you experience problems as outlined in step 7, don't interrupt the phone/program. Ask in this thread.
  • In Windows explorer, navigate to the SD card of the phone and copy the milestone_root.zip file over and rename it to update.zip.
  • Once that has copied, shut the phone down once more and put it into recovery mode (not bootloader).
    To get into recovery mode:
    • For bootloader 90.78: X button on keypad
    • For bootloader lower than 90.78: Camera button on side of phone
    Hold the respective button as detailed above and the power button together. When the Motorola logo appears, release the power button but keep hold of the X/Camera button until this icon appears:
    Posted Image
  • Phew! If you made it this far then congrats, you nearly have root!
    Now hold the Volume Up button and press the Camera button to bring up the command menu.
  • Select from the menu using the D-PAD and choose apply sdcard:update.zip. If all is well it should start saying Rooting your phone..., once it is complete the command menu will re-appear. Simply choose reboot system now.
  • Once the phone has started back up again, go through the initial setup (or skip it) and you should have a new app called Superuser Whitelist.
    Whenever an app requests root access you will get a prompt on screen similar to
    Posted Image
End
If you made it fully through this guide then you should now be able to download apps such as Root Explorer and be able to mount the various directories as r/w and be able to start going deeper into modding your phone.

One of the best bits of this is being able to uninstall the CRAPPY apps that come with the phone and clog up memory such as Facebook or Sim Toolkit (these are deleted from /system/app), you can find out more about modding with root by other various guides.

Just as a final note: I recommend turning off OTA updates as they wont work for a rooted phone, you'll need to use RSD Lite from the future (unless you unroot).

Well I hope you find this guide useful! Took me long enough to write it :unsure:

Known Issues
  • Sometimes, even when you have done everything right in RSD Lite - the start button remains greyed out. You must launch it by command line on such occasions:
    Download this batch file, copy it and the SBFs you wish to flash into the RSD Lite folder and then drag and drop the SBFs you wish to flash onto it.
  • Sometimes RSD Lite is unable to restart the phone as it needs (RSD Lite will read: Please manually power up this phone). If this happens you must manually assist the phone in flashing. Thanks to tazd for reporting this issue and finding the workaround.
  • Disconnect the USB cable and shut the phone down.
  • Start the phone up in bootloader mode.
  • Reconnect the USB cable. RSD Lite should continue now.



Hi!

Nice to see a great guide for rooting Milestone for European fellows as well; now i live in Hungary and recently purchased what turned out to be a Russian version of Milestone. I want to root it because I cannot use 3G services though I do have the correct settings from my service provider (Telenor).
Do you think it would help or will I possibly have some issues while rooting? I want to flash Central-European non-service 2.1 SBF.

Thanks,
Placca

  • 0

#22
roosh

roosh

    Newbie

  • Members
  • Pip
  • 1 posts
Progress failed at step 9 during vulnerable sbf.
I got a " Critical Error: FEBE " after FEBE there was a number but I don't remember it.
what should I do?

Edited by roosh, 14 February 2011 - 03:19 AM.

  • 0

#23
droidtech1

droidtech1

    Newbie

  • Members
  • Pip
  • 1 posts
Edited ***

I am having a problem. I managed to complete the root process but have a strange side effect after: screen slider is missing so can't unlock screen. Thought it was vunerable recovery at first deleting it because I saw the slider after flashing the 2.1 UK sbf, but after more experimentation I realised that after flashing the 2.1 UK sbf it reboots automatically and the slider is there, then if the phone is rebooted again, the slider is missing(this happens wether I flash vun recov or not). I did get the manually reboot error on RSD but followed the instructions of unplugging usb before rebooting in boot mode, had zero effect.

Obviously something is wrong with the 2.1 UK sbf I used. Is there a better source of droid sbf files other than
http://and-developers.com/sbf
?

Edited by droidtech1, 28 March 2011 - 11:23 AM.

  • 0

#24
varumin

varumin

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:motorola milestone singapore
hello i think i may have bricked my phone. at first, i tried rooting and it worked. but not as i hoped.

im using motorola milestone from starhub singapore.

used the STAR_36_GOT_SERVICE and OR-GOTmod_v1.04a from GOT to do what i needed, even managed to push the cpu up to 800mhz. problem is after booting, the android OS kept giving force close messages.

i tried reflashing again with a different rom this time.
used the SHOLS_U2_05.26.4_SIGNED_UCASHLSMR2EMEAB1B806E.0R_PDS003_USAMS1FRYORTSEA_P013_A00
_HWp2a_WIG145030_Service1FF.sbf

this time it hung on the rsdlite for about 2 hrs and i just plugged it out. after which when i boot up the phone it now shows

bootloader 90.78
code corrupt

battery low
cannot program


the battery low and cannot program errors are flashing.

i tried leaving it to charge overnight via direct a/c charger then the next morning trying to get to the boot loader by holding down X on the keyboard then the power button but after i let go of the x, then the power button the same screen still shows!

i do not get the triangle with an exclamation mark within it anymore!

i noticed that when i charged it direct to A/C the led near the usb port did not light up.
but when i plugged it into the usb port on my laptop, it did.

am now leaving the phone to charge via usb. its now 10.43am. hopefully i do not get that problem again tonight when i try again after dinner.

Can anyone please help me on this matter?

Thanks

im using motorola milestone from starhub singapore.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users