Jump to content


Photo

CoPilot Support - Driving me crazy

- - - - -

  • Please log in to reply
1 reply to this topic

#1
Calamity James

Calamity James

    An accident waiting to happen!

  • Members
  • PipPip
  • 97 posts
  • Gender:Male
  • Location:Maidstone, Kent
  • Devices:Galaxy Nexus, HTC One
  • Twitter:@JamesH
It's been over a week now since I got the "Google Checkout order number invalid" error, and I have to say, I'm not 100% impressed with their support.

I'm lucky to get one reply per day from their tech support team (even if I reply within 10 minutes of their reply), and it updates to "Solved" every time they reply!

First suggestion was to uninstall and reinstall, which I'd already tried. I now get a bit further, I get: "Sorry! Your CoPilot Trial Has Expired – Error 703".

Then they suggested the same again, but asked me to delete all my maps too and download them from a link they provided. I wasn't convinced as I don't even get far enough into the setup wizard to get the maps. So they suggested creating a new CoPilot ID, again, the same problem!

Has anyone else managed to get a solution to all of this? It's starting to get beyond a joke now!

James.

Edited by Calamity James, 17 May 2010 - 11:31 AM.

  • 0
Had: T-Mobile Pulse (dropped down a drain!), Orange San Francisco, HTC Desire
Have: HP TouchPad running ICS, Samsung Galaxy Nexus, HTC One

#2
Cowie

Cowie

    Regular

  • Members
  • PipPip
  • 71 posts
  • Devices:Nexus S

It's been over a week now since I got the "Google Checkout order number invalid" error, and I have to say, I'm not 100% impressed with their support.

I'm lucky to get one reply per day from their tech support team (even if I reply within 10 minutes of their reply), and it updates to "Solved" every time they reply!

First suggestion was to uninstall and reinstall, which I'd already tried. I now get a bit further, I get: "Sorry! Your CoPilot Trial Has Expired – Error 703".

Then they suggested the same again, but asked me to delete all my maps too and download them from a link they provided. I wasn't convinced as I don't even get far enough into the setup wizard to get the maps. So they suggested creating a new CoPilot ID, again, the same problem!

Has anyone else managed to get a solution to all of this? It's starting to get beyond a joke now!

James.


It's been a week since I submitted a support query on exactly the same matter. Not had any response, yet my query is still on their system - I even added an update begging someone to either contact me or refund me a few days ago. Nothing!

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users