Jump to content


Photo

How To: Root the Motorola CLIQ XT


  • Please log in to reply
2 replies to this topic

#1
TheUnlockr

TheUnlockr

    Newbie

  • Members
  • Pip
  • 32 posts
DOWNLOADS AND INSTRUCTIONAL VIDEO LOCATED HERE

I. Install the Motorola Drivers

1. Download the drivers for your computer and unzip them. Then double click the program inside to install the drivers.

Motorola Drivers (for 32 bit Computers) OR Motorola Drivers (for 64 bit Computers)

2. On your phone, go to Menu > Settings > Applications > Development > and make sure USB Debugging is checked ON.

II. Install the Android SDK

1. Follow our How To Setup ADB procedure just until you can see the device's serial number at the end of step 6. Then come back to this procedure.

III. Root the Phone

1. Download the Rooting Files and extract them to the C: drive on your computer (like you did the AndroidSDK).

CLIQ XT / Quench Rooting Files

2. Plug in your phone via USB cable and select Charge Only on the phone.

3. On your computer, open a command prompt by clicking on the Start menu then typing in cmd and hitting enter in the search box.

4. In the command prompt, type the following, with hitting enter at the end of each line:

cd\
cd c:\androidsdk\tools\
adb push c:\Superuser.apk /sdcard/Superuser.apk
adb push c:\su /sdcard/su
adb push c:\rageagainstthecage-arm5.bin /data/local/tmp/rageagainstthecage-arm5.bin
adb push c:\install-root.sh /data/local/tmp/install-root.sh
adb shell
cd /data/local/tmp
chmod 0755 rageagainstthecage-arm5.bin
chmod 0755 install-root.sh

5. Once you have done that, leave the phone plugged in and go to the Market and download the Free version of ConnectBot and install it.

6. Open the ConnectBot, select local in the dropdown menu, then type local into the field and hit enter. Then type the following in, on the phone, with hitting enter at the end of each line (leave the phone plugged in to the computer while you do this).

cd /data/local/tmp
./rageagainstthecage-arm5.bin

7. If it worked, you should see the following on the screen.

[+] Forked xxxx childs. (xxxx will be an actual 4 digit number)

If you do not, then close the ConnectBot and reopen it and try again.

8. If it worked, close the terminal by either typing exit and hitting enter or by hitting menu and clicking close.

9. Once it is closed, reopen ConnectBot.

10. You should now see a # symbol, if so continue. If not then start over from step 4 or go here for a tip from another reader.

11. Now, with the # symbol in ConnectBot on your phone, type the following with hitting enter at the end of the line:

/data/local/tmp/install-root.sh

You should see nothing pop up after you hit enter, that means it worked, you now should have root access and be able to open your App Drawer on the phone and see Superuser Permissions inside.

12. To load a custom ROM and other fun stuff, head from here to our How To Load a Custom ROM procedure.

Thanks Skrilax_CZ!
Thanks Sebastian Krahmer!

Hope this helps!

  • 0

#2
cbsummers1973

cbsummers1973

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:Nexus One
Ok so I have followed the directions and when I look I have superuser in my app drawer. However whenever I try to install recovery or anything it won't let me push SU and tells me I don't have permission. I also can't unroot the phone so now I am stuck with a phone that shows it's rooted without being able to do anything.

Any help would be very appreciated.

~Chris

  • 0

#3
JohnCena

JohnCena

    Newbie

  • Members
  • Pip
  • 4 posts
At this point, you can't. It looks like developers are holding off until the 2.1 update before they spend their time creating a modified ROM for the device.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users