Jump to content


Photo

Wifi Not working

- - - - -

  • Please log in to reply
8 replies to this topic

#1
azeemfazal

azeemfazal

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:ZTE Blade/OSF
The following is my problem:
When trying to connect any Wi-Fi network, it stuck on obtaining address, any open network, request seems to time out. There is an error. In all cases no problem connecting to same network with laptop and other Wi-Fi enabled phones.

My ROM is:
DSTL1 Wifi
My Hardware Version is:
Base version 20/05/2009,st32,x2a.m1
Kernel 2.6.29-senthilvel.prabakrn@si-rd10-ubld01 #1
Firmware 1.6 (Android Donut)
Software version: GT540-V10A-MAY-13-2010.

What I have tried:
Everything. I have removed battery, rebooted.
I have reinstalled factory settings, I have configured my home router linksys WRT54G with no security, no mac filtering, created static IP address for phone mac and configured phone with static address but nothing works. Router works fine with other handheld devices and laptop.
I live outside of UK and cannot claim its warranty. I installed an app Wifi buddy to see if additional settings would help, did not work.
Phone can see Wi-Fi networks and has excellent signal strength. No problem finding networks. It just can't seem to obtain the IP address. I have also checked on the wireless router that it assigned IP address to my phone.

Any help would be appreciated. This seems like a good phone/solid hardware but if it can see the Wi-Fi networks and signal strength is good, what could be going wrong? I KNOW, maybe router configuration, but I have tried EVERY POSSIBLE CONFIGURATION for IP address and with no security and no luck.

It is a very frustrating problem!!! Kindly resolve this issue ASAP.

Thanks in Advance
Regards,
Azeem Fazal

  • 0

#2
mixlis

mixlis

    Regular

  • Members
  • PipPip
  • 80 posts
  • Location:Hellas
An another guy had problem with gt540 and linkys router. Have you tried a different wifi hotspot?

  • 0

#3
ijcy

ijcy

    Regular

  • Validating
  • PipPip
  • 110 posts
  • Devices:LG gt540

The following is my problem:
When trying to connect any Wi-Fi network, it stuck on obtaining address, any open network, request seems to time out. There is an error. In all cases no problem connecting to same network with laptop and other Wi-Fi enabled phones.

My ROM is:
DSTL1 Wifi
My Hardware Version is:
Base version 20/05/2009,st32,x2a.m1
Kernel 2.6.29-senthilvel.prabakrn@si-rd10-ubld01 #1
Firmware 1.6 (Android Donut)
Software version: GT540-V10A-MAY-13-2010.

What I have tried:
Everything. I have removed battery, rebooted.
I have reinstalled factory settings, I have configured my home router linksys WRT54G with no security, no mac filtering, created static IP address for phone mac and configured phone with static address but nothing works. Router works fine with other handheld devices and laptop.
I live outside of UK and cannot claim its warranty. I installed an app Wifi buddy to see if additional settings would help, did not work.
Phone can see Wi-Fi networks and has excellent signal strength. No problem finding networks. It just can't seem to obtain the IP address. I have also checked on the wireless router that it assigned IP address to my phone.

Any help would be appreciated. This seems like a good phone/solid hardware but if it can see the Wi-Fi networks and signal strength is good, what could be going wrong? I KNOW, maybe router configuration, but I have tried EVERY POSSIBLE CONFIGURATION for IP address and with no security and no luck.

It is a very frustrating problem!!! Kindly resolve this issue ASAP.

Thanks in Advance
Regards,
Azeem Fazal

I had this and what i did was press on the Wifi that did not work and chose forget it.
then i turned off Wifi and turned back on, it found the network again i input the password and voila.

  • 0

#4
RottenFoxBreath

RottenFoxBreath

    Diehard

  • Members
  • PipPipPipPip
  • 323 posts

*snip*


Try installing HiddenSSID Enabler from the market, make sure your SSID on your router is enabled, so your router can be seen to the world, then run the programme on your phone, input your details, and then once it's connected you can hide your network again.

1.6 has issues with hidden networks, etc..

  • 0
Posted Image

#5
shoarmabakpao

shoarmabakpao

    Diehard

  • Members
  • PipPipPipPip
  • 395 posts
  • Gender:Male
  • Devices:Samsung Omnia II, Galaxy Nexus

An another guy had problem with gt540 and linkys router. Have you tried a different wifi hotspot?


Well, i'm that guy with the gt540 and an linksys router. It is my router that is the problem, my neighbourds have also an linksys router but they don't got this problem. They got also an android phone there (Samsung Galaxy S) but that one didn't make a problem, mine also didn't. However at home...the problem occurs. This is only happening to my lg GT540GO and my uncle's Sony eircsson xperia X10 (both 1.6) galaxy was 2.1 or 2.2 my other 2 phone's (sony ericsson xperia X1 and samsung omnia 2) DO work on my router and so does my other uncle's iPhone 3gs 32GB

I think this happens only to android 1.6, I am not able to update to 2.1(it keeps giving error wparam 100 blablabla) so I can't test it out even though I want it =(

  • 0

#6
azeemfazal

azeemfazal

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:ZTE Blade/OSF
Dear Mixilis,

I have also tried to connect my GT540 on my office Wlan but I face the same problem which I am facing at home. Btw I have sonicwall installed in my office.

Regards,


An another guy had problem with gt540 and linkys router. Have you tried a different wifi hotspot?


  • 0

#7
mixlis

mixlis

    Regular

  • Members
  • PipPip
  • 80 posts
  • Location:Hellas

Dear Mixilis,

I have also tried to connect my GT540 on my office Wlan but I face the same problem which I am facing at home. Btw I have sonicwall installed in my office.

Regards,

Hello,
Try a wpa+psk and 8digit password.Change channel to 11

  • 0

#8
Mr Dai

Mr Dai

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:GT540
  • Twitter:@OK
first, your phone must find the wifi signal, then
Please make sure that the phone setting meet the router setting, the address,gateway and netmask ,also the DNS.
If your router's Ip address not the default setting, you must setting your phone a suitable static IP,and so on the netmask DNS.

  • 0

#9
azeemfazal

azeemfazal

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:ZTE Blade/OSF
Dear Mr Dai,

I have tried my phone with all the possibilities like by assigning static IP address, by DHCP. My phone can view the wireless network can access the home page of my wireless router and modem too but unable to browse on internet. My phone only connect with the wireless router when I assigned IP statically otherwise on DHCP it stucks on obtaining address.


first, your phone must find the wifi signal, then
Please make sure that the phone setting meet the router setting, the address,gateway and netmask ,also the DNS.
If your router's Ip address not the default setting, you must setting your phone a suitable static IP,and so on the netmask DNS.


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users