Jump to content


Photo

T-Mobile G2 : Unlock phone with code and now no SIM card work


  • Please log in to reply
6 replies to this topic

#1
bluemoko

bluemoko

    Newbie

  • Members
  • Pip
  • 21 posts
  • Devices:Motorola DEXT
Hi, just to share my expereience and want some idea to enlight me.

I have T-Mobile G2 with a slightly loose hinge, from eBay. Then I punch a network unlock code BOOM the phone ask to reboot and once it reboot itself it can't connect to any network. It can detect SIM card fine, all SIM card can be detct. But none can be connect.

How would this situation happen? even it's own T-Mobile SIM card is not working at all

  • 0

#2
harolds5

harolds5

    Newbie

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Devices:Samsung Galaxy Nexus

Hi, just to share my expereience and want some idea to enlight me.

I have T-Mobile G2 with a slightly loose hinge, from eBay. Then I punch a network unlock code BOOM the phone ask to reboot and once it reboot itself it can't connect to any network. It can detect SIM card fine, all SIM card can be detct. But none can be connect.

How would this situation happen? even it's own T-Mobile SIM card is not working at all


Check your APN. Menu > Settings > Wireless & Networks > Mobile Networks > Access Point Names

  • 0

#3
bluemoko

bluemoko

    Newbie

  • Members
  • Pip
  • 21 posts
  • Devices:Motorola DEXT

Check your APN. Menu > Settings > Wireless & Networks > Mobile Networks > Access Point Names


It's not about data connection. It is the cell network. I can't make a phone call and going for automcatic search just came up error right away.
Anyway i will stop my thread here and move on to the G2 section >.<

Edited by bluemoko, 14 October 2010 - 10:34 PM.

  • 0

#4
tigasin ako

tigasin ako

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:htc desire z

It's not about data connection. It is the cell network. I can't make a phone call and going for automcatic search just came up error right away.
Anyway i will stop my thread here and move on to the G2 section >.<


I'm also experiencing this problem, if any can provide a solution about this.. i would really appreciate it.

  • 0

#5
kitchee

kitchee

    Newbie

  • Members
  • Pip
  • 1 posts

I'm also experiencing this problem, if any can provide a solution about this.. i would really appreciate it.


I encountered the same problem... I am still trying to find the solution from google...

  • 0

#6
mizifih

mizifih

    Newbie

  • Members
  • Pip
  • 1 posts
Same thing happened to me. I mean, to my phone. If I search for a network, I get a error message. Tried with T-Mobile SIM card (US), Claro SIM Card (Brazil), TIM SIM Card (Brazil) and BrasilTelecom SIM Card (Brazil). Nothing happens at all, the network signal meter shows a X over the bars, like if there's no signal, no network available.

I can't even register APNs on the phone, it rejects the new one after saving it. I mean, I enter all the data but when I come back to check there's no APN registered on the phone.

When I try to use that Wireless Call, a T-Mobile app, it says the SIM is invalid, so I guess that all SIMs are being rejected by the phone, all the SIMs are "invalid".

Hope you genius can help us out here. It's not nice to have a phone but use this nice piece of hardware as a *%&#*'n iPod Touch. That's just breaking my heart (also my pocket's heart)

  • 0

#7
wvn

wvn

    Newbie

  • Members
  • Pip
  • 20 posts
  • Devices:HTC Desire / Blackberry 9700
Similar problem:

I have a sim-lock free Desire Z (not unlocked by me, but bought simlock free out of the box).

Every now and then, it will lose signal. I will get the "emergency calls only" message in the notification bar.
Sometimes a restart helps. sometimes it doesnt.

Seems a firmware bug thing to me.



Same thing happened to me. I mean, to my phone. If I search for a network, I get a error message. Tried with T-Mobile SIM card (US), Claro SIM Card (Brazil), TIM SIM Card (Brazil) and BrasilTelecom SIM Card (Brazil). Nothing happens at all, the network signal meter shows a X over the bars, like if there's no signal, no network available.

I can't even register APNs on the phone, it rejects the new one after saving it. I mean, I enter all the data but when I come back to check there's no APN registered on the phone.

When I try to use that Wireless Call, a T-Mobile app, it says the SIM is invalid, so I guess that all SIMs are being rejected by the phone, all the SIMs are "invalid".

Hope you genius can help us out here. It's not nice to have a phone but use this nice piece of hardware as a *%&#*'n iPod Touch. That's just breaking my heart (also my pocket's heart)


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users