Jump to content


Photo

Nexus One 2.2.1 will not Boot

- - - - -

  • Please log in to reply
1 reply to this topic

#1
Papa_I

Papa_I

    Newbie

  • Members
  • Pip
  • 14 posts
I recently receive my Nexus One back from HTC to fix the power button. Since I received the phone back, I rooted using Super-One-Click , and installed Rom Manager to restore my phone to the rom I was using before I sent my phone away. Everything worked as expected, and my phone was fully restored. I tried to install Trackball wake and unlock from (http://forum.xda-dev....ight=trackball) and this is where my problems started. I used Root Manager to install the android.policy.jar and updated the permissions. I rebooted my phone and the phone will not get passed the “X” boot screen. I booted my phone into Bootloader mode (Power + Volume Down) and was going to push a new android.policy.jar file through ADB, but I could not connect to the phone through ADB. I do not believe I ever turned Debugging Mode on while the phone was working properly. I booted my phone into recovery and was going to restore my phone through clockwork recovery only to find out my phone did not have clockwork recovery flashed, but instead it had the stock recovery loaded. I than tried to restore my phone back to a stock image through loading a signed update.zip but that did not work. I than tried to downgrade using the PASSIMG.img method found here (http://forum.xda-dev....ore_your_Nexus), but my phone currently has hboot-0.35.0017 and will not accept the PASSIMG.img. When I try to load the PASSIMG.img I get an error stating “Main version is older!”. I for some reason cannot get adb to recognize my phone, so I don’t think I can downgrade my hboot. I have been able to get fastboot to recognize my phone, but for some reason the phone will not let my flash any files via fastboot. I would really like to find a way to restore my phone to a stock image so I can start the process over from scratch. I really would like to keep my bootloader locked if at all possible as the phone is still under warranty. Any assistance anyone could provide would be greatly appreciated. Please let me know if I left out any information that would usefully in fixing my problem. Thanks!

HBoot-0.35.0017
Bootloader-Locked
Current Rom Version-2.2.1 (this rom should be rooted)
Recovery Image: Stock

  • 0

#2
stevenz

stevenz

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 473 posts
  • Gender:Male
  • Location:Wellington, New Zealand
  • Interests:Motorcycling
    Tinkering
  • Devices:OG Tab, Note, Touchpad, N7
  • Twitter:@KnightNZ

HBoot-0.35.0017
Bootloader-Locked
Current Rom Version-2.2.1 (this rom should be rooted)
Recovery Image: Stock


Use paragraphs dude. Also, ROM Manager is a flaky, dangerous program in my opinion.

Make life easier for yourself, unlock the bootloader.

I'm running HBOOT 0.35.0017 and don't have any issues flashing recoveries, radios etc. ADB won't recognise the phone of it's in fastboot mode, if "fastboot flash recovery recovery.img" doesn't work, with a known valid recovery image (pref Amon Ra, not ClockWork). If the bootloader is unlocked (S=OFF in Fastboot) then you should be able to flash this, unless the memory is corrupted in which case there might not be much you can do.

In theory, as long as you can still get into Fastboot, and the bootloader is already unlocked, then you should be able to recover it unless the memory is damaged.

If the bootloader ISN'T unlocked, then you can try to unlock it with the "fastboot oem unlock" command, unless you really don't want to unlock it in which case you'll need to flash an OEM firmware and start from scratch with a re-root and flash a recovery via shell. Flashing non-OEM will fail.

OEM firmware on this forum via: http://android.modac...-root-insecure/

You might even want to try reinstalling the N1 USB drivers just in case.


Possibly useful tutorial: http://forum.xda-dev...ad.php?t=710842

Edited by stevenz, 01 March 2011 - 04:28 AM.

  • 0
Motorcycling watchmaker.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users