Jump to content


Photo

Correlation between loss of GSM when WIFI active?

- - - - -

  • Please log in to reply
7 replies to this topic

#1
TheChill

TheChill

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:West Yorkshire, England
  • Interests:Spores, moulds and fungus.
  • Devices:San Francisco
  • Twitter:@izzy_the_bob
The issue with a loss of GSM signal when WIFI is enabled seems to be a common complaint these days
and, to be honest, it has been bugging me recently, but I've not had the time to sit down and dig deeper
into the issue. However, I did manage to snag a crucial few seconds to glance over the Mobile Network
Settings on my (r8a) FBL install earlier, and noticed in GSM/UMTS Options that (by default?) "Use only
2G networks" was enabled.

I was prompted to explore these settings because, at that time, I had lost the GSM signal in a region of
the house that usually afforded me one bar. Anyway, not wanting to tie myself down to 2G networks
only, I disabled the option and almost immediately two things happened: my WIFI signal improved by
a notch and the GSM signal was re-attained at two bars (one bar above what the location typically
allows).

Repeating the experiment (enabling "Use only 2G networks") I find that the GSM signal is prone to being
lost (lost immediately in some cases), but re-appearing (even stronger) when "Use only 2G networks" is
disabled.

Can anyone else confirm this rather interesting phenomenon?


EDIT: I've noticed a couple of times that after re-enabling "Use only 2G networks" the signal has displayed
the 'R' roaming icon, even though roaming is disabled. It survives a reboot. Only by reconnecting to my
chosen network (3 mobile) is it removed (GSM/UMTS Options, Network operators).

EDIT: Upon disabling "Use only 2G networks" I've had no GSM disconnects in otherwise dodgy locations
in over 20 minutes, whereas it was otherwise a certainty.

Edited by TheChill, 13 February 2011 - 09:54 PM.

  • 0

#2
smudgeroo

smudgeroo

    Newbie

  • MoDaCo Silver
  • Pip
  • 15 posts
Bizarrely, yes, I get the same thing...

  • 0

#3
TheChill

TheChill

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:West Yorkshire, England
  • Interests:Spores, moulds and fungus.
  • Devices:San Francisco
  • Twitter:@izzy_the_bob

Bizarrely, yes, I get the same thing...


Including improved signal strengths on WIFI and GSM?

When you installed the ROM, was it from a clean, wiped system, or over the top of an existing installation?

  • 0

#4
Fi5h

Fi5h

    Regular

  • Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Devices:ZTE Blade
I'm using the same rom and have to use 2G cos 3G is so crap inside my house (orange)

I get loads better signal on 2G and have no issues switching between 2G and wifi, and back.

At home I have the 'use only 2G networks' on as if I leave the setting on auto it switches me between 2G and 3G as I move round the house and causes havoc with messages and calls.

  • 0
giffgaff San Francisco (OLED)
Samsung 8GB CL6 SD
Recovery: ClockworkMod 4.0.1.4
System: CM7

Posted Image

#5
rutteger

rutteger

    Newbie

  • Members
  • Pip
  • 25 posts
  • Devices:ZTE Blade
I also note loss of mobile network when wifi is switched on sometimes, using FLB 8a. Seems to ocur on 2G and 3G.

One thing I did note was that the phone still has mobile signal, when looking in Settings>About>Status I noted the following

Netowrk : Unknown
Signal : 97dmb 8asu (which is quite ok)
Mobile : HSPDA
Service : out of service

To reconnect to my mobile provider I can either wait a few minutes, select it through the wireless and networks menu or toggle wifi off-on.

  • 0

#6
Davie1888

Davie1888

    Regular

  • Members
  • PipPip
  • 120 posts

I also note loss of mobile network when wifi is switched on sometimes, using FLB 8a. Seems to ocur on 2G and 3G.

One thing I did note was that the phone still has mobile signal, when looking in Settings>About>Status I noted the following

Netowrk : Unknown
Signal : 97dmb 8asu (which is quite ok)
Mobile : HSPDA
Service : out of service

To reconnect to my mobile provider I can either wait a few minutes, select it through the wireless and networks menu or toggle wifi off-on.


I get a similar result with WiFi on

Service State : In Service
Mobile Network State : Disconnected

  • 0
<a href="http://giffgaff.com/...iate/davie1888" target="_blank"><img src="http://giffgaff.com/.../07_468x60.png" width="468" height="60" alt="Get a free Giffgaff Sim" /></a>

#7
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,657 posts
Theres an app I've been using to check the mobile signal strength called Real Signal. https://market.andro...yu73.realsignal
I installed it to help with diagnosing any issues that could be causing loss of signal on the phones. Hasn't helped yet but it certainly shows, to me, that the stock signal notification bars are showing the wrong signal strength but it's cosmetic.

  • 0

#8
smudgeroo

smudgeroo

    Newbie

  • MoDaCo Silver
  • Pip
  • 15 posts

Including improved signal strengths on WIFI and GSM?

When you installed the ROM, was it from a clean, wiped system, or over the top of an existing installation?


Clean and wiped, including system. Everything still works, so life is good!

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users