Jump to content


Photo

GPS issue - fr15

- - - - -

  • Please log in to reply
46 replies to this topic

#1
netz

netz

    Regular

  • MoDaCo Silver
  • PipPip
  • 57 posts
  • Gender:Female
  • Location:Canada
  • Devices:LG Optimus 2X > Galaxy Nexus
i flashed to fr15 a couple weeks ago, love it! its very fast! (thank you paul again!)

but i went out of town yesterday and needed gps, it kept telling me 'Your current location is temporarily unavailable' ( i've tried 20times atleast)
when i finally got back in town this morning, tried gps again, it still tells me 'Your current location is temporarily unavailable'

its not the location or the signal, because my friend has an iphone and he was using google maps right beside me, working perfectly well.

and i know the GPS on my phone was working when i was on fr13

can anyone help me plss!!

ps. my location is in canada!

thanks!!

  • 0

#2
RotoTrol_P990

RotoTrol_P990

    Newbie

  • Members
  • Pip
  • 15 posts
  • Devices:LG P990
I had the same issue in FR15 and wiping dalvik cache seems to have fixed it. Google Maps was still acting up a little, though. With stock ROM I can confirm the issue is not present, so there must be something broken somewhere.

  • 0

#3
Squide

Squide

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 235 posts
  • Devices:N/A
  • Twitter:@N/A
I experienced the same thing yesterday...
I need to stand still for around 5-10mins to get the GPS fixed its position.....

There's no buildings or hills around me... an open ground and a sunny day without clouds at all.

  • 0

#4
MillyMoo

MillyMoo

    Newbie

  • Members
  • Pip
  • 14 posts
  • Devices:LG Optimus 2x
Mine seems to be broken too in FR15, FasterFix didn't make a difference

  • 0

#5
conceptics

conceptics

    Newbie

  • Members
  • Pip
  • 20 posts
  • Devices:LG P990

Mine seems to be broken too in FR15, FasterFix didn't make a difference


I can conform this too. GPS worked excellent in FR10, FR11 and FR12. Since FR15, it doesn't (test at the same location).

It would be great if Paul could comment, since something must have changed between FR12/FR13 and FR15 and it would be great to know how to revert it ourself (if possible) or at least to know that there is a fix on the way.

  • 0

#6
conceptics

conceptics

    Newbie

  • Members
  • Pip
  • 20 posts
  • Devices:LG P990
This is strange - I'm not sure if I solved it myself using LG's hiddenmenu and changing some configs around or if indeed it seems to work better now. Could anyone else test this again who had problems initially and is on FR15?

  • 0

#7
Boergen

Boergen

    Newbie

  • Members
  • Pip
  • 20 posts
  • Location:Germany
  • Devices:LG P990 2X

This is strange - I'm not sure if I solved it myself using LG's hiddenmenu and changing some configs around or if indeed it seems to work better now. Could anyone else test this again who had problems initially and is on FR15?


If you could be a little more specific about the "changing some configs around"... :unsure:

  • 0

#8
conceptics

conceptics

    Newbie

  • Members
  • Pip
  • 20 posts
  • Devices:LG P990

If you could be a little more specific about the "changing some configs around"... :unsure:


Of course, sorry - just wanted to make sure I retract what I did correctly so that the settings I have fiddled around to make it work actually do work and not cause any other problems.

What made me fiddle around with some of the options were this link that was posted in the FR15 kitchen topic, about the expired SSL certificate of supl.google.com:
http://www.google.co...s...9ae5d&hl=en

To get it to work as flawless as before upgrading to FR15, I have made the following adjustments that seem to work well:

1. Go into the LG hidden menu
2. Go into GPS Test
3. Go into System Settings
4. MOLR Protocol (is set to User-Plane)
5. SULP Setting -> SLP Server Setting, I created a new one for the nokia servers (slp address: supl.nokia.com, port: 7275, no cert and no TLS setting)
6. SLP Auto Provision is activated

I'm in Switzerland and with this settings (supl.nokia.com), the GPS fix is relatively quick and works consistently within about 10 seconds of starting Google-Maps.

Still not sure if this is indeed FR15 related or if the problem is purely SSL Certificate related. If it is SSL Certificate related wouldn't the problem be much more widespread and wouldn't google already have updated the certificate by now?

Anyway, hope the above works at least as a temporary workaround.

  • 0

#9
Boergen

Boergen

    Newbie

  • Members
  • Pip
  • 20 posts
  • Location:Germany
  • Devices:LG P990 2X

1. Go into the LG hidden menu
2. Go into GPS Test
3. Go into System Settings
4. MOLR Protocol (is set to User-Plane)
5. SULP Setting -> SLP Server Setting, I created a new one for the nokia servers (slp address: supl.nokia.com, port: 7275, no cert and no TLS setting)
6. SLP Auto Provision is activated


Woah.. that works like a charm. :unsure: Many thanks!

Just to be on the safe side, I edited the gps.conf as well and exchanged the Google server with the Nokia one, port 7275.

  • 0

#10
MillyMoo

MillyMoo

    Newbie

  • Members
  • Pip
  • 14 posts
  • Devices:LG Optimus 2x
conceptics that worked perfectly! thank u

  • 0

#11
toti1001

toti1001

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:HTC Legend
Many thanks to conceptics !!!!! This tweak was the only one, that works perfectly with my LG. Ive tested many other things (Fasterfix,modify gps.conf etc.) but this tweak runs top!!
Ive just wait min. 1 min. for a fix, sometimes longer and only 3-4 Sats are locked. With your tweak, i got a Fix after max. 15sec. with min 6 Sats.

  • 0

#12
lozza69er

lozza69er

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Optimus 2X
Cheers, this fix works a treat. At last proper working gps. Thanks.

  • 0

#13
qhyqhy

qhyqhy

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:LG Optimus 2X
how go into the hidden menu?

edit: found

Example using LauncherPro (others will use a similar method):
Long press on home screen
Select Shortcuts
Select Activities
Scroll down to and expand com.lge.hiddenmenu
Select HiddenMenu (first entry)
Enter Shortcut name
Click on shortcut to launch

Edited by qhyqhy, 14 May 2011 - 09:43 AM.

  • 0

#14
75markus

75markus

    Regular

  • Members
  • PipPip
  • 123 posts
  • Devices:LG Optimus 2X

how go into the hidden menu?

edit: found

Example using LauncherPro (others will use a similar method):
Long press on home screen
Select Shortcuts
Select Activities
Scroll down to and expand com.lge.hiddenmenu
Select HiddenMenu (first entry)
Enter Shortcut name
Click on shortcut to launch



...or type in dialer :


1809#*990# (hidden menu)

  • 0

#15
Squide

Squide

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 235 posts
  • Devices:N/A
  • Twitter:@N/A

...or type in dialer :
1809#*990# (hidden menu)


drag ur finger from the place between back and search key
move up into the touch screen will launch the hidden menu.

no shortcut needed.

  • 0

#16
netz

netz

    Regular

  • MoDaCo Silver
  • PipPip
  • 57 posts
  • Gender:Female
  • Location:Canada
  • Devices:LG Optimus 2X > Galaxy Nexus

Of course, sorry - just wanted to make sure I retract what I did correctly so that the settings I have fiddled around to make it work actually do work and not cause any other problems.

What made me fiddle around with some of the options were this link that was posted in the FR15 kitchen topic, about the expired SSL certificate of supl.google.com:
http://www.google.co...s...9ae5d&hl=en

To get it to work as flawless as before upgrading to FR15, I have made the following adjustments that seem to work well:

1. Go into the LG hidden menu
2. Go into GPS Test
3. Go into System Settings
4. MOLR Protocol (is set to User-Plane)
5. SULP Setting -> SLP Server Setting, I created a new one for the nokia servers (slp address: supl.nokia.com, port: 7275, no cert and no TLS setting)
6. SLP Auto Provision is activated

I'm in Switzerland and with this settings (supl.nokia.com), the GPS fix is relatively quick and works consistently within about 10 seconds of starting Google-Maps.

Still not sure if this is indeed FR15 related or if the problem is purely SSL Certificate related. If it is SSL Certificate related wouldn't the problem be much more widespread and wouldn't google already have updated the certificate by now?

Anyway, hope the above works at least as a temporary workaround.



how should my nokia server setting be if i am in canada?

thanks!

  • 0

#17
qhyqhy

qhyqhy

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:LG Optimus 2X

...or type in dialer :
1809#*990# (hidden menu)



not working. I have to phone?

when I phone to this number: IHM problem.... Only ma method work on my phone

  • 0

#18
Boergen

Boergen

    Newbie

  • Members
  • Pip
  • 20 posts
  • Location:Germany
  • Devices:LG P990 2X

how should my nokia server setting be if i am in canada?

thanks!

Just use the same settings. There isn't any setting in the GPS HiddenMenu that is based on which country you're in.

  • 0

#19
orion1602

orion1602

    Newbie

  • MoDaCo Silver
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Paris
  • Devices:

Of course, sorry - just wanted to make sure I retract what I did correctly so that the settings I have fiddled around to make it work actually do work and not cause any other problems.

What made me fiddle around with some of the options were this link that was posted in the FR15 kitchen topic, about the expired SSL certificate of supl.google.com:
http://www.google.co...s...9ae5d&hl=en

To get it to work as flawless as before upgrading to FR15, I have made the following adjustments that seem to work well:

1. Go into the LG hidden menu
2. Go into GPS Test
3. Go into System Settings
4. MOLR Protocol (is set to User-Plane)
5. SULP Setting -> SLP Server Setting, I created a new one for the nokia servers (slp address: supl.nokia.com, port: 7275, no cert and no TLS setting)
6. SLP Auto Provision is activated

I'm in Switzerland and with this settings (supl.nokia.com), the GPS fix is relatively quick and works consistently within about 10 seconds of starting Google-Maps.

Still not sure if this is indeed FR15 related or if the problem is purely SSL Certificate related. If it is SSL Certificate related wouldn't the problem be much more widespread and wouldn't google already have updated the certificate by now?

Anyway, hope the above works at least as a temporary workaround.



Wow! thank you so much! my gps was perfect in rom stock and fr12, but since fr 15 it doesn't work. No matter if i changed the gps.conf to a server in FR. But now with nokia's server it's ok, and i get a fix in less then 10s from the windows. And accuracy is ok too.

  • 0

#20
Boergen

Boergen

    Newbie

  • Members
  • Pip
  • 20 posts
  • Location:Germany
  • Devices:LG P990 2X
Paul, is it possible to use the Nokia SUPL server as default in future ROMs?

A few ROMs back you added the /system/etc/gps.conf... but that file is obsolete if a working SUPL server is set in the HiddenMenu.

Edited by Boergen, 15 May 2011 - 10:30 AM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users