Jump to content


Photo

[ROM MOD][Gen2] Simple Stir Fry (Updated 01/10) - b27

* * * * * 26 votes

  • Please log in to reply
138 replies to this topic

#21
KuNgZi

KuNgZi

    Newbie

  • Members
  • Pip
  • 9 posts
gingerbread official lockscreen? half circle

  • -2

#22
wbaw

wbaw

    account closed

  • Banned
  • PipPipPipPipPipPip
  • 1,885 posts
  • Gender:Not Telling

Wow you rule. Thanks again. Although I may have to still wait for B19 because of those alleged proximity sensor issues everyone seems to be having.


I think it's just in bright ambient light, it conflicts with the light sensor somehow, I stay in my dark cave so it never affects me. I might see if the cm7 proximity libs work, that's about all I could do to try to fix it I think.

@KuNgZi that's CM7. This & also the stir fry rom that it was based on (so not sure how it was 'added') have the boring official slider one.

Also, LiveWallpapersPicker.apk wasn't added by me, it's a standard part of Android, without it you wont be able to use any live wallpapers. You must've saved about 100kb by removing all those apps :rolleyes: . ZTE dialler breaks sip calling.

And most of the graphic errors were in fact caused by zte & their (not really) 9patch png files, decompile & recompile the stock framework using apktool & it gives lots of graphic errors, like the grey lockscreen sliders. I fixed them by removing the '.9', but that causes more (smaller) graphic problems.

You left visualzation wappers & livewalpapers.apk & removed livewallpaperspicker.apk?? how does that work?

Edited by wbaw, 01 August 2011 - 07:34 PM.

  • 0

#23
Matthew Ferguson

Matthew Ferguson

    Enthusiast

  • Members
  • PipPipPip
  • 298 posts
  • Gender:Male
  • Location:London
  • Devices:Orange San Francisco/ZTE Blade

I think it's just in bright ambient light, it conflicts with the light sensor somehow, I stay in my dark cave so it never affects me. I might see if the cm7 proximity libs work, that's about all I could do to try to fix it I think.

@KuNgZi that's CM7. This & also the stir fry rom that it was based on (so not sure how it was 'added') have the boring official slider one.

Also, LiveWallpapersPicker.apk wasn't added by me, it's a standard part of Android, without it you wont be able to use any live wallpapers. You must've saved about 100kb by removing all those apps :rolleyes: . ZTE dialler breaks sip calling.

And most of the graphic errors were in fact caused by zte & their (not really) 9patch png files, decompile & recompile the stock framework using apktool & it gives lots of graphic errors, like the grey lockscreen sliders. I fixed them by removing the '.9', but that causes more (smaller) graphic problems.

You left visualzation wappers & livewalpapers.apk & removed livewallpaperspicker.apk?? how does that work?


Sorry, the live wallpapers thing was my mistake, I'm new to this whole ROM thing. As for the graphical bugs, I've been using this modified version of your ROM since b4, and I haven't noticed any issues. As for the ZTE Dialler issue, the Lite version of my ROM MOD doesn't have this present, for those who use SIP calling. I'm not overly concerned about the space saving, really, I'm more concerned with reverting to stock :)

  • 0
Orange San Francisco Black OLED Gen2
SanDisk 16GB Class 2 SD
Recovery: ClockworkMod 4.0.1.5
System: Simple Stir Fry Full b27

#24
wbaw

wbaw

    account closed

  • Banned
  • PipPipPipPipPipPip
  • 1,885 posts
  • Gender:Not Telling
well, the stock was a bit crap, but i suppose it's personal tastes. I fixed most of the graphics bugs. If you're just using the stock framework then the graphic bugs don't show up until you try decompiling & recompiling it or putting it through uot kitchen. The lockscreen sliders are a pain.

Edited by wbaw, 01 August 2011 - 07:47 PM.

  • 0

#25
Matthew Ferguson

Matthew Ferguson

    Enthusiast

  • Members
  • PipPipPip
  • 298 posts
  • Gender:Male
  • Location:London
  • Devices:Orange San Francisco/ZTE Blade

well, the stock was a bit crap, but i suppose it's personal tastes. I fixed most of the graphics bugs. If you're just using the stock framework then the graphic bugs don't show up until you try decompiling & recompiling it or putting it through uot kitchen. The lockscreen sliders are a pain.


Fair enough, but I greatly prefer them to the Froyo versions present in b18 :)



  • 0
Orange San Francisco Black OLED Gen2
SanDisk 16GB Class 2 SD
Recovery: ClockworkMod 4.0.1.5
System: Simple Stir Fry Full b27

#26
wbaw

wbaw

    account closed

  • Banned
  • PipPipPipPipPipPip
  • 1,885 posts
  • Gender:Not Telling

Fair enough, but I greatly prefer them to the Froyo versions present in b18 :)


That was b16 i think, they are stock gingerbread in B17 & B18, just a little misshaped at the end & the text colour changed to black. I prefer the Froyo ones myself, but I couldn't get the text to line up right, similar 9patch png problems, maybe taking them from another phone would work, but it doesn't bother me enough to change it.

There are a few options in framework that it's worth decompiling to set, also a load of useless mdpi graphics which can be removed, but just decompiling & recompiling breaks a bunch of graphics, need to remove the '.9' from the file name then recompile again & keep fingers crossed that it doesn't really need to be 9patch to fix it. It can easily get messy. Problem is that if you use the framework from b18 unmodified you'll get the transparent white background/black text notifications rather than the stock version, although the rest of the notification settings are in SystemUI.apk

  • 0

#27
Hellberg

Hellberg

    Newbie

  • Members
  • Pip
  • 2 posts
I just started using this rom yesterday and I love it! Big thanks to wbaw for the main rom and Matthew for making this version! It's clean, fast, seems very stable and battery life seems to be great aswell.

I flashed the full version of Simple Stir Fry, but now I realized that I probably wanted the stock android dialer and not the ZTE version. The ZTE version is nice though, but I'm using the SIP calling feature of gingerbread and since this seems to work better with the stock android dialer, I guess I should have picked the lite version of SSF (I like the colored settings menu though).

Is there any way to restore the stock android dialer without having to reflash with the lite version?

  • 0

#28
Matthew Ferguson

Matthew Ferguson

    Enthusiast

  • Members
  • PipPipPip
  • 298 posts
  • Gender:Male
  • Location:London
  • Devices:Orange San Francisco/ZTE Blade

I just started using this rom yesterday and I love it! Big thanks to wbaw for the main rom and Matthew for making this version! It's clean, fast, seems very stable and battery life seems to be great aswell.

I flashed the full version of Simple Stir Fry, but now I realized that I probably wanted the stock android dialer and not the ZTE version. The ZTE version is nice though, but I'm using the SIP calling feature of gingerbread and since this seems to work better with the stock android dialer, I guess I should have picked the lite version of SSF (I like the colored settings menu though).

Is there any way to restore the stock android dialer without having to reflash with the lite version?



I think there might be, check in the Gingerbread Goodies thread for a patch to flash the CM7 dialler? That might work

Wbaw - Odd, as I've recompiled the framework on this, to remove the CRT animation (as it's the framework from b9) unless we're talking about a different thing here?


  • 0
Orange San Francisco Black OLED Gen2
SanDisk 16GB Class 2 SD
Recovery: ClockworkMod 4.0.1.5
System: Simple Stir Fry Full b27

#29
Hellberg

Hellberg

    Newbie

  • Members
  • Pip
  • 2 posts

I think there might be, check in the Gingerbread Goodies thread for a patch to flash the CM7 dialler? That might work


Thanks! Tried that and it seems to work perfectly! :)

  • 0

#30
wbaw

wbaw

    account closed

  • Banned
  • PipPipPipPipPipPip
  • 1,885 posts
  • Gender:Not Telling

I think there might be, check in the Gingerbread Goodies thread for a patch to flash the CM7 dialler? That might work

Wbaw - Odd, as I've recompiled the framework on this, to remove the CRT animation (as it's the framework from b9) unless we're talking about a different thing here?


Maybe it's my version of apktool that's broken then? UOT kitchen does the same thing too. Are your lockscreen sliders light grey when pressed? or did you use one from after I fixed it (i'd probably fixed it before b9)? There was also a problem with the tabs in applications (like contacts), white line under the deselected tabs rather than grey, that was fixed later than the lockscreen, not sure if it was fixed in b9, i think i fixed that around the same time as I fixed the notifications to be readable on the transparent background. tab_selected_bar*.png were the files affected by that, just need to replace those files with ones from a working version, remove the '.9' from the file name & recompile, if it's a problem. There could still be a few minor graphics errors hiding, there are about 200 of those 9patch png files, I'm not sure if any others are broken - can't just replace them all because some of them need to be 9patch pngs.

If its got jog_tab_bar_left_end_normal.png rather than jog_tab_bar_left_end_normal.9.png then it's one that I fixed so that it can be decompiled & recompiled without causing the lockscreen bug.

I thought you were using the stock unmodified framework, I didn't change it for the first few betas, I think I'd fixed the lock screen thing by b9.

I think the only things that are visually different between the current framework & stock are the text colour on the lock screen sliders & the notifications.

I also changed these values in framework bools.xml , not sure which beta, but they affect animations...

<bool name="config_sf_limitedAlpha">true</bool>
<bool name="config_sf_slowBlur">true</bool>

They should both be true, imo, it seems to be a bit smoother after I changed those.

Edited by wbaw, 02 August 2011 - 12:54 PM.

  • 0

#31
Matthew Ferguson

Matthew Ferguson

    Enthusiast

  • Members
  • PipPipPip
  • 298 posts
  • Gender:Male
  • Location:London
  • Devices:Orange San Francisco/ZTE Blade

Maybe it's my version of apktool that's broken then? UOT kitchen does the same thing too. Are your lockscreen sliders light grey when pressed? or did you use one from after I fixed it (i'd probably fixed it before b9)? There was also a problem with the tabs in applications (like contacts), white line under the deselected tabs rather than grey, that was fixed later than the lockscreen, not sure if it was fixed in b9, i think i fixed that around the same time as I fixed the notifications to be readable on the transparent background. tab_selected_bar*.png were the files affected by that, just need to replace those files with ones from a working version, remove the '.9' from the file name & recompile, if it's a problem. There could still be a few minor graphics errors hiding, there are about 200 of those 9patch png files, I'm not sure if any others are broken - can't just replace them all because some of them need to be 9patch pngs.

If its got jog_tab_bar_left_end_normal.png rather than jog_tab_bar_left_end_normal.9.png then it's one that I fixed so that it can be decompiled & recompiled without causing the lockscreen bug.

I thought you were using the stock unmodified framework, I didn't change it for the first few betas, I think I'd fixed the lock screen thing by b9.

I think the only things that are visually different between the current framework & stock are the text colour on the lock screen sliders & the notifications.

I also changed these values in framework bools.xml , not sure which beta, but they affect animations...

<bool name="config_sf_limitedAlpha">true</bool>
<bool name="config_sf_slowBlur">true</bool>

They should both be true, imo, it seems to be a bit smoother after I changed those.



Hmm, well that's definitely the framework from b9 I'm using, and it has no lockscreen bugs, and the issue you mentioned with applications isn't there, either. I'm using a completely stock SystemUI (I think) so maybe that partially causes the problem? I'll take a look at the bools.xml when I get the chance. Obviously I've never used UOT as I prefer the stock look :P




  • 0
Orange San Francisco Black OLED Gen2
SanDisk 16GB Class 2 SD
Recovery: ClockworkMod 4.0.1.5
System: Simple Stir Fry Full b27

#32
Oyorf

Oyorf

    Regular

  • Members
  • PipPip
  • 62 posts
I would like to have lite version but with colorful settings. Or full version with stock dialler. Can some one make this? Or which one is easier to make by myself and how?

Can I just copy dialler from lite version to full verison zip and then install that? Or can I just copy some color file from full version zip to lite version zip?

  • 0

#33
Matthew Ferguson

Matthew Ferguson

    Enthusiast

  • Members
  • PipPipPip
  • 298 posts
  • Gender:Male
  • Location:London
  • Devices:Orange San Francisco/ZTE Blade

I would like to have lite version but with colorful settings. Or full version with stock dialler. Can some one make this? Or which one is easier to make by myself and how?

Can I just copy dialler from lite version to full verison zip and then install that? Or can I just copy some color file from full version zip to lite version zip?


Copy Settings.apk from system/app to the lite version :) Overwrite the existing version.



  • 0
Orange San Francisco Black OLED Gen2
SanDisk 16GB Class 2 SD
Recovery: ClockworkMod 4.0.1.5
System: Simple Stir Fry Full b27

#34
azentner

azentner

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:ZTE Blade
Thanks Matthew for this great ROM!

(thanks to wbaw and all the forefathers too.... wouldn't like to offend anyone ;-))

I've been using it for a couple of days now.
This ROM is simple, clean and fast. Exactly what I was looking for.


p.s. I got help from a dude at another forum to add support for the Hebrew language, both keyboard and proper right to left support (he patched some of the libraries for me). If anyone else is interested in these fixes, I'm happy to share my ROM.

  • 1

#35
aNtArCt

aNtArCt

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:ZTE Blade
Hi, I know there's 'no wipe, no whine policy' but I've got a question.

Had any of you have problem with wi-fi? I cannot enable it on Simple Stir Fry (b18), it does automatically disable after 2 secs, and in this time doesn't see any network...

Now my sin (way of installation):

Before SSF i was using CM7 149, then:

- in recovery I've formatted /boot, /cache and /system
- installed SSF, reboot
- many force closes (most from Facebook and Music)
-reboot
- less FCs:) (reinstallation of Facebook and changing folder name from Music to something random and back fixed problems)
- reboot
- no ringtones
- reboot
- ringtones back:)

And then everything seemed to be working, with all my apps, data and settings from CM7. It was so beautiful.

Then I went back home and tried to connect via wifi...

Any ideas?

Edited by aNtArCt, 04 August 2011 - 11:33 AM.

  • 0

#36
Matthew Ferguson

Matthew Ferguson

    Enthusiast

  • Members
  • PipPipPip
  • 298 posts
  • Gender:Male
  • Location:London
  • Devices:Orange San Francisco/ZTE Blade

Hi, I know there's 'no whipe, no whine policy' but I've got a question.

Had any of you have problem with wi-fi? I cannot enable it on Simple Stir Fry (b18), it does automatically disable after 2 secs, and in this time doesn't see any network...

Now my sin (way of installation):

Before SSF i was using CM7 149, then:

- in recovery I've formatted /boot, /cache and /system
- installed SSF, reboot
- many force closes (most from Facebook and Music)
-reboot
- less FCs:) (reinstallation of Facebook and changing folder name from Music to something random and back fixed problems)
- reboot
- no ringtones
- reboot

And then everything seemed to be working, with all my apps, data and settings from CM7. It was so beautiful.

Then I went back home and tried to connect via wifi...

Any ideas?


Yes, I really should add this to my main page, as it's listed on the Ginger Stir Fry page - NO WHIPE, NO WHINE


CM7 is built on a different kernel and a different base - you're lucky you got the phone to boot, let alone have any apps work. Wipe data and do a factory reset, and reinstall the ROM. That will fix your issues.



  • 0
Orange San Francisco Black OLED Gen2
SanDisk 16GB Class 2 SD
Recovery: ClockworkMod 4.0.1.5
System: Simple Stir Fry Full b27

#37
aNtArCt

aNtArCt

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:ZTE Blade

Yes, I really should add this to my main page, as it's listed on the Ginger Stir Fry page - NO WHIPE, NO WHINE


CM7 is built on a different kernel and a different base - you're lucky you got the phone to boot, let alone have any apps work. Wipe data and do a factory reset, and reinstall the ROM. That will fix your issues.




But there's only one issue: no wifi connection. Except this one everything is working as it should (tested for about 6hours), so I still have a little hope that this can be fixed.
Isn't there any posibility to somehow 'reinstall' wifi driver or any system file connected with this?
If it was possible then (I think) many people would start using yours SSF, factory reset when you have apps and data collected in months is simply not an option:(

Edited by aNtArCt, 04 August 2011 - 11:33 AM.

  • -1

#38
ThrashMan

ThrashMan

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 464 posts
  • Gender:Male
  • Location:Miserable old git!
  • Devices:ZTE Blade [UK 512MB TFT]
As well as formatting /boot, /cache & /system you ought to go into advanced and wipe dalvic cache & battery stats too.

Hi, I know there's 'no wipe, no whine policy' but I've got a question.

Had any of you have problem with wi-fi? I cannot enable it on Simple Stir Fry (b18), it does automatically disable after 2 secs, and in this time doesn't see any network...

Now my sin (way of installation):

Before SSF i was using CM7 149, then:

- in recovery I've formatted /boot, /cache and /system
- installed SSF, reboot
- many force closes (most from Facebook and Music)
-reboot
- less FCs:) (reinstallation of Facebook and changing folder name from Music to something random and back fixed problems)
- reboot
- no ringtones
- reboot
- ringtones back:)

And then everything seemed to be working, with all my apps, data and settings from CM7. It was so beautiful.

Then I went back home and tried to connect via wifi...

Any ideas?


  • 0

#39
aNtArCt

aNtArCt

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:ZTE Blade

As well as formatting /boot, /cache & /system you ought to go into advanced and wipe dalvic cache & battery stats too.


I also did this steps.

  • 0

#40
Matthew Ferguson

Matthew Ferguson

    Enthusiast

  • Members
  • PipPipPip
  • 298 posts
  • Gender:Male
  • Location:London
  • Devices:Orange San Francisco/ZTE Blade

I also did this steps.


When switching ROMs, wiping Data is pretty much a given, as it causes issues like this. Since you can't switch from CM7 to any other ROM, I'm not too bothered. The only way you're likely to get Wifi back is by wiping.

  • 0
Orange San Francisco Black OLED Gen2
SanDisk 16GB Class 2 SD
Recovery: ClockworkMod 4.0.1.5
System: Simple Stir Fry Full b27




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users