Jump to content


Photo

09 Aug: Superboot - root access for the ZTE Skate

- - - - -

  • Please log in to reply
292 replies to this topic

#1
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,369 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Introducing.... Superboot - root access for your ZTE Skate / Orange Monte Carlo! :)

Superboot is a boot.img that when flashed, will root your device the first time you boot (installing su and the superuser APK). No need to flash the system partition, no messing with the contents of your data partition, no overwriting the shipped ROM on your device, just flash the boot image using the instructions below and you're done!

APPLY THIS AT YOUR OWN RISK!

Before download, you need to check your device 'about' screen to determine which superboot version you need.

  • Superboot for OUK_P743TV1.0.0B05 - DOWNLOAD (Mediafire Pro) - MD5: 24866507d5b2819a2369f69a5783882d
The superboot image is also 'insecure', allowing you to use 'adb remount' as well as having full ADB root access to your device.

How to use Superboot - Windows, Linux and OSX

- Download the Superboot zip file above and extract to a directory
- Ensure USB debugging is enabled in 'Settings -> Development' and that, if on Windows, you have installed any requested drivers
- WINDOWS - double click 'install-superboot-windows.bat'
- MAC - Open a terminal window to the directory containing the files, and type 'chmod +x install-superboot-mac.sh' followed by './install-superboot-mac.sh'
- LINUX - Open a terminal window to the directory containing the files, and type 'chmod +x install-superboot-linux.sh' followed by 'sudo ./install-superboot-linux.sh'

That's it! Enjoy! ;)

P

  • 9

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#2
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
Great work Paul again!

  • 0

#3
MoreLazers

MoreLazers

    Regular

  • Members
  • PipPip
  • 55 posts
When I try to do this and recovery I get "< waiting for device >" both times.

Debug mode is on.

  • 0

#4
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,369 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Check your device manager for missing drivers.

If your device is showing as a 'USB drive', eject it.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#5
MoreLazers

MoreLazers

    Regular

  • Members
  • PipPip
  • 55 posts
Showing up as an "AndroidPhone" under Other devices in Device Manager, will not let me install the Google USB driver from Android SDK, and when I turn USB storage off I'm still seeing "Removable Disk F:\", even though it tells me to insert something when I try to explore it.

  • 0

#6
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,369 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien

Showing up as an "AndroidPhone" under Other devices in Device Manager, will not let me install the Google USB driver from Android SDK, and when I turn USB storage off I'm still seeing "Removable Disk F:\", even though it tells me to insert something when I try to explore it.

Can you right-click and eject it?

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#7
MoreLazers

MoreLazers

    Regular

  • Members
  • PipPip
  • 55 posts

Can you right-click and eject it?

P


Same result, I've also removed the SD card from the phone.

EDIT: Sorted it, managed to find the correct USB drivers after a few useless ones, Superboot and Recovery both installed now.

Edited by MoreLazers, 09 August 2011 - 04:11 PM.

  • 1

#8
lordjubblydave

lordjubblydave

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Essex
  • Devices:M8-MotoG-GPad_8.3
  • Twitter:@jubblydave
Anyone got any ideas, i am not great with the Terminal, USB Debugging is enabled
Here is my Terminal

lordjubblydave@laptop:~$ chmod +x install-superboot-linux.sh
lordjubblydave@laptop:~$ ./install-superboot-linux.sh
./install-superboot-linux.sh: line 1: chmox: command not found
* daemon not running. starting it now *
* daemon started successfully *
error: device not found
< waiting for device >

  • 0

#9
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,369 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
The ADB connection is only exposed after the 'USB driver disk' is ejected, so you'll need to do that (not sure how that's done from the Linux command line?)

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#10
philmein

philmein

    Diehard

  • MoDaCo Silver
  • PipPipPipPip
  • 330 posts
  • Gender:Male
  • Location:Proud Lancastrian
  • Interests:E-Cigs
    expensive hobby
  • Devices:Orange Monte Carlo zte blade

Same result, I've also removed the SD card from the phone.

EDIT: Sorted it, managed to find the correct USB drivers after a few useless ones, Superboot and Recovery both installed now.



any chance of a link to the drivers
waiting for device here too windows7



  • 0

#11
sej7278

sej7278

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,647 posts
  • Gender:Male
  • Devices:ZTE Blade

Anyone got any ideas, i am not great with the Terminal, USB Debugging is enabled
Here is my Terminal

lordjubblydave@laptop:~$ chmod +x install-superboot-linux.sh
lordjubblydave@laptop:~$ ./install-superboot-linux.sh
./install-superboot-linux.sh: line 1: chmox: command not found
* daemon not running. starting it now *
* daemon started successfully *
error: device not found
< waiting for device >


it should be chmod not chmox:

chmod +x adb-linux
chmod +x fastboot-linux
./adb-linux reboot bootloader
./fastboot-linux flash boot boot.superboot.img
./fastboot-linux reboot


same goes for the clockworkmod installer. the r2 zip says "chmox" instead of "chmod" and secondly, the fastboot command is missing the "flash" bit so it should be:

chmod +x adb-linux
chmod +x fastboot-linux
./adb-linux reboot bootloader
./fastboot-linux flash recovery clockworkmod.img
./fastboot-linux reboot


note that when you reboot into the bootloader its just the green android logo, its not crashed, its just sitting there waiting for a command.

Edited by sej7278, 09 August 2011 - 05:11 PM.

  • 0

#12
lordjubblydave

lordjubblydave

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Essex
  • Devices:M8-MotoG-GPad_8.3
  • Twitter:@jubblydave

it should be chmod not chmox:

chmod +x adb-linux
chmod +x fastboot-linux
./adb-linux reboot bootloader
./fastboot-linux flash boot boot.superboot.img
./fastboot-linux reboot


same goes for the clockworkmod installer. the r2 zip says "chmox" instead of "chmod" and secondly, the fastboot command is missing the "flash" bit so it should be:

chmod +x adb-linux
chmod +x fastboot-linux
./adb-linux reboot bootloader
./fastboot-linux flash recovery clockworkmod.img
./fastboot-linux reboot


note that when you reboot into the bootloader its just the green android logo, its not crashed, its just sitting there waiting for a command.



Still no joy, i still get waiting for device :(


  • 0

#13
sej7278

sej7278

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,647 posts
  • Gender:Male
  • Devices:ZTE Blade

Still no joy, i still get waiting for device :(


i got that (on the blade) when i did it a couple of times although i'm not sure why.

did you try running it as root, using either "su -" or "sudo -s", then running the adb and fastboot commands.

does adb devices list anything like this (obviously for skate not blade):

./adb-linux devices
List of devices attached 
Blade-CM7	device

Edited by sej7278, 09 August 2011 - 05:50 PM.

  • 0

#14
lordjubblydave

lordjubblydave

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Essex
  • Devices:M8-MotoG-GPad_8.3
  • Twitter:@jubblydave
OK Here is what i did it worked

sudo chmod +x fastboot-linux
sudo ./adb-linux reboot bootloader


adb devices
adb reboot
adb reboot bootloader
./fastboot-linux flash boot boot.superboot.img
./fastboot-linux reboot


Running Ubuntu 11.04

Hope it helps someone, Thanks Sej

  • 0

#15
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,369 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
I spotted the chmod typo, uploading fix now but it *shouldn't* affect most people.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#16
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,369 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Typo fixed version uploaded.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#17
sej7278

sej7278

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,647 posts
  • Gender:Male
  • Devices:ZTE Blade

I spotted the chmod typo, uploading fix now but it *shouldn't* affect most people.


maybe add that it needs to be run as root (su/sudo) in the instructions?

also note the problems are in the recovery too not just superboot.

nice fast, work by the way paul, i forgot to say earlier (oh and i managed to compile cwm 4.0.1.4 for blade btw).

Edited by sej7278, 09 August 2011 - 06:20 PM.

  • 0

#18
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,369 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
I fixed it in the recovery script too.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#19
todoleo

todoleo

    Geek at heart, Tech Support Monkey and feeder of Wobbles (@fatol

  • Moderator Team
  • PipPipPip
  • 225 posts
  • Gender:Male
  • Devices:Galaxy Nexus / Lumia 710
  • Twitter:@Todoleo

When I try to do this and recovery I get "< waiting for device >" both times.

Debug mode is on.


Same here!

  • 0
Twitter: @Todoleo
Identi.ca: @Todoleo

Blog: Todoleo.com

#20
sej7278

sej7278

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,647 posts
  • Gender:Male
  • Devices:ZTE Blade

I fixed it in the recovery script too.


not wanting to be mr.whiney thread hijacker, but r3 still says "./fastboot-linux recovery clockworkmod.img" so is still missing the "flash" bit :D

todoleo: did you try as root?

Edited by sej7278, 09 August 2011 - 08:08 PM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users