Jump to content


Photo

Radio crashing on gr6

- - - - -

  • Please log in to reply
13 replies to this topic

#1
vrowdy

vrowdy

    Regular

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Devices:Xperia S, Lumia 800
Hello all,

I'm unfortunately again encountering the crashing radio problem on Gr6 again. Sometimes when you pick up the handset, the signal bars are white and there are no arrows or only one blinking arrow underneath the G or 3G/H icon.
Then the radio has crashed and you cannot call or be called at all.
Ypu need to reboot the phone, after which battery levels have dropped by 25-50%.

I've experienced this with stock 20L, gr5 and gr6.
I'm using bb 0725 from 20L. With gr6, I used the stock kernel option.
I dont't have this issue at all with CM 7.1 (nor did I have it on stock Froyo).

In the 20O release notes I saw a lot of fixes regardng the radio/data so I had hoped this would have been fixed.

My question is, is it possible this has been fixed in stock 20O but is still present in gr6 since gr6 uses kernels from 20L?
Or are there any more fixes or causes known to this problem today?

I really want to use stock-based instead of CM... :)

  • 0

#2
rmein

rmein

    Regular

  • Members
  • PipPip
  • 58 posts
  • Devices:LG Optimus 2X

Hello all,

I'm unfortunately again encountering the crashing radio problem on Gr6 again. Sometimes when you pick up the handset, the signal bars are white and there are no arrows or only one blinking arrow underneath the G or 3G/H icon.
Then the radio has crashed and you cannot call or be called at all.
Ypu need to reboot the phone, after which battery levels have dropped by 25-50%.

I've experienced this with stock 20L, gr5 and gr6.
I'm using bb 0725 from 20L. With gr6, I used the stock kernel option.
I dont't have this issue at all with CM 7.1 (nor did I have it on stock Froyo).

In the 20O release notes I saw a lot of fixes regardng the radio/data so I had hoped this would have been fixed.

My question is, is it possible this has been fixed in stock 20O but is still present in gr6 since gr6 uses kernels from 20L?
Or are there any more fixes or causes known to this problem today?

I really want to use stock-based instead of CM... :)


  • 0

#3
rmein

rmein

    Regular

  • Members
  • PipPip
  • 58 posts
  • Devices:LG Optimus 2X
I also have this problem with stock gingerbread roms. It always happens when I use a particular lift, so I think it must be caused by a sudden loss of signal.
I have tried a variety of bb and roms, but haven't found a reliable combination yet.

  • 0

#4
KolsyratVatten

KolsyratVatten

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:LG Optimus 2x
+1

This is the reason I switched to CM7.

  • 0

#5
rmein

rmein

    Regular

  • Members
  • PipPip
  • 58 posts
  • Devices:LG Optimus 2X

+1

This is the reason I switched to CM7.


Unfortunately I suffered from SOD on CM7 - when charging and also sometimes with Bluetooth connections. Came back to stock roms because of that. I'm almost tempted to go back to Fr19 with the Italian v10d baseband - it was by far the most stable rom I've had on the phone.

  • 0

#6
MrOtacon

MrOtacon

    Newbie

  • Members
  • Pip
  • 22 posts
I've been having the same problem with the radio crashing.
I'm using: Core + Vanilla GR6.
Baseband is v20O.
I know the thread mentions v20L as being for this rom. but the Baseband thread also doesn't contain v20O.
I also know that the actual baseband version appears the same with 20L and 20O - but the RILs are 100% different so Im not sure the basebands are the same. Don't know why v20O isn't in the baseband thread.

Two nights in a row. plus when the radio does die, it seems to have the fast dormancy issue, which causes massive battery drain.
If you restart your phone, you will have half the battery power you had before restarting

I did the following yesterday, and havent had a crash yet - will report as soon as it does though (if it does :D)
  • Rebooted to Recovery
  • Converted to EXT4 with UniversalEXT4 Converter
  • Cleared Cache
  • Cleared Dalvik Cache
  • Installed FPS 0.3a Kernel
  • Installed Swap Enabler 0.1 (for FPS)
  • Cleared Cache
  • Cleared Dalvik Cache
  • Rebooted
First boot took a couple of minutes, a reboot was considerably quicker.
So far - No crash like I said.


Maybe a different kernel will help you.

Edited by MrOtacon, 23 January 2012 - 11:35 AM.

  • 0

#7
vrowdy

vrowdy

    Regular

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Devices:Xperia S, Lumia 800
Thanks, I also started this discussion with gr5 and just wanted to know if there were any new insights. I hope stock ICS does fix IT then hand perhaps Paul can ask huis LG contact about this. IT is really annoying.

  • 0

#8
MrOtacon

MrOtacon

    Newbie

  • Members
  • Pip
  • 22 posts

Thanks, I also started this discussion with gr5 and just wanted to know if there were any new insights. I hope stock ICS does fix IT then hand perhaps Paul can ask huis LG contact about this. IT is really annoying.


Actually in the downtime between roms, I've been using Django Manouche, which is now up to version 0.6. Its pretty stable, and the small bugs that exist can be worked around.
I too am holding out for Stock ICS. Hopefully LG will do a better job. It is blazing fast compared to GB

  • 0

#9
vrowdy

vrowdy

    Regular

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Devices:Xperia S, Lumia 800
Just to add:

I also tried Gueste's new Hybrid v3.0 which is CM7.2RC0 with many stock apps and stock drivers.
In this version, the radio also crashed on me the same day.
So I went back to normal CM7.2RC0 and it's all fine again. So this crashing radio thing is really something in some LG driver.

I really hope some-one here can do anything with this info or Paul can relay this info to his LG contact, because this bug makes stock firmware or stock-based firmware completely unusable to me (and I'm very glad there is CM7 and I know how to install it, otherwise I would have an unusable phone, stuck on v20L/M/O with crashing radio all day).

  • 0

#10
Deus_ex11

Deus_ex11

    Regular

  • Members
  • PipPip
  • 81 posts
I have been using V20l BB + V20l ril for a week now and I have not noticed any problems with it. If you are using getril, the one I used is V20l, Italy. The other one on there gave me problems.

  • 0

#11
clivec

clivec

    Enthusiast

  • MoDaCo Silver
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:The Matrix..
  • Interests:Phones, Amateur Radio, General Techy stuff.
  • Devices:HTC one X, Nexus S
  • Twitter:@clivectmob
Best way to stop SOD on charging is to tick "stay awake" in settings>applications>developer ops> keeps device from sleeping while plugged in, never had it since.

  • 0
There is no spoon...

#12
lap33733

lap33733

    Newbie

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Devices:lg optimus 2x

I have been using V20l BB + V20l ril for a week now and I have not noticed any problems with it. If you are using getril, the one I used is V20l, Italy. The other one on there gave me problems.

Same here

  • 0

#13
vrowdy

vrowdy

    Regular

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Devices:Xperia S, Lumia 800
I'm also seeing 20Q so, perhaps LG has finally fixed the problem... Otherwise I will try the RILs you mentioned.

  • 0

#14
Involver

Involver

    Regular

  • MoDaCo Silver
  • PipPip
  • 90 posts
  • Gender:Male
  • Devices:LG O2x / HTC Hero / Asus TF101
Check out my other posts but basically I'm very happy using this ROM and this baseband combo!

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users