Jump to content


Photo

screen goes black while calling

- - - - -

  • Please log in to reply
18 replies to this topic

#1
bartvdv

bartvdv

    Newbie

  • Members
  • Pip
  • 31 posts
As I make a phone call the screen goes black and none of the keys will work until the call is completed, which is pretty annoying if no one picks up or I get the answering service and have to press a 1 or # to complete the call ... I can't ..

the only option so far is remove the battery and start over ...

tried some other roms like cyanogenmod 7 and atOmic 4.0 ... and the ZTE stock rom but the problem remains

it seems the ZTE default "in call" screen is the problem and is not updated by installing a new rom version ?

Anybody else having this problem ? and how to fix ..... ?

  • 0

#2
PedroVader

PedroVader

    Addict

  • Members
  • PipPipPipPipPip
  • 518 posts
Don't want you to be flamed by less patient members, but this has been covered ad infinitum.

Run a search for proximity sensor, or have a browse through the threads, you'll find it ;-)

Sent from my ZTE Skate using Tapatalk

  • 0
<a href="http://giffgaff.com/...ate/anakin1138" target="_blank"><img src="http://giffgaff.com/.../07_468x60.png" width="468" height="60" alt="Get a free giffgaff Sim" /></a>

#3
bartvdv

bartvdv

    Newbie

  • Members
  • Pip
  • 31 posts
ad infinitum ? proximity and call logic missing or is it, it senses the one I want to call is in close proximity so I better speak a little louder ..... any how I have a look ... thanks

  • 0

#4
PedroVader

PedroVader

    Addict

  • Members
  • PipPipPipPipPip
  • 518 posts
Its there, but its been a problem since release. It was duff in the stock from from orange.

Probably the only real shortcoming of the phone aside from the weedy arm6 processor.

Sent from my ZTE Skate using Tapatalk

  • 0
<a href="http://giffgaff.com/...ate/anakin1138" target="_blank"><img src="http://giffgaff.com/.../07_468x60.png" width="468" height="60" alt="Get a free giffgaff Sim" /></a>

#5
bartvdv

bartvdv

    Newbie

  • Members
  • Pip
  • 31 posts

Its there, but its been a problem since release. It was duff in the stock from from orange.

Probably the only real shortcoming of the phone aside from the weedy arm6 processor.

Sent from my ZTE Skate using Tapatalk


for all other android noobs ... like me

http://blog.brightpo...ty-sensor-patch

and fixed ...
direct download to your phone use next link

http://blog.brightpo...Clib_signed.apk

Edited by bartvdv, 28 January 2012 - 05:41 PM.

  • 0

#6
tillaz

tillaz

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 5,850 posts
  • Gender:Male
  • Location:R* North
  • Interests:ET Life
  • Devices:Nexus 4
there's an app in atomic to fix this, its also in the FAQ.

  • 0

#7
bartvdv

bartvdv

    Newbie

  • Members
  • Pip
  • 31 posts

there's an app in atomic to fix this, its also in the FAQ.


can't find zte skate FAQ ... anyhow i am back to stock mode, wifi was slow ( 10% speed ) in both other roms, and the light sensor didn't work in cyanogenmod 7 and since i am in bed most of the time and using it as a tablet I had to keep adjusting the brightness which is automatically done in the stock rom.

perhaps a link to the FAQ and a link to the modaco calibration apk will help

  • 0

#8
tilal6991

tilal6991

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 3,781 posts
  • Gender:Male
  • Devices:ZTE Skate, Huawei U8150
its pinned.

  • 0
If you like my work or if I helped, click the Plus button.

#9
AbrantesPT

AbrantesPT

    Regular

  • Members
  • PipPip
  • 56 posts
  • Devices:ZTE SKATE

its pinned.


Im using IceArmour Rom

My proximity sensor dont works, only with stock rom.

And my light sensor dont works auto :S

Can anyone help with solutions? thanks in advance





  • 0

#10
avenn

avenn

    Newbie

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Devices:ZTE Skate

  • 0

#11
JetKun

JetKun

    Diehard

  • Members
  • PipPipPipPip
  • 439 posts
  • Gender:Male
  • Location:stephen fry
  • Devices:ZTE Skate (OMC)
  • Twitter:@stephenfry
What's really strange is that my proximity sensor worked straight out of the box, Orange Monte Carlo and all

  • 0

#12
metal.mickey

metal.mickey

    Enthusiast

  • Members
  • PipPipPip
  • 205 posts
  • Gender:Male
  • Devices:Newman K1a
There inst a definitive fix.

some of the pinned threads offer a patch or a proximity sensor recalibration.

if neither of those work, you can select "Power button ends call" in the Acessibility menu. But if you need to "press 1 for eggs, press 2 for bacon" then youre screwed.

im running an app called KeepScreen which prevents the screen from dimming full stop so proximity sensor is no longer an issue.

MM


  • 0

#13
FatLadZ

FatLadZ

    Regular

  • Members
  • PipPip
  • 137 posts
  • Gender:Male
  • Devices:Samsung Galaxy SII I9100
  • Twitter:@#FatLadZ
ring oramnge tell them they will get you a new handset out :)

  • 0

#14
hso

hso

    Regular

  • Members
  • PipPip
  • 87 posts
  • Devices:zte skate

As I make a phone call the screen goes black and none of the keys will work until the call is completed, which is pretty annoying if no one picks up or I get the answering service and have to press a 1 or # to complete the call ... I can't ..

the only option so far is remove the battery and start over ...

tried some other roms like cyanogenmod 7 and atOmic 4.0 ... and the ZTE stock rom but the problem remains

it seems the ZTE default "in call" screen is the problem and is not updated by installing a new rom version ?

Anybody else having this problem ? and how to fix ..... ?


  • 0

#15
hso

hso

    Regular

  • Members
  • PipPip
  • 87 posts
  • Devices:zte skate

As I make a phone call the screen goes black and none of the keys will work until the call is completed, which is pretty annoying if no one picks up or I get the answering service and have to press a 1 or # to complete the call ... I can't ..

the only option so far is remove the battery and start over ...

tried some other roms like cyanogenmod 7 and atOmic 4.0 ... and the ZTE stock rom but the problem remains

it seems the ZTE default "in call" screen is the problem and is not updated by installing a new rom version ?

Anybody else having this problem ? and how to fix ..... ?



hello To solve black screen you have to calibrate your proximity sensor. Dial *983*0# go to sensors and click calibrate. you may want to plub charger in so screen stays lit thats what i did and its perfect now

  • 0

#16
FatLadZ

FatLadZ

    Regular

  • Members
  • PipPip
  • 137 posts
  • Gender:Male
  • Devices:Samsung Galaxy SII I9100
  • Twitter:@#FatLadZ
yep but some dont fix and just say "stop" next to them

My wifes wouldnt work right so i rang orange and they fobbed me off left rioght and center so i told them that the screen stays black adn the speaker stopped working.

immediatly they agreed to a replace,ment handset.
Looks like you need to lie a little to get satisfaction from orange.

But having said that i called 7pm saturday night and the phone came sunday morning.

Brilliant customer services :)

  • 0

#17
PejotA

PejotA

    Regular

  • Members
  • PipPip
  • 117 posts
  • Gender:Male
  • Location:Osasco - S.P Brasil
  • Devices:Zte Skate V960 Ice Armor
  • Twitter:@Pajorve
We are having the same problem .... did the zip flash already cited (Blade) but even then it didn't work ...

I have to remove the battery to qur the Skate running again again after a call ...

I hope a solution very soon ... I'm using Ice 2 Armor

Posted ImagePosted Image

  • 0

#18
NorthernNoel

NorthernNoel

    Newbie

  • Members
  • Pip
  • 44 posts

We are having the same problem .... did the zip flash already cited (Blade) but even then it didn't work ...

I have to remove the battery to qur the Skate running again again after a call ...

I hope a solution very soon ... I'm using Ice 2 Armor

Posted ImagePosted Image


I've kind of got it working by manually editing the values using root explorer. Run the calibration tool in settings/device settings and it creates a file called prox_data.txt in data/misc. The values that you can play with are the prox_theshold_hi and low. I've found that if the hi one is above 1000 it seems to keep the screen on all the time (which is what mine set it as when running the calibration tool). Mine are currently at 952 and 949 and that works for me today. You'll need to reboot after editing the file.

No doubt I haven't got it perfect yet but at least I know which area to look.

  • 0

#19
12speed

12speed

    Newbie

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Location:Nottingham ,England
  • Devices:Galaxy S2
Hi guys i found this info and it worked a treat for my sons monte carlo screen going black during calls.

The calibration of the ear sensor somehow breaks.

The only way to end the call is to take the battery out if you're not lucky enough to enable a press of the power
button to drop a call.

However, here's a fix:

"Type this into dialer -

*983*0#

Go to

Sensors - to do that scroll down the list

and while not covering the sensor, click Calib - short for calibrate

Then Click OK

hope i have been of help

  • 0
Life is short enjoy it




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users