Jump to content


Photo

ClockworkMod Recovery for Huawei U8815/Ascend G 300


  • Please log in to reply
266 replies to this topic

#1
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404
Here we go, this is *MY* customized build of Koush's ClockworkMod Recovery v3.0.1.5 for the Huawei U8815/Ascend G 300.

I have tested it as much as I can, but I'm always open to any more constructive feedback.

[RECOVERY] : ClockworkMod Recovery for Huawei U8815/Ascend G 300

Note this is a Customized version, that will handle the 2 extra partitions Huawei use this means backups made with this version will only be partly compatible with vanilla versions of Clockwork Mod Recovery.

The Device Config to build Clockwork Mod Recovery as part of CyanogenMod can be found on my GitHub.

And the source code for this fork of ClockWork Mod Recovery can also be found on my GitHub.

  • 7

#2
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
USB doesn't mount in the one you posted on Twitter mate is this the same one or updated?

  • 0

#3
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404
Well... the USB mounting should work now, but.. erm, I uploaded the wrong file...

if you want to download it again now, it will work :) or it did for me at any rate :)

  • 0

#4
dt_matthews

dt_matthews

    Diehard

  • Members
  • PipPipPipPip
  • 335 posts
hi dudes,

I flashed the custom cwm img successfully but when I go in to it and hit any of the menus, I just get the cwm logo, and have to hit the power button to get back to the main cwm menu.

Any advice please as I really want to flash your rom seb? :)

Thanks for all your work as ever.

  • 0

#5
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
Are you pressing power button to select?! Cos that doesn't work you use the home button.

  • 0

#6
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
can you post what buttons do what please Frankish for anyone coming here as I haven't flashed it just yet

  • 0

#7
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
Errr...basically just home to select an option. Volume buttons go up and down menu list and back goes...back. :)

  • 1

#8
dt_matthews

dt_matthews

    Diehard

  • Members
  • PipPipPipPip
  • 335 posts

Are you pressing power button to select?! Cos that doesn't work you use the home button.

yes, selecting (home button) any menu brings up the cwm logo, and only hitting power can get me back to the main menu, any thoughts?

  • 0

#9
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
Clueless i'm as confused as you are...

  • 0

#10
dt_matthews

dt_matthews

    Diehard

  • Members
  • PipPipPipPip
  • 335 posts

yes, selecting (home button) any menu brings up the cwm logo, and only hitting power can get me back to the main menu, any thoughts?

kill me now. fml - what a muppet i am. working fine [dan punches himself in the face] thanks frankish ;)

  • 0

#11
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,536 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
We're you still using power to select you fool?!

  • 0

#12
FlatPackPete

FlatPackPete

    Regular

  • Members
  • PipPip
  • 118 posts
  • Gender:Male
  • Location:Liverpool
  • Devices:Nexus 7, Nexus 4, Note 2
It works great so farPosted Image, the only thing I have noticed is the progress bar does not move while backing up the system to the SD card.

  • 0

#13
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404
sessh.. it says 'Use vol keys to highlight and home to select.' at the top :)


the settings & power button toggles the menu on/off, it lets you see the log of your actions, if you install a rom or something you can see the full screen that way rather than the X number of lines at the bottom.

  • 0

#14
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
I am getting E: signature verification failed when trying to install the update zip. Any ideas or does it need to be unzipped to an image file and put on the root of the SD card.?

  • 0

#15
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
anyone? I did a Google search about install custom image and most that state install custom image are downloading the image straight from cwm so it's a supported recovery where as this is not.
I am rooted with Paul's instructions. Any help appreciated.

  • 0

#16
mramonks

mramonks

    Newbie

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Devices:HTC Sensation/ Huawei G300
  • Twitter:@mramonks

anyone? I did a Google search about install custom image and most that state install custom image are downloading the image straight from cwm so it's a supported recovery where as this is not.
I am rooted with Paul's instructions. Any help appreciated.



You need to flash the recovery through adb as written in the instruction. You can't flash it through the stock recovery

  • 1

#17
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
thanks for that. Time to download adb to my PC.

  • 0

#18
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
Thanks again mramonks. I managed to get it installed. My first attempt at adb and it was a bit scary to be honest.
Also thanks for the concise instructions sebastian404, didnt make much sense until I got stuck in. Makes perfect sense when you have the tools on the screen in front of you. Thank you very much.

  • 0

#19
feckineejit

feckineejit

    Addict

  • Members
  • PipPipPipPipPip
  • 578 posts
  • Gender:Male
  • Location:Derry/Ireland
  • Devices:ZTE BLADE, Huawei G300
I think i've got the clockwork installed now, when i go into it, it says CWM -based recovery v4.0.1.5 but when i try to accept any of the options like backup etc, it just sits on the picture of the hat, if i go down the list and click an option etc: "install zip from sdcard" it just pops up the hat and sits there doesnt go into sdcard, if i push power button it goes back to the options. i need to pull battery as well for "reboot system now" as the power button does not restart it. anyone know what ive done wrong

Edited by feckineejit, 26 April 2012 - 10:39 PM.

  • 0
Posted Image

#20
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
Its a guess but I would boot the rom normally and open rom manager to ensure that superuser permission is accepted.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users